Edgy RC AMD 64 Desktop installer crashed

Bug #67452 reported by qiv on 2006-10-21
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I just tried to install Edgy RC on my AMD 64, but it crashed when trying to install grub on hd0, where already a Grub is installed.

If you need any further information or know a workaround, please contact me at <email address hidden>.

Kind regards,
Philipp Germann

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 166, in ?
    main()
  File "/usr/bin/ubiquity", line 161, in main
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 57, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 305, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 856, in process_step
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/gtkui.py", line 628, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s\n%s" %
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 1404, in ?
    install.run()
  File "/usr/share/ubiquity/install.py", line 385, in run
    self.configure_bootloader()
  File "/usr/share/ubiquity/install.py", line 1163, in configure_bootloader
    raise InstallStepError(
InstallStepError: GrubInstaller failed with code 1

qiv (phg-gmx) wrote :
qiv (phg-gmx) wrote :
Caroline Ford (secretlondon) wrote :

Could you attach /var/log/installer/syslog as well? Thanks.

Changed in ubiquity:
status: Unconfirmed → Needs Info
qiv (phg-gmx) wrote :

When I boot from the CD and do the installation again it does not create a /var/log/installer/syslog, there is just a file called version in this directory. And on the partition I used for the installation there is no /var/log/installer directory at all.

qiv (phg-gmx) wrote :

Maybe grub has a problem with my hd1, my second S-ATA-HDD, where I installed Edgy on partition /dev/sdb4. When I do > find /var/log/syslog in the grub command line of the old grub installation, it just finds this file on various partitions on hd0, none on hd1. I can just change > root (hd1, 0) all other partitions do not work. Maybe there is something wrong with the configuration of my second disk - gparted of the edgy beta could not find it as well, but fdisk and the installation routine could ...

qiv (phg-gmx) wrote :

I was able to install Edgy without problems on the first harddrive. But if someone needs any further information or testings I still have the second drive ;)

Dhonn Lushine (dhonn) wrote :

I have a "dmesg" of this problem that might be related. I have tried to install edgy rc many times on my amdx2 with the 32bit cd and got some errors regarding the package.

Colin Watson (cjwatson) wrote :

/var/log/installer/syslog isn't needed on Edgy. Cancelling needs-info.

Changed in ubiquity:
status: Needs Info → Confirmed
Przemek K. (azrael) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The version of Ubuntu that you were using has reached its End Of Life. Please test the latest Ubuntu version (9.10) and report a new bug if necessary.
https://help.ubuntu.com/community/ReportingBugs

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers