Edgy doesn't like KVMs, uses wrong UUIDs and tries to boot from the wrong driv

Bug #66256 reported by Fridtjof Busse on 2006-10-15
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

The CD boots, but after selecting an option, the installer hangs, the last displayed infos are:
ata_piix 0000:00:1f.2: invalid MAP value 0 (I also get this with the working 6.06 install, so this shouldn't be the cause of the hang)
hub 3-2:1.0 hub_port_status failed (err = -71)
hub 3-2.3:1.0 hub_port_status failed (err = -71)
hub 3-2.3:1.0 hub_port_status failed (err = -71)
ACPI: getting cpuindex for cpiid 0x1
Starting system lo daemon: syslogd, klogd

The last two lines only appear after quite some time (at least two minutes). Maybe there would appear more, I only waited 15 minutes, but at that time not even the numlock-LED reacted.

6.06 runs currently fine on the Intel MAC mini, I only had to replace the grub-package due to the gate A20 bug.

OK, after connecting the keyboard directly to the MAC, 6.10 boots. I'm using a ATEN KVM-switch, which worked fine with 6.06. With 6.10 it obviously doesn't.
Installation works fine, but booting the installed kernel fails again, the last thing I see are

ACPI: Getting cpuindex for acpiid 0x1
ata_piix 0000:00:1f.2: invalid MAP value 0

That's it, even in single user mode I don't get very far (hangs somewhere around USB).

OK, more info on this bug, the real problem is far more subtile.
Grub tries to boot from the wrong partition, but doesn't give the error I'm used to, might be due to the initram.

menu.lst contains /dev/hda1 as the boot-device, but /dev/hda is the CD-ROM. After changing this, I noticed that "/" could not get mounted correctly.
The UUID in /etc/fstab was "UUID=AD00-9F80". Completly incorrect syntax and not even remotly the UUID of "/".
Interestingly enough, menu.lst contained this UUID as well:

kopt=root=UUID=AD00-9F80 ro

but tried to use this for booting

kopt_2_6=root=/dev/hda1 ro (which was used and would've worked, if /dev/hda would be the HD)

So this bugs actually describes three problems: Edgy doesn't like KVMs, uses wrong UUIDs and tries to boot from the wrong drive. :)

Martin Kossick (hacktick) wrote :

Does this problem still occur in newer versions?
Edgy is not supported any more.

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in ubiquity:
status: New → Incomplete

Unfortunatly I dont't own the hardware any longer, thus I cannot verify if this bug has been fixed.

Magnus S (magnuss) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubiquity:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers