Ubuntu

ubiquity crashed with DBusException in call_blocking() when the option "Install 3rd party software" is checked.

Reported by Alex on 2010-10-02
624
This bug affects 124 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Ubuntu Installer Team
Oneiric
High
Ubuntu Installer Team

Bug Description

Binary package hint: ubiquity

I was installing but the installer stopped where i can choose "Download updates while installing" etc.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: ubiquity 2.4.4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sat Oct 2 12:14:34 2010
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/4593/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with DBusException in call_blocking()
UserGroups:

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Alex (icidrop) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
tags: added: ubiquity-2.4.4
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Confirmed on Oneiric when the checkbox 'Install 3rd party software' is ticked.

For previous releases the problem might be different but apport keep marking new bugs as duplicate of this one.

Changed in ubiquity (Ubuntu Oneiric):
importance: Undecided → High
milestone: none → ubuntu-11.10-beta-1
summary: - ubiquity crashed with DBusException in call_blocking()
+ ubiquity crashed with DBusException in call_blocking() when the option
+ "Install 3rd party software" is checked.
Changed in ubiquity (Ubuntu Oneiric):
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
tags: added: oneiric
Erick Brunzell (lbsolost) wrote :

As reported in duplicate bug 834480 I had this appear while testing the i386-20110825 Lubuntu image after selecting "install this third party software" and clicking on continue. I had both checked the md5sum and also used the "check CD for defects" option before booting to the live desktop.

I restarted the installation w/o even rebooting and this time unchecked the "install this third party software" box and the installation completed successfully.

Perhaps unrelated but I'd also had a jockey-backend crash before starting the initial installation as reported in bug 831754.

florin (florin-arjocu) wrote :

Actually https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/834480 it's not really a duplicate as it's talking about a different version of Ubuntu. This bug report is for version 10.10, the other is for alpha Oneiric Ocelot (11.10). :)

I had the same bug with a nightly build. When I selected any of the checkboxes Third party software or Download updates while installing I could not install. I had to boot cd again and then start the installation without those checkboxes for the installer to work.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.18

---------------
ubiquity (2.7.18) oneiric; urgency=low

  * Properly handle unicode around the hostname (LP: #831309).
  * Properly handle unicode around the timezone entry box (LP: #831533).
  * Properly handle unicode in the question dialog (LP: #831419).
  * Disable the background setting code for beta 1.
  * Wait forever for jockey to shutdown (LP: #653571).
  * Bump indicators to v6 (LP: #819979).
 -- Evan Dandrea <email address hidden> Fri, 26 Aug 2011 17:56:37 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers