ubiquity KDE frontend does not start

Bug #646827 reported by Jonathan Riddell on 2010-09-24
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: ubiquity

The ubiquity KDE frontend does not start, backtrace suggests some permissions issues

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubiquity 2.4.1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Fri Sep 24 13:40:58 2010
LiveMediaBuild: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100924)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Jonathan Riddell (jr) wrote :
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-10.10
tags: added: kubuntu
Jonathan Riddell (jr) on 2010-09-24
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Evan (ev) on 2010-09-24
Changed in ubiquity (Ubuntu):
importance: Critical → Undecided
status: New → Fix Committed
importance: Undecided → Critical
katmen (katmen) wrote :

in today daily build from 25.september the frontend does not start, so I was unable to install kubuntu on my system

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.4.2

---------------
ubiquity (2.4.2) maverick; urgency=low

  [ Jonathon Riddell ]
  * gui/qt/stepLanguage.ui: nicer icons and better layout on
    language page (LP: #628808)

  [ Mario Limonciello ]
  * Set the LANG before running oem-config-remove.
  * Prevent a crash of debconf-communicate when removing oem-config.
    (LP: #641478)
  * Raise privileges when running the language page in only-installable
    mode. (LP: #647792)
  * Automatic update of included source packages: flash-kernel
    2.28ubuntu10.

  [ Evan Dandrea ]
  * Don't let Jockey's automatic driver installation failing cause the
    entire prepare page to fail.
  * Make sure $LANGUAGE gets set in the parallel debconf child process,
    so that we get translated descriptions (LP: #646109).
  * Set the effective UID in regain_privileges_save so we don't try to
    setgroups([]) as a regular user (LP: #646827).

  [ Didier Roche ]
  * depends on latest libindicator-dev for ABI change (LP: #637692, #647739)
 -- Mario Limonciello <email address hidden> Sat, 25 Sep 2010 18:24:06 -0500

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Peter Lemieux (seijisensei) wrote :

I tried installing this morning's daily build of Kubuntu 10.10 for the amd64, and this bug is still present. Was this fix ported to the 64-bit branch as well? At the top I only see the i386 architecture mentioned.

Peter Lemieux (seijisensei) wrote :

After reading a response to a comment I posted at ubuntuforums, I downloaded another copy of this CD about an hour ago. The installer bug seems to have been fixed.

Jonathan Riddell (jr) wrote :

thanks for testing Peter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers