Messages from apt in install_progress_text are not localised

Bug #644736 reported by AJenbo on 2010-09-21
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
apt (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Colin Watson
Quantal
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

The following messages appear during installation and are not translatable:

 * "Installing..."
 * "Retrieving file x of y"
 * "Retrieving file x of y (zs remaining)"

Related branches

Milo Casagrande (milo) wrote :

Those strings can be found in the debian-installer template:

https://translations.edge.launchpad.net/ubuntu/maverick/+source/debian-installer

To see those strings as translated you should work on the upstream translation of debian-installer:
https://wiki.ubuntu.com/Translations/Upstream/Debian/DebianInstaller

MArking as invalid.

Changed in ubuntu-translations:
status: New → Invalid
Changed in ubiquity (Ubuntu):
status: New → Invalid
AJenbo (ajenbo) wrote :

A search for "copying" in both packages only turns up "Copying partition...".
The Danish translation has been 100% done for a few weeks now but the text still appears as English in the daily iso.

Milo Casagrande (milo) wrote :

The "Copying file..." could be an issue. That string should be in the ubiquity template, if you have done the translation of that string a long ago (more than a year?), it could be a problem, otherwise it could be just a matter of time to wait the translations export.

Can somebody else confirm that that string is still in English even if it has been translated for a while?

David Planella (dpm) wrote :

Could someone add a link to the translations that appear in either ubiquity or debian-installer and point out which ones are not in a template?

This would make it much easier to track whether translations are either not loaded, not updated, or missing in the template.

Thanks!

Changed in ubuntu-translations:
status: Invalid → Incomplete
Changed in ubiquity (Ubuntu):
status: Invalid → Incomplete
Milo Casagrande (milo) wrote :

The "Copying files" comes from ubiquity, not debian-installer:

http://goo.gl/exgd

AJenbo (ajenbo) wrote :

Arh tanks. This line has been translated in to danish since 2009-08-25.

AJenbo (ajenbo) wrote :

The latest translations that was done (2010-09-16) for Ubiquity appears in the ISO I tested, do this defiantly isn't a question of wating.

Other lines i notices that aren't translated in the UI:

"Ready when you are..."
"Retrieving files %s of %s"

AJenbo (ajenbo) wrote :

Went threw the installation process with a fine toothed come and founded that the following 11 status texts are not being translated.

"Installing..."
"Starting up the partitioner"
"Scanning disks..."
"Detecting file systems..."
"Formatting swap space in partition #5 of Virtual disk 1 (vda)..."
"Creating ext4 file system for / in partition #1 of Virtual disk 1 (vda)..."
"Calculating files to skip copying..."
"Copying files..."
"Ready when you are..."
"Retriving file x of y"
"Retriving file x of y (zs remaning)"

summary: - 3 lines i can't figure out how to translate
+ 11 lines that can't be translated
AJenbo (ajenbo) on 2010-09-22
description: updated

Most of the strings you quote come from the debian-installer: can you please check the status of the upstream debian-installer translation for your language?

Links should be in the wiki page I quoted you a couple of messages before:
https://wiki.ubuntu.com/Translations/Upstream/Debian/DebianInstaller

Thanks.

AJenbo (ajenbo) wrote :

They are translated and have been so for a while, both locally and upstream (I'm also the guy handling the upstream for debian)

David Planella (dpm) wrote :

Thanks AJenbo for the investigation and for the detailed list of untranslated strings.

It would be very useful to specify which of these strings are a) Translatable in the template but not loaded and b) Not present in any template. These are two different issues, and it would make solving the problem easier if they can be tracked separately.

Do you think you could find that out and update the bug description with your findings?

Thanks!

AJenbo (ajenbo) wrote :

Sure

AJenbo (ajenbo) on 2010-09-23
description: updated
AJenbo (ajenbo) on 2010-09-23
description: updated
AJenbo (ajenbo) on 2010-09-23
description: updated
David Planella (dpm) wrote :

Thanks for finding out the different types of problems.

I've now filed separate bugs for each issue, so that can be better tracked. They are bug 646106 and bug 646109. Feel free to subscribe to them and add any additional information.

description: updated
Changed in ubuntu-translations:
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in ubiquity (Ubuntu):
status: Incomplete → Confirmed
summary: - 11 lines that can't be translated
+ Untranslatable messages in the installer

Unmarking as a duplicate after a conversation with seb128 on #ubuntu-devel, who could also reproduce it.

It seems that the strings come from the apt-all.mo domain in the apt package, and are translated in the languages where this can be reproduced.

According to cjwatson: "the whole apt source package is supposed to be blacklisted from langpack stripping
 I think it's more likely that the locale isn't set up properly ... (could be wrong, it would just be my first hypothesis)"

Note that apt translations do not come from language packs, but from the package itself, since they have to be used in the installer, where language packs are not used (as they are not yet installed).

tags: added: iso-testing
AJenbo (ajenbo) wrote :

I belive they appear during the part where the lang pack are fetched and installed, if not they may be from when updates are being fetched and installed.

AJenbo (ajenbo) wrote :

How will testing this on the ISO help? The strings does not appear in any translation file so wount be translated, before a new pot is uploaded, even If the issue is fixed.

Sebastien Bacher (seb128) wrote :

I can confirm the issue on a french maverick desktop installation

AJenbo (ajenbo) wrote :

Just tested this with the final release. I didn't spot "Installing...", but the other is still there.

tags: removed: iso-testing
tags: added: iso-testing
Gabor Kelemen (kelemeng) wrote :

I just installed Natty, and I think I saw Installing... untranslated, but not the others.

AJenbo (ajenbo) wrote :

They appear during the download of updates and lang pack

Changed in apt (Ubuntu):
status: New → Confirmed
David Planella (dpm) wrote :

Related bug bug 985652 (probably a duplicate?)

In any case, could someone confirm which exact strings still appear untranslated?

It's not that the strings are untranslated, it's just the small terminal is not running in the user's locale. Therefore any strings outputed by e.g. apt-get update / install are all in English instead of the user's locale.

summary: - Untranslatable messages in the installer
+ Installer does not set locale in the embedded terminal, resulting in
+ "untranslated" strings visible to the user.
tags: added: i18n
Changed in ubiquity (Ubuntu Quantal):
importance: Undecided → Medium
Changed in apt (Ubuntu Quantal):
status: Confirmed → Invalid
Colin Watson (cjwatson) wrote :

Really? The embedded terminal just tails log files, as far as I can see, and probably doesn't work anyway at the moment given overlayfs. I'm fine with the text in the embedded terminal not being localised, since the main purpose of the log files is to be useful for bug reports. The screenshots I looked at in duplicate bugs are in install_progress_text, not in the embedded terminal hidden by the expander triangle.

Victor Zhou (victor.zhou) wrote :

yes, there are a lot of screen shot in this bug: https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1055406

Al 27/09/12 03:41, En/na Colin Watson ha escrit:
> Really? The embedded terminal just tails log files, as far as I can
> see, and probably doesn't work anyway at the moment given overlayfs.
> I'm fine with the text in the embedded terminal not being localised,
> since the main purpose of the log files is to be useful for bug reports.
> The screenshots I looked at in duplicate bugs are in
> install_progress_text, not in the embedded terminal hidden by the
> expander triangle.
>

As far as I can understand it, the original bug was about untranslated
strings in the UI, not those within the embedded terminal. I too don't
think it's too important to localize the terminal output in this case,
and that the focus should rather be to get the UI fully translatable.

I think the confusion might have come from the change of title in
comment #23. I'll change it back to the original.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

summary: - Installer does not set locale in the embedded terminal, resulting in
- "untranslated" strings visible to the user.
+ Untranslatable messages in the installer
Colin Watson (cjwatson) wrote :

David: Comment #23 was the comment that I was disagreeing with, yes :-)

I suspect that the problem is that most of ubiquity uses debconf translations, but apt relies on having the C library locale set correctly. We can only do this after we've generated the locale in the target system (and even then it will take some fiddling), but fortunately that's before most of our apt-related activity. I'll see if I can make this work.

summary: - Untranslatable messages in the installer
+ Messages from apt in install_progress_text are not localised
Changed in ubiquity (Ubuntu Quantal):
status: Confirmed → Triaged
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

In fact, my last comment was a little wrong too. A large chunk of apt-related activity currently takes place before we generate the locale in the target system. I think we'll need to arrange to generate the locale slightly earlier, and then copy the locale out so that we can use it easily.

Colin Watson (cjwatson) on 2012-09-30
Changed in ubiquity (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Colin Watson (cjwatson) on 2012-10-01
Changed in ubiquity (Ubuntu Quantal):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.12.8

---------------
ubiquity (2.12.8) quantal; urgency=low

  [ Colin Watson ]
  * Before starting to do anything with apt, generate the locale in the
    target system, copy it out, and start using it (LP: #644736).
  * Update translations from Launchpad.

  [ Stéphane Graber ]
  * Replace use of assert in install_misc by a check, revert and exception
    so that errors can be ignored by the caller, useful for langpacks.
    (LP: #898787)
 -- Colin Watson <email address hidden> Wed, 03 Oct 2012 09:11:16 +0100

Changed in ubiquity (Ubuntu Quantal):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2012-10-09
Changed in ubuntu-translations:
status: Triaged → Fix Released
Victor Zhou (victor.zhou) wrote :

verified OK in build 20121009 with choosing Simple Chinese as the installation language

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/644736

tags: added: localized-iso
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers