Ubuntu

Updates not downloaded during install when selected and internet is available

Reported by Scott Kitterman on 2010-09-10
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: ubiquity

Before installing, I ran sudo jockey-text -a in the live session and established wireless connectivity (checked it worked).

During install I checked that I wanted updates installed and the installer screen indicated I had internet connectivity.

After the install, there were still many updates available, but not installed.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Thu Sep 9 23:50:55 2010
EcryptfsInUse: Yes
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100909)
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Scott Kitterman (kitterman) wrote :
Mario Limonciello (superm1) wrote :

As I understand, the option for downloading updates while installing does just that - downloads them. They're stored in /var/cache/apt/archives then for when the user runs the update manager in the future.

Jonathan Riddell (jr) wrote :

possibly related, bug 628836 did not install restricted packages

tags: added: kubuntu
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-10.10
Scott Kitterman (kitterman) wrote :

No, I got the restricted drivers installed this time (because I had internet). I'll update the other bug to make it clear that's only about not installing off the installation media.

Scott Kitterman (kitterman) wrote :

If the design is to only download updates for later installation, then it's working correctly, I just made some incorrect assumptions. Perhaps the text could be clearer?

Scott Kitterman (kitterman) wrote :

Nevermind re #4. I was thinking of a different bug. I did get the drivers on this install.

Evan Dandrea (ev) wrote :

Scott, can you confirm that when this box is checked, the installed system has packages in /var/cache/apt/archives?

Scott Kitterman (kitterman) wrote :

I'll need to redo the install to check as I've done postinstall updates now.

Kristian Kißling (kkissling) wrote :

It seems as if only the language packages get installed (see pics attached)

Kristian Kißling (kkissling) wrote :
Jonathan Riddell (jr) wrote :

Confirming bug, I get this problem from the RC.

bug 652945 has my logs

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Jonathan Riddell (jr) wrote :

from bug 652945:

updates aren't installed when using ubiquity kde frontend. the updates box is ticked and I did have an internet connection. the restricted packages did get downloaded and installed. only restricted packages and language pack dependencies are in /var/cache/apt/archive

Jonathan Riddell (jr) wrote :

Contents of cache

jr@weeny:~$ ls /var/cache/apt/archives/
firefox_3.6.10+build1+nobinonly-0ubuntu3_i386.deb libmediastreamer0_3.3.2-2ubuntu2_i386.deb lock
firefox-branding_3.6.10+build1+nobinonly-0ubuntu3_i386.deb libofa0_0.9.3-3.1_i386.deb openoffice.org-help-en-gb_1%3a3.2.1-6ubuntu1_all.deb
flashplugin-installer_10.1.85.3ubuntu1_i386.deb liborc-0.4-0_0.4.6-1_i386.deb openoffice.org-help-en-us_1%3a3.2.1-6ubuntu1_all.deb
kde-l10n-engb_4%3a4.5.1-0ubuntu1_all.deb libortp8_3.3.2-2ubuntu2_i386.deb openoffice.org-hyphenation_0.6_all.deb
kopete-gcall_4%3a4.5.1-0ubuntu2_i386.deb libpostproc51_4%3a0.6-2ubuntu3_i386.deb openoffice.org-hyphenation-en-us_2.5-1ubuntu1_all.deb
kubuntu-restricted-addons_4_i386.deb libschroedinger-1.0-0_1.0.9.really-1build1_i386.deb openoffice.org-l10n-common_1%3a3.2.1-6ubuntu1_all.deb
libavcodec52_4%3a0.6-2ubuntu3_i386.deb libsrtp0_1.4.4~dfsg-6_i386.deb openoffice.org-l10n-en-gb_1%3a3.2.1-6ubuntu1_all.deb
libavformat52_4%3a0.6-2ubuntu3_i386.deb libstartup-notification0_0.10-1build1_i386.deb openoffice.org-l10n-en-za_1%3a3.2.1-6ubuntu1_all.deb
libavutil50_4%3a0.6-2ubuntu3_i386.deb libswscale0_4%3a0.6-2ubuntu3_i386.deb openoffice.org-thesaurus-en-au_2.1-5_all.deb
libdvdnav4_4.1.3-7_i386.deb libtunepimp5_0.5.3-7.3ubuntu2_i386.deb openoffice.org-thesaurus-en-us_1%3a3.2.1-2ubuntu1_all.deb
libdvdread4_4.1.3-10ubuntu2_i386.deb libtunepimp5-mp3_0.5.3-7.3ubuntu2_i386.deb partial
libfftw3-3_3.2.2-1_i386.deb libva1_1.0.1-3_i386.deb ubufox_0.9~rc2-0ubuntu5_all.deb
libgsm1_1.0.13-3_i386.deb libvpx0_0.9.2-1build1_i386.deb xul-ext-ubufox_0.9~rc2-0ubuntu5_all.deb
libk3b6-extracodecs_2.0.1-1ubuntu3_i386.deb libxcb-event1_0.3.6-1build1_i386.deb
libmad0_0.15.1b-4ubuntu2_i386.deb libxine1-ffmpeg_1.1.18.1-4ubuntu4_i386.deb

Lennie (lbesselink) wrote :

I'm not familair with the installer at all, but I had a look at /var/log/installer/syslog, maybe this has something to do with it:

Oct 2 20:22:49 ubuntu in-target: A error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://extras.ubuntu.com maverick Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192

Could that KEY be included with the installation ? Because I also get the same error after installation.

This is from a dutch mirror: http://nl.archive.ubuntu.com/ (very likely ubuntuarchive.bit.nl), I'm do not know if it is the same with all mirrors (I presume the mirror is up to date).

Kristian Kißling (kkissling) wrote :

You can make that message disappear if you install "ubuntu-extras-keyring" at least that was in Beta. Its due to the new "extras.ubuntu.com"-Repository but it should not be related to this update-problem.
See also: https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/645434

Evan Dandrea (ev) on 2010-10-04
summary: - Updates not installed when selected and internet is available
+ Updates not downloaded when selected and internet is available

To be clear, the updates will not be installed. This is by design. The check box for this option says "download updates", not "download and install".

Jonathan,

The contents of your apt cache lead be to believe that the functionality is in fact working. Was that /var/cache/apt from the target filesystem?

If anyone is still hitting this bug, please put set -x on the second line of /usr/share/ubiquity/scripts/update-apt-cache and make the following change to /usr/share/ubiquity/install.py:

=== modified file 'scripts/install.py'
--- scripts/install.py 2010-09-16 08:13:20 +0000
+++ scripts/install.py 2010-10-04 08:24:08 +0000
@@ -116,8 +116,7 @@
             # imagine. Have those spin until the lock is released.
             if self.db.get('ubiquity/download_updates') == 'true':
                 cmd = ['/usr/share/ubiquity/update-apt-cache']
- subprocess.Popen(cmd, stdin=subprocess.PIPE,
- stdout=subprocess.PIPE)
+ subprocess.Popen(cmd)
             try:
                 self.copy_all()
             except EnvironmentError, e:

Then run the install again, being sure to check the download updates box. When the install completes, attach /var/log/syslog and /var/log/installer/debug to this bug report.

Thanks!

Jonathan Riddell (jr) on 2010-10-09
summary: - Updates not downloaded when selected and internet is available
+ Updates not downloaded during install when selected and internet is
+ available
Changed in ubiquity (Ubuntu):
milestone: ubuntu-10.10 → maverick-updates
Scott Kitterman (kitterman) wrote :

Since this just affects installation and we don't respin ISOs for NON-LTS, I think a natty milestone makes more sense.

Changed in ubiquity (Ubuntu):
milestone: maverick-updates → natty-alpha-3
Jonathan Riddell (jr) wrote :

Seems to work in natty

Changed in ubiquity (Ubuntu):
milestone: natty-alpha-3 → none
status: Confirmed → Fix Released
Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers