Wubi fails to boot after installation (using 30 Aug ISOs)

Bug #626882 reported by Jeff Lane on 2010-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Installed using Wubi 64bit inside a Windows 7 Home Premium setup using Wubi from the 30 August ISO build of Ubuntu 64bit.

Wubi worked and installed Maverick to a 10GB file inside the Windows system. It also successfully shut down Windows after install.

HOWEVER, once the machine rebooted, I chose Ubuntu from the Winddows boot loader, which then led to Grub, which failed (as it seems to have been doing so far for others testing).

So while the first part of wubi install worked, the second part fails as grub doesn't allow me to boot.

Jeff Lane (bladernr) wrote :

Wubi is still broken as of the 31 August ISO images. I'm trying using the AMD64 image on an Athlon II system.

Wubi, as before, installs, but once you try to reboot, any attempt to boot Ubuntu results in a grub shell.

I did some further checking, and in C:/ubuntu/disks/boot/grub there is nothing. No grub config at all... curiouser and curiouser...

Below is the current contents of the Win boot loader as edited by Wubi during install...

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>bcdedit.exe

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=\Device\HarddiskVolume1
description Windows Boot Manager
locale en-US
inherit {globalsettings}
extendedinput Yes
default {current}
resumeobject {8a3ac661-a285-11df-bfdc-f4bfeccaa990}
displayorder {current}
                        {8a3ac668-a285-11df-bfdc-f4bfeccaa990}
toolsdisplayorder {memdiag}
timeout 10
customactions 0x1000085000001
                        0x5400000f
custom:5400000f {8a3ac665-a285-11df-bfdc-f4bfeccaa990}

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Windows 7
locale en-US
inherit {bootloadersettings}
recoverysequence {8a3ac665-a285-11df-bfdc-f4bfeccaa990}
recoveryenabled Yes
osdevice partition=C:
systemroot \Windows
resumeobject {8a3ac661-a285-11df-bfdc-f4bfeccaa990}
nx OptIn
detecthal Yes

Real-mode Boot Sector
---------------------
identifier {8a3ac668-a285-11df-bfdc-f4bfeccaa990}
device partition=C:
path \ubuntu\winboot\wubildr.mbr
description Ubuntu

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
Evan (ev) wrote :

Jeff, can you try with the latest daily-live CDs? We believe we fixed this with r193.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Jeff Lane (bladernr) wrote :

Evan:

I'm sorry for the delay on this... I was in Lexington when I tested it, and came home from that trip only to go on holiday for a week. I'm syncing isos now, so I'll give it a shot from the latest daily build as soon as that's complete and update this with the results.

Jeff Lane (bladernr) wrote :

Evan:

I retried a Wubi install from the AMD64 ISO as of 13 Sept on a 64bit Win7 system. It again correctly removed the previous attempt and installed everything, but on reboot dumped me back at the grub shell... so no bootable Ubuntu system.

Changed in ubiquity (Ubuntu):
status: Incomplete → New
Jeff Lane (bladernr) wrote :

Attempted again using the Wubi version included in the ISO that I synced on the 17th of Sept and still no luck getting a bootable system after Wubi installs. I still get dumped to the grub console.

Jeff Lane (bladernr) wrote :

Update: Attempted 32bit Wubi inside Windows XP on a netbook (using Wubi from the Netbook ISO from 20 Sept) and it successfully rebooted and began completing the installation.

I was able to get all the way through the installation and reboot. On reboot, I hit the Ubuntu option in the NTLoader, and it attempted to find Ubuntu but then failed.

So we're a step closer. Wubi at least now seems to boot and finish installing Ubuntu, but it's not bootable after installation is completed.

Evan (ev) wrote :

Jeff,

Can you elaborate on how it failed? If you hold down shift upon rebooting, do you get into the GRUB menu? If you remove 'quiet splash' from the kernel command line in the GRUB editor mode and boot, what error messages do you get?

Thanks so much for your persistence on this.

Jeff Lane (bladernr) wrote :

Evan:

So it happens like this:

NTLoader loads and gives options for WinXP and Ubuntu
Pick Ubuntu, hit enter
Get a message that says "Try (hd0,0): FAT32:" and then it goes back to the boot loader...

Now, this is AFTER install completes. So, I DO actually boot Maverick initially... the flow is like this:

Boot WinXP
Run Wubi
Do the Windows portion of the install
Reboot
Choose Ubuntu to complete installation
Maverick boots, Ubiquity loads and the installation completes.
Install finishes, reboot.
NTLoader opens, Choose Ubuntu
Get the message noted above.

Note, though, this was Wubi from the 32bit Netbook image. My previous attempts were with Wubi from 64bit Desktop on a Win7 laptop...

BUT, I'm assuming that wubi is wubi is wubi so if it works on one it should, in theory work on all. (of course, that could be utterly incorrect).

Jeff Lane (bladernr) wrote :

Oh, crap... forgot to mention:

This is already on a multi-boot netbook... so it's more like this:

Boot system
Grub loads
Choose WinXP
NTLoader Loads
Choose Ubuntu
Get "Try (hd0,0): FAT32:" message
bounce back to Grub
Choose WinXP
NTLoader Loads
Repeat cycle...

Evan (ev) on 2011-02-08
Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Jeff Lane (bladernr) wrote :

Long forgotten. Closing

Changed in ubiquity (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers