Correct locale settings not set within KDE after installation

Bug #62613 reported by Marc Schiffbauer on 2006-09-27
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Harald Sitter

Bug Description

Binary package hint: kubuntu-desktop

Hi!

I just installed kubuntu knot-3 and installed it in german language. All went fine so far.

But locale settings were not set to german within KDE, they were still set to "C".

I had to do the following to correct this:
(As I have a german desktop I try to translate the following back to english so it might not 100% fit the wording on the original english desktop...)
K-Menu -> system settings -> Personal / Locale settings and Language ->
(here "Country or Region" was set to "C") -> Central Europen -> Germany

Now I have correct Time/Money/Language settings etc.

I think john doe will not correct/check that setting if he is new to the system but instead will wonder why some system settings for money / time / numbers are a bit strange on his brandnew non-english linuxsystem...

I think this should be set according to the information entered at install time.

Cheers
-Marc

Caroline Ford (secretlondon) wrote :

kubuntu-meta>ubiquity

Can you provide /var/log/installer/syslog?

Changed in kubuntu-meta:
status: Unconfirmed → Needs Info
Marc Schiffbauer (mschiff) wrote :

here you are...

Julian Olivien (julianolivien) wrote :

I have exactly the same problem - also with german in feisty beta. County/Region & Language (kcmlocale) was at "C" for Country or Region and the Language was hence set to US-English (The desktop was translated to german, though -- only kcmlocale wasn't translated since it changes its language dynamically based on the language selection).

Also attaching /var/log/installer/syslog ...

Javier Jardón (jjardon) wrote :

Kubuntu Feisty 7.04, fresh install
I choose spanish in the installation. When finish programs are in spanish BUT:
   - KDM is in english -> i should change it in systemsettings to spanish
   - Country, currence.... are in C/english/$ --->i should change it in systemsettings to spain/spanish

See bug #59334 (is this a duplicate?)

Javier Jardón (jjardon) wrote :
Divan (divan-santana) wrote :

Me too! Hope this gets fixed, believe this was with earlier Kubuntu as well!

Javier Jardón (jjardon) on 2007-04-25
Changed in ubiquity:
status: Needs Info → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers