Time remaining display should be less granular

Bug #61514 reported by Matt Zimmerman on 2006-09-20
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Low
Colin Watson

Bug Description

As agreed in Wiesbaden, ubiquity can't really hope to provide time estimates commensurate with the granularity of its display. The display fluctuates quite a bit as it tries to display with 1-second resolution.

Instead, I think it should say "about N minutes remaining", and "less than a minute remaining". I'll subscribe mpt for his input also.

Matt Zimmerman (mdz) wrote :

This is of low importance, but should be very quick to implement and I would like to see it for edgy if possible.

Changed in ubiquity:
importance: Untriaged → Low
Colin Watson (cjwatson) wrote :

My chief concern here is that debconf can't do plural form translations, so translations of "about N minutes remaining" are bound to be poor in many languages. Can we come up with some rewording to avoid that problem? MM:SS was ideal because it dodged the issue entirely.

Matt Zimmerman (mdz) wrote :

I thought I addressed that in my original report, by using a different string for the singular case

Colin Watson (cjwatson) wrote :

It's not that simple; many languages have more forms than just singular and plural. For example, Russian and some similar languages have one form for numbers ending in 1 but not ending in 11, a second form for numbers ending in 2-4 but not in 12-14, and a third form for everything else. Lithuanian has a special case for numbers ending in 12-19. Czech and Slovak have one plural that's used for 2-4, and another for everything else - and so on. See "Plural forms" in the gettext documentation for more details.

debconf has never implemented this, so where possible I prefer to try to avoid relying on substituting numbers into debconf messages in a way that requires plural nouns.

Colin Watson (cjwatson) wrote :

(I'm willing to do something suboptimal quickly if we promise to come up with something better before the string freeze a week after the beta, otherwise translators for lots of languages are going to come and hunt me down.)

On Thu, Sep 21, 2006 at 12:52:17AM -0000, Colin Watson wrote:
> It's not that simple; many languages have more forms than just singular
> and plural. For example, Russian and some similar languages have one
> form for numbers ending in 1 but not ending in 11, a second form for
> numbers ending in 2-4 but not in 12-14, and a third form for everything
> else. Lithuanian has a special case for numbers ending in 12-19. Czech
> and Slovak have one plural that's used for 2-4, and another for
> everything else - and so on. See "Plural forms" in the gettext
> documentation for more details.
>
> debconf has never implemented this, so where possible I prefer to try to
> avoid relying on substituting numbers into debconf messages in a way
> that requires plural nouns.

Can we translate these messages without using debconf?

How about using SI unit notation? "about <n> min remaining" or "time
remaining: about <n> min"

--
 - mdz

Colin Watson (cjwatson) wrote :

I could instantiate an entire new translation scheme for one string, but I'd rather not if possible :-)

Something like "About <n> min remaining" doesn't sound too bad to me, though. Thanks for that suggestion.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

I wussed out and just avoided displaying a time at all until there's less than a minute to go (because it occurred to me that the case where there's a little bit more than a minute to go is awkward even in English). Perhaps we can revisit this later, when debconf has better translation facilities.

ubiquity (1.1.26) edgy; urgency=low

  [ Colin Watson ]
  * Build-depend on po-debconf (>= 1.0) for new translation-handling
    features.
  * Add a FAQ about backporting to doc/README.
  * Document ubiquity/install/filesystem-images in doc/README.
  * autogen.sh: Force use of automake-1.8 and aclocal-1.8.
  * Move auxiliary autotools files to a build subdirectory.
  * Add a check to debian/rules to remind me to bump the version number in
    configure.ac.
  * Read partition flags from gparted (>= 0.2.5-1.1ubuntu9). Display an
    error on the mountpoints page if running on powerpc and there is no HFS
    partition with the boot flag set. Treat HFS partitions with the boot
    flag set as NewWorld bootstrap partitions (closes: Malone #43768).
  * GTK frontend: Add a keyboard variant selector (closes: Malone #61729).
    (The same needs to be done for the KDE frontend.)
  * Remove old kbd-chooser component, which won't be usable any more.
  * Send stderr to /var/log/installer/debug if UBIQUITY_DEBUG is set.
  * Send DEBCONF_DEBUG=filter output to stderr, not syslog; it should be
    interleaved with DEBCONF_DEBUG=developer output.
  * GTK frontend: Throw away stderr from gnome-screensaver-command; it
    outputs far too much rubbish and confuses users.
  * KDE frontend: Fix reboot dialog button handling (closes: Malone #62765).
  * Replace the rather jittery time-remaining message while copying files
    with a message that appears when there's less than a minute remaining
    (closes: Malone #61514).

  [ Jonathan Riddell ]
  * KDE Frontend:
   - Add ensureItemVisible in set_keyboard (closes: Malone #61710).

 -- Colin Watson <email address hidden> Tue, 3 Oct 2006 17:04:38 +0100

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers