Advanced grub install options show partition table BEFORE format/repartition instead of AFTER

Bug #614309 reported by Mahmoud H. Al-Qudsi on 2010-08-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

When installing Ubuntu from the normal i386/AMD64 install CD, after reaching the step where the GRUB setup can be customized (the last page of the installer) and hitting the "Advanced" button, the drop-down list of partitions lists the *current* partition layout before the repartitioning, instead of displaying the partition layout *post*-partitioning. (the screen I'm referring to: http://farm5.static.flickr.com/4131/4837104879_7b9c388b3b_o.png )

Since

a) The partition layout will change possibly deleting the partition selected for GRUB installation to bootsector, and
b) The partition we wish to install GRUB to may not yet be created

This does not work. The drop-down needs to reflect not the entries in the MBR but the entries that _will_ be in the MBR after partitioning is complete.

MerolaC (a11111135) on 2010-10-25
Changed in ubiquity:
status: New → Confirmed
jammanuser (jamman647) wrote :

This does not sound like much of a bug to me, no offense.
Why the heck should the installer show your what your HDD and partition layout will look like after installation before the installation is even begun?
That does not make much sense to me.
That would only add more confusion to users about where they want to install Grub to, since the layout they're looking at doesn't even reflect what their layout actually is prior to installation.

jammanuser (jamman647) wrote :

Adding to my previous comment, I think what should happen with the installer *assuming this is not already done* (I haven't installed the latest version of ubuntu yet myself) is, the user will first come to a step where he/she has a chance to change he/she's HDD and partition layout by resizing, deleting, moving, or creating/formatting a partition. Next step, after the user has already made his system the way he wants it to be, he can then decide which partition to install Grub to, assuming he opts not to install to MBR. Presto...problem solved.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed

This bug appears to be fixed as of 12.04.1.

Colin Watson (cjwatson) on 2012-10-16
no longer affects: ubiquity
Mahmoud H. Al-Qudsi (mqudsi) wrote :

@jamman647: 8 years late to the party, but the installer bases its *post*-install configuration based on the selection you make on that screen. There's no way to tell it what partition to boot from if it doesn't show you what your partitions will look like at the time your system, well, boots. Who cares what your partition layout looks like if you're going to wipe it all away in a minute?

Phillip Susi (psusi) wrote :

I'm pretty sure this was fixed years ago.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers