Ubuntu

wubi installation failed - boot configuration store could not be opened

Reported by John Webster on 2010-08-04
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

Error occurred while testing Kubuntu 20100803.3 ISO. Windows log file attached.

John Webster (civil-bigpond) wrote :
tags: added: iso-testing
Martin Pitt (pitti) wrote :

Can you please be more specific what failed exactly? Did the installer abort? Did it succeed, but booting Ubuntu fails? Please feel free to attach a screenshot.

On 04/08/10 21:10, Martin Pitt wrote:
> Can you please be more specific what failed exactly? Did the installer
> abort? Did it succeed, but booting Ubuntu fails? Please feel free to
> attach a screenshot.
>
>
The installer aborted at the last moment with the message quoted in the
subject heading. No "installation" occurred (that is, there was no
Ubuntu application requiring removal once I'd recorded the log file and
cleared away the residue).

I used a Windows 7 partition for testing, if that's relevant. I could
try a Windows XP installation on one of my other computers if that would
be useful.

--
Dr John Webster
365 Table Top Road
Bridge Creek
Victoria 3723
Australia

phone/fax +613-5776-9875
mobile +614-1642-2892

Evan Dandrea (ev) wrote :

The "The boot configuration data store could not be opened." message implies that Wubi is failing to elevate its privileges. Could you please right click on the Wubi executable and select "Run as Administrator", and let me know if that gets you any further (attaching logs if it fails)?

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
John Webster (civil-bigpond) wrote :

Tried that, but the result is exactly the same. Log file attached as requested (looks very similar to the original one). Note that the log file seems to imply that a required file is missing, not that access has been denied to an existing file.

John Webster (civil-bigpond) wrote :

I haven't yet been able to check this under Vista or XP, but can now confirm that the bug does not appear to be machine-specific. The same behaviour occurs on two of my other machines (a Lenovo M9952-RZ4 box and an Acer eMachines EL1301) running Windows 7 and generates more or less identical log files. Note that I have checked the integrity of the Kubuntu 20100803.3 installation disk in question, and have had no significant problems with any of the three physical installations that I have now performed using that disk.

papukaija (papukaija) wrote :

The requested information has been provided.

tags: added: kubuntu maverick
Changed in ubiquity (Ubuntu):
status: Incomplete → New
linex83 (linex83) wrote :

Confirming the problem when installing the ISO to a USB stick.

linex83 (linex83) wrote :

I think this bug is quite critical since it prevents users from installing and testers from testing.

John Webster (civil-bigpond) wrote :
John Webster (civil-bigpond) wrote :

As demonstrated in the above log file, this bug also arose in ISO testing for the latest version of Kubuntu 10.04.1 (20100816.2). The symptoms are unchanged.

KI7MT (ki7mt) wrote :

Ara asked me to test this on 10.04.1 release.

Used ubuntu-desktop-i386.iso 20100816.1

Install proceeded well until the last possible second, then fails stating:

"Cannot Download Metalink and Therefore The ISO"

Odd this is, it produced what looks to be 2x error log versions, yet this is the first time I've ever tried Wubi.

Base System is Windows XP w/SP3.

Wubi-Logs Attached.

Colin Watson (cjwatson) wrote :

KE1HA has a separate problem so far, which I'm debugging separately.

Robbie Williamson (robbiew) wrote :

This did NOT occur for me when testing against a Windows XP installation, so could be specific to Vista or Win7

Kate Stewart (kate.stewart) wrote :

Was able to boot Kubuntu from 10.4.1 candidate when using a CD on Win 7.
- downloaded image
- burned CD
- eject/re-insert CD
- execute WUBI from CD
- select install under Win 7.
   ---> it then had to remove Ubuntu 10.4.1 image already installed, sucess.
- images copied over.
- reboot, and two boot level selections needed.
- installation proceeded normally
- booted into Kubuntu and logged in.

What was different?

Changed in ubiquity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
John Webster (civil-bigpond) wrote :

@Kate

I suspect that, because you had a pre-existing 10.04 installation within Windows, the installer was able to access a configuration file whose contents were sufficiently close to those of the 10.04.1 version to enable the installation to complete successfully. I've always tended to test a clean installation initially, on the possibly spurious grounds that people typically use Wubi only to test the new OS for a few weeks at most, before proceeding to a full installation. Your procedure is the correct one, of course, for those users who prefer to continue running, and updating, Ubuntu/Kubuntu within Windows.

linex83 (linex83) wrote :

Please note that this bug is probably not related to windows at all since I get the very same message when I run the installation from a bootable USB stick. So what is said here is wrong: http://www.ubuntu.com/testing/maverick/beta#Known%20issues

I somewhat agree with what anton.pussep suggested. I tried to install the beta from CD to dual boot with windows 7. Eveything went well up to the point of user setup. After I filled in the user information the installer poped up an error dialog stating someting like:,, the wubi-user-setup failed to create user data. Please try again, or the installation might be damaged." with three buttons: Ignore, retry and cancel installation. Tried to retry that several times with no success. If i ignore and continue, the installation halts, with progress bar notice:,,Ready when you are". After that i have to kill the installation.

Robrto Sanchz (robech) wrote :

I also had same error while installing kubuntu for laptop

I downloaded and run wubi.exe, selected kubuntu Notebook and got error below:

cannot download the metalink and therefore the iso
 c:\users\por\appdata\local\temp\wubi-10.04.1-rev190.log

Fabián Rodríguez (magicfab) wrote :

The following has been added to the Ubuntu Maverick release notes:
 * The Wubi Windows installer was reported to be unable to open Windows' boot configuration data store in some (but not all) cases. Investigation of the problems are ongoing (Bug:613288)

Changed in ubuntu-release-notes:
status: New → Fix Released
James Don Book (jdonbook) wrote :

I found that the quality/cleanliness of the install CD is quite critical. I had several failed wubi installs with various problems. I looked at the disk and it had a few finger prints on it, no scratches. Once I cleaned it with one of those CD cleaners, the install went without a hitch. I guess cleanliness IS next to Ubuntuness (or Wubiness).

codeslinger (codeslinger) wrote :

I suspect the common denominator is that this is specific to Windows 7
and that it be a clean/new machine without any previous installs.

I also encountered a very similar problem with a brand new cpu from hp.

One thing to note is the typical partitioning scheme these days makes it very difficult/impossible to install a multiboot system. I would not be surprised if this is intentional.

Windows 7 typically comes as
p1: small, hidden boot utility
p2: large, most of disk, the Win7
p3: 10 gigs, recovery-reinstaller

Since windows has historically not functioned if you try to rearrange the partition numbers, attempting to split partition #2 into two partitions is likely to break the ability to run the recovery from partition #3.

It should be possible to resize #2 and then move #3 closer, thus freeing up disk at the end for ubuntu while preserving the partition sequence for windows compatibility. but the current install software does not support this -- thus the increasing desire to be able to use wubi.

On the hp that I attempted to install wubi on, everything appeared to go well, no error messages. but when booting the computer it failed to be able to load/find ubuntu. It was still able to boot win7. since it was using the microsoft boot loader instead of grub, and since microsoft appears to have totally changed how their boot loader config works in windows 7, I was not able to discern much about what was going on, I did not find a boot.ini file. I also didn't see a way to remove the failed wubi install.

I didn't have a lot of time to spend on this, so I finally erased win7 and did a full install of ubuntu 10.0.4

Corey Knoettgen (cknoettg) wrote :

Had a dual boot Windows XP, SP3 / Ubuntu 10.04.01 LTS via Wubi. Bootup of Ubuntu had been problematic from the start, but a patch had more or less solved the problem (but it still failed to boot on occasion). Upgraded to 10.10 from within 10.04 with no problems. No more bootup failures. I just wanted to add a positive experience into the mix.

I have a dual boot Wubi download install and have had similar problems to the above in that the boot fails to reinitialise entailing deletion from within Windows and a new install - however unlike the descriptions above, there aren't any error messages at all (context: I attempted update (twice) to the new version 10.10 from Lucid as per the button on the update manager inviting me to do that) in my case it was not possible to take a screenshot, since I ended up not anywhere in either Windows or Ubuntu to be able to do that (or anything else except switch off) So I am stuck with the Wubi primary Lucid (10.10 doesn't download, Lucid still does) until I can be reasonably certain the bug is fixed. (and sorry would like to help but am codingly challenged so haven't a clue how to!) Is there a case for removing the 10.10 from the update manager until this works? I lost all my settings and work twice because of it.

Rick Bone (rickyracer2009) wrote :

Yes, entry 22 on 10-10-2010 was/is correct. Microsoft IS ACTIVELY FIGHTING THE INSTALLATIONS OF UBUNTU!! I FOUND THIS OUT MYSELF LAST Dec. 2010 on 3 laptops.. Sorry about caplock. MS is adding un-necessary partitions, deleting essential install files and it quit near the end. MS also deleted the header files from otherwise seemed normal ISOs I tried to install. So what I don't See/ Read here is a fix or a work- around developed by Now July 16, 2010. This is serious. There is no telling how many tried to install & gave up. Does anyone know any good anti- trust lawyers in Europe since they take anti- trust issues more seriously ie Internet Explorer & that big Fine MS quickly paid.
  Anyway, I was hoping for an easy answer here for 2 new laptops I have but I don't see it.

Rick Bone (rickyracer2009) wrote :

I guess I could add my solution to 2 computers I install Ubuntu dual boot with Win7 64bit.
  I did Acronis Images of all 3 three partitions to a USB HDD. Then I only put back 2, the puny nuisance 100MB one MS seems to like (And Hide) and the main Win7 Part- I only gave it 200GBs. That left 300GB for a DVD install of Lucid on one laptop & Ultimate Edition 2.8 on the other. I really like part of the UE. I also HAD to use store bought DVDs of Ubuntu since I believe MS destroys some code when making the ISOs. Yes, they are that smart & devious.
  I hope this helps.
  Since I am still learning Ubuntu, now I need help on fixing 10 new headers I have acquired since & I see on the GRUB menu at boot without breaking something.
  Anyone point me to an answer??

Jason Tucker (jasonjtucker) wrote :

In Windows 7/Vista, if you get the "boot configuration store could not be opened" error when installing with Wubi, try this:

Go to Administrative Tools -> Computer Management -> Disk Management. See if you have a small (100MB or so) partition at the beginning of one of your drives. On mine (an HP) it's called SYSTEM and is 106MB. Right-click on it, select "Change Drive Letter and Paths..." and if it has no drive letter, add one (it doesn't matter what letter) then close everything and try installing with Wubi again.

Once I assigned a drive letter, bcdedit.exe was able to access the boot configuration store and Wubi installed fine.

bcbc (bcbc) wrote :

According to http://support.microsoft.com/kb/2419286 :
Problem: “The boot configuration data store could not be opened. The system cannot find the file specified.”
Symptoms
When you run Bcdedit /enum all you get the following error
“The boot configuration data store could not be opened. The system cannot find the file specified.”
Look for the following registry key HKEY_LOCAL_MACHINE\BCD00000000
If we check under HKLM you will not find the key BCD00000000

Cause
If some 3rd party storage Disk or Storage Management software is installed it may bring all the volume without drive letter offline
Generally 100 MB partition is system partition which contains Boot configuration Database and does not have a drive letter assigned.

Solution
From adminstrator command prompt:
C:\>Diskpart
C:\Diskpart> List volume
C:\Diskpart> Select volume 1 (Considering this is 100 MB system partition)
C:\Diskpart> Online volume
C:\Diskpart> exit

This has been confirmed to work here http://ubuntuforums.org/showthread.php?t=1871823

Note the Microsoft solution also mentions the solution Jason Tucker provided in #27 - but I think it's probably better not to have to assign a drive letter to the system boot partition.

I don't think therefore this is caused by Wubi/Ubuntu

Colin Watson (cjwatson) on 2012-10-16
no longer affects: ubiquity
dino99 (9d9) wrote :
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu Maverick):
status: Confirmed → Invalid
Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers