should offer a way to configure pppoe

Bug #59491 reported by Hidde Brugmans on 2006-09-08
14
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

As per a comment on bug 59488, which I fully agree with.

Re: pppoeconf should be on livecd from Martijn van de Streek at 2006-09-08 11:02:52 CEST

That's good: imho ubiquity should have an option to configure the network using PPPoE, along with options for DHCP, etc.

PPPoE is also quite easy to detect (there's a tool in the pppoeconf package to do this, afaik)

Martijn vdS (martijn) wrote :

The tool is /usr/sbin/pppoe-sniff in the 'pppoe' package.

that is: /usr/sbin/pppoe-sniff

Without some sort of easy way to set this up, new users might be searching for a long time, since most providers only provide a username and a password, and the user has to know that what they are looking for is a way to connect to pppoe.

Colin Watson (cjwatson) wrote :

We don't have any network configuration at all in ubiquity at the moment, so this will have to wait.

Changed in ubiquity:
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed
Julian Olivien (julianolivien) wrote :

This is somewhat related to debian-installer wish 33240.

unggnu (unggnu) wrote :

Why not ship the graphical pppoe configurator with the live cd? That one that Knoppix brings with it? It is very hard for a newbie without internet to find this pppoeconf in console. I thought this will be done in Edgy but it is still not. Please integrate this. This is just one package and it helps very much. Not everyone has a Router.
I think that this is much more important than PPP since a dialup isn't that good for Linux.

unggnu (unggnu) wrote :

The only thing needed is xdialog and a PPPOE-Conf-Link under Internet menu so everyone can find it and needs no console to set it up like in Knoppix (xdialog convert text messages to gui boxes). Please fix this at least in Feisty+1.
Best thing of course would be a NetworkManager plugin but a graphical pppoe-conf would do it anyway.

Martijn vdS (martijn) wrote :

I think this bug needs a bit of attention in the "intrepid" time-frame, with the "on-line anywhere" goal etc.

Might also become easier with a new NetworkManager.

unggnu (unggnu) wrote :

This should be fixed in Intrepid Alpha 4 and later since the NetworkManager supports PPPoE now. It is still not so easy to find but I guess this would be fixed until release.

Changed in ubiquity:
status: Confirmed → Incomplete
Javier Jardón (jjardon) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

unggnu (unggnu) wrote :

I guess this could be closed since PPPOE configuration is possible with NetworkManager in Intrepid.

Changed in ubiquity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers