Ubuntu

ubiquity crashed with InstallStepError in configure_plugins() in Ubuntu 10.04 VM in VirtualBox 3.2.4, Ubuntu 9.10 Host

Reported by rusivi2 on 2010-06-07
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Virtualbox
Fix Released
Unknown
ubiquity
Fix Released
Unknown
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

1) lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

2) apt-cache policy ubiquity
ubiquity:
  Installed: 2.2.24
  Candidate: 2.2.24
  Version table:
 *** 2.2.24 0
        500 http://archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        100 /var/lib/dpkg/status
     2.2.23 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

3) What I expected to happen is that when I tried to perform a fresh install of Ubuntu 10.04 VM in VirtualBox 3.2.4 (Ubuntu 9.10 Host) it installs successfully with no problem.

4) What happens instead is the install failed.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.24
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Mon Jun 7 15:34:45 2010
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2056/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with InstallStepError in configure_plugins()
UserGroups:

visibility: private → public

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #530283, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check

Host information:

lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

apt-cache policy virtualbox-3.2
virtualbox-3.2:
  Installed: 3.2.4-62431~Ubuntu~karmic
  Candidate: 3.2.4-62431~Ubuntu~karmic
  Version table:
 *** 3.2.4-62431~Ubuntu~karmic 0
        100 /var/lib/dpkg/status

Removing duplicate status as bug 530283 is different architecture, VirtualBox version, and Ubuntu version, despite same error message.

affects: ubiquity → virtualbox
Changed in virtualbox:
status: Unknown → New

Added link to VBox bug http://www.virtualbox.org/ticket/6907 as this problem manifested itself in version 3.2.2 and remained into 3.2.4

Added link to Kernel.org bug https://bugzilla.kernel.org/show_bug.cgi?id=16165 as VBox developers believe the issue is kernel related when using ext4 filesystem.

Changed in ubiquity:
status: Unknown → New

A new version of VirtualBox (3.2.6) has been released, with a work around for Linux hosts with the ext4 filesystem, which is most likely the cause of this bug. Downloaded the newest version of VBox, and successfully installed and updated a Ubuntu 10.04 VM. Hence, this bug is considered closed.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Changed in ubiquity:
status: New → Fix Released
Changed in virtualbox:
status: New → Fix Released
Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.