Ubuntu

ubiquity crashed with OSError in chroot_cleanup() in Ubuntu 10.04 VM in VirtualBox 3.2.2

Reported by rusivi2 on 2010-06-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Virtualbox
Fix Released
Unknown
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

1) lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

2) apt-cache policy ubiquity
ubiquity:
  Installed: 2.2.24
  Candidate: 2.2.24
  Version table:
 *** 2.2.24 0
        500 http://archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
        100 /var/lib/dpkg/status
     2.2.23 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages

3) What I expected to happen is when I tried to do a fresh install of a MD5 verified iso of Ubuntu 10.04, downloaded from www.ubuntu.com, into a VirtualBox 3.2.2 virtual machine (VM)m it would install without any problem.

4) What happened instead is that when I tried to install it (for the third time) it failed and crashed.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.24
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sat Jun 5 04:42:26 2010
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2045/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with OSError in chroot_cleanup()
UserGroups:

tags: removed: need-duplicate-check
tags: added: 10.04 2.2.24 3.2.2 ubiquity virtualbox

Host information:

lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

apt-cache policy virtualbox-3.2
virtualbox-3.2:
  Installed: 3.2.2-62298~Ubuntu~karmic
  Candidate: 3.2.2-62298~Ubuntu~karmic
  Version table:
 *** 3.2.2-62298~Ubuntu~karmic 0
        100 /var/lib/dpkg/status

affects: ubiquity → virtualbox
Changed in virtualbox:
status: Unknown → New
visibility: private → public

New version of VirtualBox came out (3.2.4) which seems to be the root cause of this problem. This bug is considered closed.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Changed in virtualbox:
status: New → Fix Released
Changed in virtualbox:
status: Fix Released → New
Changed in virtualbox:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.