Couldn't find a way to create new partitions

Bug #57583 reported by Francis J. Lacoste on 2006-08-24
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Colin Watson

Bug Description

I found another wart when using the KDE installer. I chose the 'Manual partitioning' option. After resizing the NTFS partition, I had a huge block of free space available. But I couldn't find any way to create a new partition in that free space. The 'New partition' button remained disabled throughout. I also try right-clicking on the free space to have a contextual menu item to create a partition in that free space but didn't find one.

My free space was in the middle of the disk. Came first a small primary partition for the Dell Utilities. Then the small repartitioned NTFS primary partition. Then the free space. Then another small Dell system primary partition at the end of the disk.

I finally partitioned the disks outside the installer using cfdisk and everything went fine from there. I created an extended partition on the free space and then create my swap space and two other partitions.

Colin Watson (cjwatson) wrote :

If you can reproduce this situation again, can you try starting qtparted and see if it exhibits the same bug when run standalone?

Changed in ubiquity:
status: Unconfirmed → Needs Info
Colin Watson (cjwatson) wrote :

I'm pretty sure that the new advanced partitioner in Feisty shouldn't suffer from this problem. I'd welcome re-testing if you can set up a similar situation again somehow.

Changed in ubiquity:
assignee: nobody → kamion
status: Needs Info → Fix Released
Henrik Nilsen Omma (henrik) wrote :

I've marked 178299 as a duplicate of this bug and reopened, as it still seems present in Hardy.

Changed in ubiquity:
status: Fix Released → Incomplete
Evan (ev) wrote :

We no longer use qtparted, but can someone who is experiencing this please try the final release of Ubuntu 8.04 and report back as to whether the bug is fixed or not. If the latter case is true, then please also attach /var/log/syslog and /var/log/partman.

Thanks!

Colin Watson (cjwatson) wrote :

Bug 178299 is not a duplicate of this bug; it's a slightly different (I think) complaint about a completely different partitioner implementation. I've unmarked it as a duplicate and am re-closing this bug.

Changed in ubiquity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers