Unobvious where to report Ubuntu installation problems

Bug #57189 reported by era on 2006-08-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Through trial and error I have found this to be the apparent right place for bug reports about installation problems in Dapper. However, there are various other places where people are reporting bugs against the installer, including "ubuntu-express", "debian-installer", and "ubuntu-meta".

It's not clear to me how this should be fixed, but some things come to mind.

- Put a pointer in the "welcome to ubuntu" on-line docs. Probably not a good overall solution, but a useful step for those who look there.

- Maybe create a package called "ubuntu-live-install" or some such which simply redirects to whichever installer is current. For the record, https://launchpad.net/distros/ubuntu/+search?text=ubuntu+install displays "installation guide" and "ubuntu express" before "ubiquity", and unless you happen to know what "ubiquity" means in this particular context, you are unlikely to land there.

- Deprecate "ubuntu-express" in various visible ways to prevent people from reporting ubiquity bugs there. I have been unable to find out the status and roadmap for "ubuntu-express" but it seems that that is also part of the problem, rather than (solely) a problem with my abilities.

- Similarly, somehow make it clear what the division of responsibilities between "debian-installer" and "ubiquity" is. http://packages.ubuntu.com/dapper/devel/debian-installer looks like d-i should not be used, whereas https://launchpad.net/distros/ubuntu/+source/debian-installer/+bugs looks like a lot of bugs are being accepted for debian-installer even where they seem to be specific to the live CD installer.

- Follow up on bugs reported against "ubuntu-express" and poke on the reporters to figure out if these are genuine "ubuntu-express" bugs or actually meant to be reported against ubiquity. (Oh, seems like this is already started; I recall there were many more bugs there last time I looked.)

- Add pointers to https://launchpad.net/people/ubuntu-installer/+assignedbugs too, if possible (if nothing else, assign a "meta-bug" pointing to the right place). For the record, this is the "I'm feeling lucky" hit in Google for "ubuntu installer bugs". Perhaps the search results could be doctored to prefer a more informative page. Or perhaps Google could even be persuaded to sponsor a link to whatever Ubuntu says is the right place.

- Update https://wiki.ubuntu.com/InstallerTeam and make sure to keep it up to date. The bugzilla link should be replaced with a launchpad link and the Hoary and Breezy goals should probably be removed; or, at the very least, add Dapper and Edgy.

Because my own understanding of the Right Answer is muddy at best, I have to apologize if some parts of this bug report are inaccurate or even preposterous. The bottom line should still be that if people can't figure out where to report bugs, you will not receive reports about all the problems people are having.

Simon Law (sfllaw) wrote :

Ubiquity often tells you to file bugs against it when things go wrong.

Sadly, it's difficult for someone to determine which part of the
installation process is failing. We try to sort bugs into the right place.

Of course, adding documentation is a good thing, but there really
isn't an official document that describes this adequately. You may
wish to edit http://ubuntuguide.org/wiki/Dapper and add this information
there.

Thanks.

Changed in ubiquity:
status: Unconfirmed → Fix Released
era (era) wrote :

"Fix released"? Come on, even if that guide was changed, the problem would not be fixed. I have enumerated a bunch of things you could do to rectify the situation at least slightly, most of which only incidentally involve a little documentation. For the most part, you should assume that people will not read documentation just to figure out how to give you feedback.

The real bug is that nobody with a basic understanding of usability has paid any attention to the scenario screaming children + old hardware + angry spouse + installer wipes your hard drive and sets your house on fire. You really really should make it as obvious and painless as possible to file a bug and/or get help when this happens.

Colin Watson (cjwatson) wrote :

I've updated https://launchpad.net/people/ubuntu-installer and http://wiki.ubuntu.com/InstallerTeam with a bit more information. I hope that helps.

Changed in ubiquity:
assignee: nobody → kamion
status: Fix Released → Confirmed
Colin Watson (cjwatson) wrote :

There is no single installer that's current. Both debian-installer and ubiquity are used for different purposes.

Colin Watson (cjwatson) wrote :

I've removed ubuntu-express from edgy, which should help (it was an oversight that it wasn't removed from dapper):

=========================================================================
[Date: Wed, 23 Aug 2006 11:52:54 +0100] [ftpmaster: Launchpad Archive Manager]
Removed the following packages from edgy:

ubuntu-express | 0.3 | source, amd64, hppa, i386, ia64, powerpc, sparc

------------------- Reason -------------------
(cjwatson) superseded by ubiquity
----------------------------------------------
=========================================================================

I can't do much about the ubuntu-express product; I don't own it, and I think it may still be used by the Guadalinex people.

Colin Watson (cjwatson) wrote :

I've cleaned up the remaining two ubuntu-express bugs.

era (era) wrote :

Excellent progress; the audience cheers!

era (era) wrote :

Might want to go over the ubuntu-meta bugs also, there's a number there which would seem to belong somewhere else, and maybe think about adding a hint or a description to the ubuntu-meta package like you did for the ubuntu-installer team, if possible.

era: there are a few bug triagers active who read incoming bugreports.
One of their tasks is making sure that a bug is filed aginst the correct
source package.

era (era) wrote :

The dominating problem is making sure that reporting a bug is not so frustrating that it doesn't happen in the first place. The threshold is already rather high among users (look in the forums for examples, every day; ubuntuforums.org is a good place to start) and the problem is exacerbated if additionally, the doorway is narrow and emits a weird odor, if you know what I mean.

Dennis Kaarsemaker (dennis) wrote :

I agree with you on that, but the bugtracker itself is not suitable for
this. If you could make a summary of the most frightening things in
malone, given what you've read on the forums, I'm sure the launchpad
people can fix that.

scandisk (esteban-orravan) wrote :

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 166, in ?
    main()
  File "/usr/bin/ubiquity", line 161, in main
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 57, in install
    ret = wizard.run()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 338, in run
    self.process_step()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 828, in process_step
    self.progress_loop()
  File "/usr/lib/ubiquity/ubiquity/frontend/kde-ui.py", line 599, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s\n%s" %
RuntimeError: Install failed with exit code 1
Traceback (most recent call last):
  File "/usr/share/ubiquity/install.py", line 1404, in ?
    install.run()
  File "/usr/share/ubiquity/install.py", line 335, in run
    self.configure_user()
  File "/usr/share/ubiquity/install.py", line 897, in configure_user
    raise InstallStepError("UserSetupApply failed with code %d" % ret)
InstallStepError: UserSetupApply failed with code 1

Przemek K. (azrael) wrote :

Ubuntu is now using Apport for semiautomatic bug reporting. Does this bug still apply?

era (era) wrote :

Przemysław Kulczycki: many of the issues I enumerated in the original bug report are still open, but perhaps this bug can be closed, and a new one opened against Launchpad and/or the wiki documentation. Perhaps this is more Brainstorm stuff now (that didn't exist when I filed the bug, either).

Colin Watson (cjwatson) on 2012-05-17
Changed in ubiquity (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
Phillip Susi (psusi) wrote :

express bugs cleaned up, wiki updated... automatic apport bug reporting... looks like this old bug can be closed out.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers