Ubuntu

[Lucid] no GRUB menu entry for other operating systems

Reported by Jeff Lane on 2010-04-27
142
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Critical
Unassigned
Nominated for Lucid by Dooitze de Jong

Bug Description

Release note:
When installing in a dual boot environment, the other operating system will not appear at first in the GRUB menu. Installing the available updates and rebooting will fix this issue.

Original report follows:
Binary package hint: ubiquity

Installed 10.04 amd64 in a VM with WinXP pre-installed. I chose a dual boot install with each OS having 50% of the disk space.

After install and reboot, however, I noticed that grub does not have a menu entry for Windows at all.

I checked the partition table and XP is still there, so perhaps I could manually fix this, however, the problem remains that my side-by-side install fails because Grub did not create a boot entry for Windows.
---
Architecture: amd64
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
Package: ubiquity (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-21-generic x86_64

tags: added: iso-testing
Otus (jan-varho) wrote :

The same happened to me when installing Lucid 20100427.1 beside another Lucid installation. Running:
sudo update-grub
manually afterwards solved the problem.

Martin Pitt (pitti) wrote :

Can you please attach /var/log/installer/syslog, /var/log/installer/partman, and /var/log/installer/debug ?

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

Colin Watson (cjwatson) on 2010-04-27
summary: - [Lucid] Installer fails to configure grub for dual boot
+ [Lucid] no GRUB menu entry for Windows

Colin Watson,

As I wrote in the first comment, this is not specific to Windows. I can reproduce this with Ubuntu Lucid or Karmic as the second OS. Also, it happens with both automatic resize and manual partitioning. Unlike with a single OS "entire disk" install, the grub screen gets displayed for 10s.

Colin Watson (cjwatson) wrote :

The GRUB delay is a direct consequence of os-prober not finding any other operating systems when run from within ubiquity.

(We think that this may be down to a migration-assistant bug, which leaves the other filesystem mounted in such a way that os-prober can't easily get at it from within the installed-system chroot - at least not without double-mounting it rather than bind-mounting, which I'm not sure is safe.)

summary: - [Lucid] no GRUB menu entry for Windows
+ [Lucid] no GRUB menu entry for other operating systems
Fabio Marconi (fabiomarconi) wrote :

Same to me
@ Colin
I think too, if i remember well in one of mine installation of today, going forward and back in the settings passes, i see a popup that tell that a partition was mounted and request me if i want unmount it.
Good work
Thanks to give us Ubuntu everyday better.

Fabio Marconi (fabiomarconi) wrote :

@colin
I've tested now Xubuntu 20100427 and in autoresize install i've got the correct entries for grub, but in the other system i've nothing to migrate, then migration assistant don't propose me nothing.
hope helpfull.

This bug is also present on the Xubuntu i386 desktop image. I hit it using partitioning 'use entire disk'. I reproduced it on two different hardware systems.

Evan Dandrea (ev) wrote :

For those of you experiencing this bug prior to release, please run `sudo update-grub` to fix your boot menu.

description: updated
Erick Brunzell (lbsolost) wrote :

Evan, sorry to be a pest as I'm sure you're quite busy, but do you think this deserves a release notes task?

I'm not really suggesting that it does, I'm just unsure. I always try to put myself in the shoes of those who are totally new to Ubuntu.

No need to reply, you'll know best :^)

Evan Dandrea (ev) wrote :

Erick,

You're not being a pest at all :). I've already added a release notes task for it.

Colin Watson (cjwatson) wrote :

Release note text added:

== Other operating systems may be missing from GRUB menu after installation ==

The desktop installer may fail to create GRUB menu entries for other operating systems in some cases. This is due to incorrect interaction between some components of the installer. To correct the problem after installation, run the following command: {{{
sudo update-grub
}}}

Alternatively, the first kernel update after installation will automatically correct this as a side-effect, and we expect to fix it in the installer as well for 10.04.1. (Bug:570765)

Changed in ubuntu-release-notes:
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
Nicolas Delvaux (malizor) wrote :

I think it's not enough.

How many newbies will install Lucid and think that their windows has been removed?
This is a far more important bug than you seem to think, and asking to run "sudo update-grub" is not quite user friendly...
(and we often say that the first feeling is the most important)

The best workaround for me (cause there is no way to delay the release) may be to release a dummy/no-change upgrade (grub? kernel?) that will force grub to update.
This have to be done now, so the update will be available when people reboot for the first time (and if possible as a security update, so that update-manager pop-up on the screen directly).

Do you see my point?

Jeff Lane (bladernr) wrote :

+1 for Nicolas' point... this issue, small and seemingly easy to work around as it may be, is a huge factor in the user experience, especially from the standpoint of the new user. For that reason, this is a critical bug, even though it does not directly impact Ubuntu itself.

Even the appearance that 10.04 has deleted the new user's Windows install is, IMHO, anathema to the entire drive to capture new users and bring them to the Linux world.

Jeff Lane (bladernr) wrote :

I went ahead and set this as critical, hoping that the corrected grub will be pushed before Release after some reflection and a brief discussion in #ubuntu-testing.

<bladernr> indeed, just the context seems to be that it's being pushed to "read the release notes and grab an update" and from the perspective of the new user, having to immediately sudo grub-update from a CLI (especially if the new user has never touched a CLI before) is horrifying. I do hope this gets pushed before tomorrow.
<bladernr> I'd be more accepting of release-notes for this if it were an OS targeted to already tech savvy users (e.g. RHEL or SLES environments) but being one who teaches a formal "Intro to Linux" class, my students would be lost on day one if they went home and tried installing and lost their Windows Installs.

I very strongly believe that this is exactly the sort of situation we want to avoid, especially on a release that is so targeted at bringing new users into the fold.

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical

Based on the reports, and the release-notes, I am confirming this issue.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Evan Dandrea (ev) wrote :

I cannot believe I have to repeat something that you appear to be directly replying to. To quote Colin and the release note, "Alternatively, the first kernel update after installation will automatically correct this as a side-effect, and we expect to fix it in the installer as well for 10.04.1."

It will not be necessary to use the console to fix this.

Fabio Marconi (fabiomarconi) wrote :

I can confirm that when there's something to migrate i've got the bug, but if there's nothing to migrate (two newly installation) the process go well and grub shows the two entries correctly.
+2 for Nicolas.

Evan Dandrea (ev) wrote :

I understand that you're passionate about making Ubuntu easy to use, but this inflammatory language completely misrepresents the facts.

Evan Dandrea (ev) wrote :

Just to be clear, my comments were in reply to earlier statements in the thread, and not Fabio's.

Erick Brunzell (lbsolost) wrote :

I have tried many installation scenarios to reproduce this bug and I've never seen it occur if Windows is the only other OS. I've only seen it occur if I have another Linux OS on the machine with a separate "/home". Now, it's possible that I'm wrong!

Anyone care to clarify?

Nicolas Delvaux (malizor) wrote :

Will the "first kernel update" be available tomorrow?

And you have to be aware that there is sometime no good Internet connexion in some countries.

I mean, if there is a possibility to solve this before the release, this have to be done (updates are just a workaround).

Fabio Marconi (fabiomarconi) wrote :

good work guys, i'm just an iso tester.
Thanks to give us Ubuntu everyday better.

Jeff Lane (bladernr) wrote :

Evan, we're all passionate about ensuring that 10.04 is the best Ubuntu and Linux release ever... but I see nothing here in my or anyone else's comments that is inflammatory.

I understand what Colin said about "first automatic kernel update". Is that a guarantee that the first automatic kernel update will be a 0-day update released alongside 10.04?

The point is that when a prospective new user first installs this and sees that Windows is gone (unless that first kernel update is going to occur BEFORE the first post-install reboot) he/she is going to freak out. The very first thought associated by that user to Ubuntu will be "OMG LINUX DELETED WINDOWS!"

If this is not fixed prior to release and is left as an automatic update that may or may not be pushed on the same day as the release, the damage will have been done. New users don't know to read release notes. Most new users, unfortunately, wouldn't even notice if there was a slide in the install slide show that informed them in large type that Windows or a secondary OS may not show up in the boot menu.

That's my biggest concern, because from that point of view, a bad first impression is the one that will last, no matter how polished the OS is, or how quickly something this basic is fixed (and I do not mean basic in the terms of being trivial or simple, but basic as in part of the core functionality of Ubuntu).

Also, Nicolas has a good point WRT to countries with poor internet connectivity, or users who want to try it out so they go to an internet cafe or library or other such spot to get connectivity long enough to download the ISO so they can install later at home without internet access, or other similar user situations around the world (satellite net users w/ stingy fair-use policies come immediately to mind).

Nicolas Delvaux (malizor) wrote :

+1 for Jeff.

I do not know how ubiquity work but AFAIK I see 3 solutions here (sort by expected difficulty):

- release a 0 day upgrade (dummy if necessary) that will force grub to update → bad because the iso is buggy, the user may be afraid on the first reboot and all users can't update their OS whenever they want.

- disable migration-assistant by default (because the bug is likely to came from here and it seems to be buggy anyway, see bugs #536673 and #220064) → bad because this is also a feature for some users...

- find and apply a proper fix → may request some time...

perhaps number 2 is the less bad in this situation ?

Colin Watson (cjwatson) wrote :

We plan to get the first kernel upgrade out today if at all possible, yes - it's on our list of 0-day updates here in the release war room ...

Colin Watson (cjwatson) wrote :

Alternatively, there's already a grub2 update in the queue anyway, so it may be simplest to get that validated and out - it'll be a much smaller download than the kernel.

Robbie Williamson (robbiew) wrote :

Jeff/Nicolas,

Are you proposing slipping the 10.04 release for this? Do you realize it takes 2 days to respin ISOs, thus making this a 10.05 release?

Colin Watson (cjwatson) wrote :

A third alternative is that if we get a fix into lucid-updates ASAP, then the "Update this installer" link at the start of the installer can be made active - that was designed for this kind of purpose.

Nicolas Delvaux (malizor) wrote :

@Robbie: for me this is a release blocker so if I was allowed to chose, I would delay the release. (and personally I will not be affected by this bug, so I may not be too subjective).
I am aware of all the logistics behind the release, but I also think of those potential users that will hate Ubuntu when they will think that it deleted their windows. (be serious, no newbie read release notes, and what will do the one without internet that received his live-cd via ship-it or a loco?)

@Colin: these updates are the minimum I think. But, as Jeff and I said, this is definitely not the best solution.

ps: a delayed release can be seen as a good point by some companies (active qa...)

Robbie Williamson (robbiew) wrote :

Nicolas: Thanks for your feedback, we are discussing a stop-gap solution now.

Fabio Bossi (fabio-bossi) wrote :

I also think that releasing with this is unacceptable: new users will deeply hate it.

Robbie Williamson (robbiew) wrote :

We've decided to respin the 32bit and 64bit CDs of Ubuntu Desktop *ONLY*, as we feel this gives us the widest spread fix possible and allows us to still release today (April 29th). Unfortunately, this means other affected variants, such as Xubuntu, will not have this fix, and we deeply apologize for this.

Robbie Williamson (robbiew) wrote :

UPDATE: This respin will also include Ubuntu Netbook Edition and the DVD.

Robbie Williamson (robbiew) wrote :

UPATE: The DVD is ***only if we have time***

Nicolas Delvaux (malizor) wrote :

Great news !

But I wonder, is it so horrible to delay the release until tomorrow to have time to respin all variant? (excluding alternate CDs and server of course).
Tomorrow is still ok for 10.04 you know. ;)

Otherwise you really took the good decision.

Robbie Williamson (robbiew) wrote :

We will notify the maintainers of the other affected variants (Xubuntu, Mythbuntu, and Edubuntu), and it will be up to them to respin or not.

Evan Dandrea (ev) on 2010-04-29
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
description: updated
46 comments hidden view all 126 comments

If I may editorialize, the logic people are using to evaluate the bug is pretty amusing:

1. It can't exist, because a problem this big would have been reported much earlier.
2. It can't be a dup of bug 191119, because that bug was reported much earlier.

Chris (racerx-makeworld) wrote :

Things must have been cleared up - Just saw the release announcement from the Ubuntu Announcements list.

Evan Dandrea (ev) wrote :

ubiquity (2.2.24) lucid-updates; urgency=low

  * Automatic update of included source packages: migration-assistant
    0.6.6.

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Pjotr12345 (computertip) wrote :

Hurray for the developers! Thanks for this lightning quick action, guys!

Free beer for everyone, all evening. First round is Belgian beer: Hoegaerden, Trappist and Duvel. Cheers!

Chris, if that's the case, I'm afraid for people's data. That RAD bug is still there. It's going to be interesting to see how they answer questions about this when people ask why their data had to be lost...

Erick Brunzell (lbsolost) wrote :

What I'm seeing so far:

First install was a true reproduction of what I improperly reported in post numbers 17 and 18 here:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/526581

I was told that nothing was suitable for migration and the install completed successfully, grub picked up all OS's and they all booted as expected. Anything that could have been "migrated" was on sda whereas I was installing to sdb.

So for the second install I manually transferred my .mozilla and Documents to the existing install on sdb and chose to "auto-resize". Still it says "nothing to migrate" but the install did complete successfully, grub found all other OS's and they booted as expected.

So I guess I have a question, "should migration-assistant now be NOT finding anything to migrate"?

I'm next going to try a manual install to pre-existing partitions on sda and see if anything is "suitable to migrate".

I should perhaps mention that I noticed a very minor "cosmetic bug" with the "auto-resize" install:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/571802

I'll have to "spin up" an older Live CD to see if this is a regression, but I rather expect it's something I'd just previously overlooked.

Sorry to be a bit slow today, myoclonic seizures are messing with me.

M Henri Day (mhenriday) wrote :

I hope the following won't be interpreted as an attempt to hijack this thread, but the problem I'm experiencing with multiple-boots and Lucid is not that the GRUB2 menu doesn't display my other OS-loader - it does - but rather that the loader cannot be accessed from it. This on my main (stationary) computer, and on my laptop, both of which are running an AMD x86-64 dual-core processor. The strange thing is that on my laptop, when I click the other OS loader in GRUB (1.98-1ubuntu5), the computer reboots, while on my stationary box, I instead get a black screen with a blinking dash, seemingly waiting for a command. I've checked using GParted, and the non-Ubuntu OS installations are still there, but as noted above, I can't open them. Updating using «sudo update-grub», which I've tried many times, doesn't help - despite the loader in question being registered. I've been experiencing this problem on my laptop ever since Lucid beta 1 was released (the gory details can be found on pp 38 & 39 of the GRUB2 Basics thread (http://ubuntuforums.org/showthread.php?t=1195275&page=38) on the English-language Ubuntu fora, to which I first posted on 23 March), and on my stationary box ever since the release of beta 2....

Henri

Yuhong Bao (yuhongbao-386) wrote :

If not all ISOs are going to be respun, why not add something about this bug to the release notes?

This is not a mailing list or forum thread. It is really a bug report. If you are getting a different bug than originally described, you probably should file a new bug report.

As for the respin, this did not affect every image. The images affected were respun.

Erick Brunzell (lbsolost) wrote :

OK, third test, whew! I created sda18 as root "/", and sda19 as "/home":

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a6391

   Device Boot Start End Blocks Id System
/dev/sda1 * 1 2589 20796111 7 HPFS/NTFS
/dev/sda2 2590 3683 8787555 83 Linux
/dev/sda3 3684 4757 8626905 83 Linux
/dev/sda4 4758 60801 450173368 5 Extended
/dev/sda5 4758 5341 4690917 83 Linux
/dev/sda6 5342 5919 4642753+ 83 Linux
/dev/sda7 52539 53852 10554673+ 83 Linux
/dev/sda8 53853 56511 21358386 83 Linux
/dev/sda9 56512 59192 21535101 83 Linux
/dev/sda10 59193 60566 11036623+ 83 Linux
/dev/sda11 60567 60801 1887606 82 Linux swap / Solaris
/dev/sda12 5920 6945 8241313+ 83 Linux
/dev/sda13 6946 7492 4393746 83 Linux
/dev/sda14 7493 8573 8683101 83 Linux
/dev/sda15 8574 9101 4241128+ 83 Linux
/dev/sda16 9102 9970 6980211 83 Linux
/dev/sda17 9971 10566 4787338+ 83 Linux
/dev/sda18 10567 11405 6739236 83 Linux
/dev/sda19 11406 11981 4626688+ 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001d22b

   Device Boot Start End Blocks Id System
/dev/sdb1 * 1 4727 37961717+ 83 Linux
/dev/sdb2 4727 9730 40187905 5 Extended
/dev/sdb5 9328 9730 3227648 82 Linux swap / Solaris
/dev/sdb6 4727 9133 35395584 83 Linux
/dev/sdb7 9133 9327 1559552 82 Linux swap / Solaris

Partition table entries are not in disk order

Still nothing to import! So, if your intention was to disable the migration assistant you succeeded. Actually I'm OK with that. But then I was also OK with just a release note task (IMO those who who fail to read documentation will always encounter problems).

The install did complete successfully and all OS's boot as expected. I didn't mention before but one of those Lucid's needs work so when I say "as expected" it's the same as booting off it's own grub2, which is not well =)

Now to see if this:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/571802

is a regression or something I've overlooked. I suspect the latter. I will let you know.

Fabio Marconi (fabiomarconi) wrote :

Big, Big, Big.
Thanks guys, everythings ok for me in two Lucid side by side on the same disk with migration that work well with evolution but not with firefox (old bug).
Thanks again.
Fabio.
Now i'm going to test with a separated /home (on another disk), but im sure it work again.
see you later

Erick Brunzell (lbsolost) wrote :

OK I've checked with an older CD (04/27) and the following was not a regression:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/571802

Obviously something I overlooked previously.

M Henri Day (mhenriday) wrote :

Thank you, Charlie ; I am fully cognizant of the fact that this «is really a bug report». Moreover, I regard the problem I described above as a bug, quite similar to, if not identical with, the one reported by Jeff Lane two days ago. In any event, I have taken your advice and reported a new bug, #571893....

Henri

kpmcdole (kpmcdole) wrote :

This has been a bug for several months...yet it's only been reported this week?

Charlie,

The problem is that there's no evidence that those bugs have even been seen or evaluated by the appropriate personnel, despite being clearly ubuntu installer problems that result in file system corruption and the loss of data. Bug 19119, for example, managed to go over 2 years without being addressed, despite being confirmed at the time by multiple people. Bug 568183 has also been confirmed by multiple people, yet it's still marked as 'new' and still has not been assigned to anyone.

If this bug *does* have the attention of the appropriate personnel, it would seem that a 3-sentence reminder is reasonable to let them know of the existence of the others.

Tom (tom6) wrote :

Hi :)

Reinstall grub2 seems easiest way to solve this! We get a lot of questions about this in Answers Section & reinstall always seems to fix it. I have only just heard that updating grub2 often works too. Grrrr. lol. With grub orginial it was easy to edit the menu.lst but we don't seem to understand any finesses with grub2 yet. Reinstall of grub2 only takes about 5mins at the most tho.

People expect there to be problems with a beta & sometimes don't bother to report stuff they see as trivial or stuff they don't notice in the excitement.

Delaying a release would make us increasingly relaxed about all this sort of thing & might lead to all subsequent releases also being delayed. I think it's good to push it out so that next time we are forced to try harder to get everything in ahead of time. Perhaps it's only me in all the world that has time management issues & a tendency to leave things to the last minute?

Regards from
Tom :)

I have install lucid on my machine, which was having both redhat as well as xp. After installation xp was there in grub but
redhat is missing. How to solve it??

Changed in ubuntu-release-notes:
assignee: Colin Watson (cjwatson) → Sonal Kumar Jain (sonaljain-spl)
assignee: Sonal Kumar Jain (sonaljain-spl) → nobody
1 comments hidden view all 126 comments
Nandan Vaidya (gotunandan) wrote :

@ Sonal Kumar Jain

Running update-grub from the command line should solve that problem.

$ sudo update-grub

I have install lucid on my machine, which was having both redhat as well as xp. After installation xp was there in grub but
redhat is missing. How to solve it??
After running "sudo update-grub" i got the following msg

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-21-generic
Found initrd image: /boot/initrd.img-2.6.32-21-generic
Found memtest86+ image: /memtest86+.bin
Found Microsoft Windows XP Professional on /dev/sda1
Found Windows NT/2000/XP on /dev/sda3
Found Red Hat Enterprise Linux Client release 5.3 (Tikanga) on /dev/sdb7
done

As you have seen that it is showing redhat in the msg, but i reboot the system redhat was missing in grub menu.

looking for solution

M Henri Day (mhenriday) wrote :

Sonal, your problem *seems* to be the same as mine, i e, an inability to boot into non-Ubuntu loaders even though they are displayed on the GRUB menu, something for which, in accordance with a suggestion by Charlie Kravetz above, I have filed a separate bug notice (#571893). But your situation remains a trifle unclear to me ; can you or can you not boot into Windows XP or Red Hat Tikanga from your GRUB menu ?...

Henri

Michael Lueck (mlueck) wrote :

I seem to have dupe reported this bug here:

https://bugs.launchpad.net/bugs/570398

Lower number... I guess I won, just was not noticed.

  • grub.cfg Edit (3.5 KiB, application/octet-stream; name="grub.cfg")

Here I m attaching my grub.cfg file. I could able to boot in XP, but the
main problem is that i am not able to redhat
entry in grub menu...

On Fri, Apr 30, 2010 at 9:52 PM, M Henri Day <email address hidden> wrote:

> Sonal, your problem *seems* to be the same as mine, i e, an inability to
> boot into non-Ubuntu loaders even though they are displayed on the GRUB
> menu, something for which, in accordance with a suggestion by Charlie
> Kravetz above, I have filed a separate bug notice (#571893). But your
> situation remains a trifle unclear to me ; can you or can you not boot
> into Windows XP or Red Hat Tikanga from your GRUB menu ?...
>
> Henri
>
> --
> [Lucid] no GRUB menu entry for other operating systems
> https://bugs.launchpad.net/bugs/570765
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in “ubiquity” package in Ubuntu: Fix Released
>
> Bug description:
> Release note:
> When installing in a dual boot environment, the other operating system will
> not appear at first in the GRUB menu. Installing the available updates and
> rebooting will fix this issue.
>
> Original report follows:
> Binary package hint: ubiquity
>
> Installed 10.04 amd64 in a VM with WinXP pre-installed. I chose a dual
> boot install with each OS having 50% of the disk space.
>
> After install and reboot, however, I noticed that grub does not have a menu
> entry for Windows at all.
>
> I checked the partition table and XP is still there, so perhaps I could
> manually fix this, however, the problem remains that my side-by-side install
> fails because Grub did not create a boot entry for Windows.
> ---
> Architecture: amd64
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64
> (20100427.1)
> Package: ubiquity (not installed)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Tags: lucid
> Uname: Linux 2.6.32-21-generic x86_64
>
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/570765/+subscribe
>

--
****************************************

Sonal Kumar Jain
RF, Space Physics Laboratory
Vikram Sarabhai Space Centre
Trivandrum 695022
INDIA

Ph: +91 471 2562906 (O)
     +91 9388472745 (M)
alternative e-mail: <email address hidden>
<email address hidden>

Am Samstag, den 01.05.2010, 00:48 +0000 schrieb Michael Lueck:
> I seem to have dupe reported this bug here:
>
> https://bugs.launchpad.net/bugs/570398
>
> Lower number... I guess I won, just was not noticed.
>
numbers dont make you win, only the amount of attached logs and
information does ;)

Fabio Marconi (fabiomarconi) wrote :

Referred #42:
Don'work
manual partitioning on a separated /home (another disk) .
Sorry

Tom (tom6) wrote :

Reinstalling grub2 seems to work in most cases

Fabio Marconi (fabiomarconi) wrote :

Oops # 97, sorry

Should I try grub legacy (old grub)??

On Sat, May 1, 2010 at 3:10 PM, Fabio Marconi <email address hidden>wrote:

> Oops # 97, sorry
>
> --
> [Lucid] no GRUB menu entry for other operating systems
> https://bugs.launchpad.net/bugs/570765
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in “ubiquity” package in Ubuntu: Fix Released
>
> Bug description:
> Release note:
> When installing in a dual boot environment, the other operating system will
> not appear at first in the GRUB menu. Installing the available updates and
> rebooting will fix this issue.
>
> Original report follows:
> Binary package hint: ubiquity
>
> Installed 10.04 amd64 in a VM with WinXP pre-installed. I chose a dual
> boot install with each OS having 50% of the disk space.
>
> After install and reboot, however, I noticed that grub does not have a menu
> entry for Windows at all.
>
> I checked the partition table and XP is still there, so perhaps I could
> manually fix this, however, the problem remains that my side-by-side install
> fails because Grub did not create a boot entry for Windows.
> ---
> Architecture: amd64
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64
> (20100427.1)
> Package: ubiquity (not installed)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Tags: lucid
> Uname: Linux 2.6.32-21-generic x86_64
>
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/570765/+subscribe
>

--
****************************************

Sonal Kumar Jain
RF, Space Physics Laboratory
Vikram Sarabhai Space Centre
Trivandrum 695022
INDIA

Ph: +91 471 2562906 (O)
     +91 9388472745 (M)
alternative e-mail: <email address hidden>
<email address hidden>

Michael Lueck (mlueck) wrote :

@sonal Kumar Jain #114

>Should I try grub legacy (old grub)??

Absolutely not! Grub2 has been the Ubuntu standard since 9.10. Should stay with the common direction and get this bug resolved. Thank you!

Michael Lueck (mlueck) wrote :

@Oliver Grawert #110

One bug I opened against Lucid I even fixed the bug attaching a diff to fix the script. No one ever touched that bug.

So "attaching things" does not guarantee action.

napstr (viraj-kamboj) wrote :

even i am having the same problem as sonal kumar jain, that after running
sudo update-grub
i got the same log..........
By the way i have winXP SP2 and was having ubuntu 9.10 alongside....yesterday night i upgraded to 10.04, but didnt knew that this would happen...
i have done this sudo update thing. So please suggest me what to do next so as that i can work again in windows.

PS: does reinstalling grub2 will fix this?

Waiting for replies from all.!!!!!

I added the redhat entry manually in my grub2 menu using
"/etc/grub.d/40_custom" file..
Now i could able to boot in my redhat also

On Sun, May 2, 2010 at 2:52 PM, napstr <email address hidden> wrote:

> even i am having the same problem as sonal kumar jain, that after running
> sudo update-grub
> i got the same log..........
> By the way i have winXP SP2 and was having ubuntu 9.10
> alongside....yesterday night i upgraded to 10.04, but didnt knew that this
> would happen...
> i have done this sudo update thing. So please suggest me what to do next so
> as that i can work again in windows.
>
> PS: does reinstalling grub2 will fix this?
>
> Waiting for replies from all.!!!!!
>
> --
> [Lucid] no GRUB menu entry for other operating systems
> https://bugs.launchpad.net/bugs/570765
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Release Notes: Fix Released
> Status in “ubiquity” package in Ubuntu: Fix Released
>
> Bug description:
> Release note:
> When installing in a dual boot environment, the other operating system will
> not appear at first in the GRUB menu. Installing the available updates and
> rebooting will fix this issue.
>
> Original report follows:
> Binary package hint: ubiquity
>
> Installed 10.04 amd64 in a VM with WinXP pre-installed. I chose a dual
> boot install with each OS having 50% of the disk space.
>
> After install and reboot, however, I noticed that grub does not have a menu
> entry for Windows at all.
>
> I checked the partition table and XP is still there, so perhaps I could
> manually fix this, however, the problem remains that my side-by-side install
> fails because Grub did not create a boot entry for Windows.
> ---
> Architecture: amd64
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64
> (20100427.1)
> Package: ubiquity (not installed)
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
> Tags: lucid
> Uname: Linux 2.6.32-21-generic x86_64
>
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/570765/+subscribe
>

--
****************************************

Sonal Kumar Jain
RF, Space Physics Laboratory
Vikram Sarabhai Space Centre
Trivandrum 695022
INDIA

Ph: +91 471 2562906 (O)
     +91 9388472745 (M)
alternative e-mail: <email address hidden>
<email address hidden>

napstr (viraj-kamboj) wrote :

I forgot to mention that at boot time i had the list coming already i.e. windows and linux

the problem is still that when i click on to the Windows loader , a cursor just simply starts blinking on an empty screen for eternity.

@Sonal: i did the same what u wrote, but seems it is for displaying the menu. My problem is coming after it i.e on clicking it i am not able to process any further.

Waiting for help!

M Henri Day (mhenriday) wrote :

Napstr, you might want to take a look at the separate bug report (#571893) I filed ; thanks to Takkat, who posted a link to the Source Forge testdisk app, you may well be able to find a solution to your problem there. Ironically enough, the solution posted by Takkat didn't suffice to resolve his own problem, but it certainly worked for me !...

Henri

Mathieu Marquer (slasher-fun) wrote :

@napstr : This is a bug report form, not a help forum. Please use a forum if you need help, and open a separate bug report if you believe you've found a bug. Thanks.

napstr (viraj-kamboj) wrote :

@M Henri Day: it worked for me. Thanks.
@ mathieu marquer: sorry bro!
@Takkat: hope u get the way out of the bug soon.I would post it as soon as i get a solution.

Cheers to the community!

M Henri Day (mhenriday) wrote :

Glad that it worked for you, napstr ! You might want to consider logging in once again to #571893 and clicking the «This bug affects you» button, so that the developers realise that the problem deserves serious consideration....

Henri

Luqe (luqeckr) wrote :

my grub menu just appear about a half second(very fast), and then dissapear
even if i keep pressing my keyboard many times, the menu is not freeze

it seem that the timeout is not working here, the same problem when i install
karmic koala.

but the grub menu listing is normal (windows and linux is listed)

i have run "sudo update-grub" many times, but still i can't access the grub menu
# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.32-21-generic
Found initrd image: /boot/initrd.img-2.6.32-21-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows NT/2000/XP on /dev/sda1
Found Microsoft Windows XP Home Edition on /dev/sda2
done

this is really annoying bug.. btw, i'm using MSI Wind U100

any other solution guys ? thx

M Henri Day (mhenriday) wrote :

Luqe, your problem has nothing to do with the bug described here ; a more suitable venue for discussing it would have been the Ubuntu fora. Be that as it may, to resolve the problem you can install the «StartupManager» from Synaptic, and then edit the timeout via System → Administration → StartupManager....

Henri

I noticed this after ubuntu 10.04 had more than 50% of the drive, but before when I dual booted with less than 50% allocated to ubuntu 10.04 It did recognize my other os.

Displaying first 40 and last 40 comments. View all 126 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers