Mouse pointer disappear after screensaver resume

Bug #569821 reported by Fabio Marconi on 2010-04-25
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: Gnome-screensaver

Everytime when resuming from a long time of inactivity, the mouse pointer disappear, is there but is invisible.

tags: added: iso-testing
Evan (ev) wrote :

This is not a bug in the installer. Moving to gnome-screensaver.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Fabio Marconi (fabiomarconi) wrote :

The problem persist and it's annoying

description: updated
summary: - Mouse pointer can disappear after screensaver resume
+ Mouse pointer disappear after screensaver resume
Fabio Marconi (fabiomarconi) wrote :

The problem is present during install of Xubuntu 20100901, when screensaver start, at the resume the pointer is invisible.

billjoie (joie-bill) wrote :

I cannot reproduce this bug with Ubuntu 10.10 (not fresh install, upgraded from 10.04). After resuming from screensaver, my cursor is alway present. gnome-screensaver 2.30.0-1ubuntu1. This is true whether I lock the screensaver or not.

RedSingularity (redsingularity) wrote :

Fabio, how can I reproduce this event on my machine?

Fabio Marconi (fabiomarconi) wrote :

Hello RedSingularity
Just now i'm testing Xubuntu 20101008.1 and it happens again during install.
Installing the screeng goes black and when i mouve the mouse the desktop appears but with invisible pointer.
This time i cannot see in Ubuntu testing.
Is a random bug.
Tried to reproduce two times on installed system and don't appear.
Now i go to test another install then i report

Fabio Marconi (fabiomarconi) wrote :

Yes reproduced again.
Start a live cd and install, let the screen go black and let it black for about 10 minutes, move mouse to resume and the pointer is invisible
version tested
Xubuntu amd64 20101008.1

Fabio Marconi (fabiomarconi) wrote :

reproducible if launch install by live session or if lauched from plymouth

RedSingularity (redsingularity) wrote :

I tried several times to reproduce this bug. I cannot get it though. I am using the most recent version of Xubuntu. It may have been a problem in just a few releases. Let me know if you reproduce it again and tell me which candidate of Xubuntu you are using. Thanks.

Fabio Marconi (fabiomarconi) wrote :

Hello RedSingularity
I can reproduce it everytime with a Xubuntu install.
Now i'm trying Xubuntu desktop 201008.1 i386
here the video
http://www.youtube.com/watch?v=9GkRIAhfb10

Fabio Marconi (fabiomarconi) wrote :

At now i cannot reproduce on installed system

Fabio Marconi (fabiomarconi) wrote :

from installer/debug
WARNING: Could not open DriverDB cache /var/cache/jockey/driverdb-OpenPrintingDriverDB.cache: [Errno 2] No such file or directory: '/var/cache/jockey/driverdb-OpenPrintingDriverDB.cache'
WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl
form /installer/syslog
Oct 9 10:49:57 ubuntu ubiquity: Elaborazione dei trigger per libc-bin...
Oct 9 10:49:57 ubuntu ubiquity: ldconfig deferred processing now taking place <---update during install
Oct 9 10:49:57 ubuntu ubiquity: Elaborazione dei trigger per software-center...
Oct 9 10:49:59 ubuntu ubiquity: No protocol specified
Oct 9 10:49:59 ubuntu ubiquity: /usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
Oct 9 10:49:59 ubuntu ubiquity: warnings.warn(str(e), _gtk.Warning)
Oct 9 10:50:00 ubuntu ubiquity: WARNING:root:Failed to setup dbus (ignoring)
Oct 9 10:50:38 ubuntu ubiquity: Elaborazione dei trigger per python-support...
Oct 9 10:50:38 ubuntu ubiquity: Elaborazione dei trigger per python-central...

Fabio Marconi (fabiomarconi) wrote :

Installer syslog

Fabio Marconi (fabiomarconi) wrote :

installer debug

Fabio Marconi (fabiomarconi) wrote :

installer debug

Fabio Marconi (fabiomarconi) wrote :

Reproduced again and immediatly after screen goes black.
I notice that if i select, from plymouth to install, when the process start i cannot click on the tringle to show up the Skip button.
All my tests are done on real hardware and all images are downloaded with zsync.

To clarify, are you having this problem with a Live CD or with a fully installed system? I have been trying it on a Live CD. I never actually installed Xubuntu it to my hard drive. Is yours installed to your hard drive when the problem is occurring? If it is I will fully install Xubuntu and try again to reproduce.

Fabio Marconi (fabiomarconi) wrote :

Hello RedSingularity.
In this release i've noted this problem only with Xubuntu installations during install process in real hardware (not vm).
I'm an Iso tester and i have reproduced this issue on 6 installation of i386 and amd64
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

The installations are made from usb

Ok. I have a spare machine so I will try it on some actual hardware. One more question. What program do you use to make the USB? Thanks.

Fabio Marconi (fabiomarconi) wrote :

I use startup disk creator

I have just tried it on my laptop. I still cannot reproduce it though. Now that the final release is out try that on your computer and report back when your done.

Marking as incomplete for now.

Changed in gnome-screensaver (Ubuntu):
status: New → Incomplete
Changed in gnome-screensaver (Ubuntu Maverick):
status: New → Incomplete
Otto Kekäläinen (otto) wrote :

This bug is likely to be in X rather than the screensaver. There are several duplicates with same symptoms.

Ah, thats a good point. If it is X then maybe i cannot reproduce it because I do not have the same hardware configuration. Graphics wise i mean.

Changed in gnome-screensaver (Ubuntu Maverick):
status: Incomplete → Invalid
Changed in gnome-screensaver (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments