Ubuntu 10.04-rc desktop installer unreverable error

Bug #569214 reported by Kenyon Karl on 2010-04-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

In trying to run Ubuntu 10.04 RELEASE CANDIDATE - LIVE from CD-ROM, the desktop installer encountered an irrecoverable error on my IBM Thinkpad T42 laptop. As a result, I could not proceed any further with 10.04 RC testing!

Note that this report was submitted from my Ubuntu 9.10 system in hope that it will give you the hardware configuration of my machine. Note that I could not get far enough with the 10.04 RC to report while running that OS. :-(

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 2f46bfa49172683ab4caae9e727080e9
CheckboxSystem: b1cca5f799a911bbb44e7180c2fd235d
Date: Fri Apr 23 17:50:55 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/yelp
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: yelp 2.28.0-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
SourcePackage: yelp
Uname: Linux 2.6.31-20-generic i686
XsessionErrors:
 (gnome-settings-daemon:1753): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:1753): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:1853): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:1869): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-panel:1852): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Kenyon Karl (kenyon-karl) wrote :
Iiro R-J (irj-iki) wrote :

I can confirm this bug in IBM Thinkpad T43, a next model in same series.
The installer tries for a long time and then spits:
"The installer encountered an unrecoverable error..." and the system reboots.
I have also tried to install from USB and from DVD. Same behavior.

coldrol (hidegrol) wrote :

I can confirm on T42 too. Tried with nomodset=off, but the same problem exist:
"The installer encountered an unrecoverable error..."

Michael Losonsky (michl) wrote :

I think this is the same issue reported in #569973.
I have the same problem on Dell C610 laptop.

Changed in ubuntu:
status: New → Confirmed
Ara Pulido (ara) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in ubiquity.
For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

affects: ubuntu → ubiquity (Ubuntu)
Ara Pulido (ara) wrote :

In order to process your bug, we would need some missing information.

Can you please attach to this bug report the following files in the broken system:

/var/log/syslog and everything under /var/log/installer

If you can access a deskop session after the crash, you can collect all the required information running in a terminal:

$ apport-collect 569214

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Michael Losonsky (michl) wrote :

Here is the syslog from /var/log/installer

Michael Losonsky (michl) wrote :

Here is the /var/log/syslog

Kenyon Karl (kenyon-karl) wrote :

This issue has been SOMEWHAT resolved in the final release. On the first of two tries with a CD-ROM burned from the ISO that I downloaded on Apr 29, 2010, the machine booted nicely, I checked the disk for errors (none) and then entered into a Live session without any problems whatsoever. However, I had to reboot halfway through system testing because of a failure of video modes that I don't normally use. On second reboot from the CD-ROM I waited through the timeout and thus went directly to the Live session. The unrecoverable message DID appear, but that did not stop progress into the live session.

Michael Losonsky (michl) wrote :

I tried the April 29 release live on the Dell C610 laptop and
received the unrecoverable message and the machine
froze.

Michael Losonsky (michl) on 2010-05-02
Changed in ubiquity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers