ubiquity crashes on manual disc setup

Bug #563309 reported by marcinq on 2010-04-14
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan

Bug Description

Please grant a freeze exception for the following fix. This change brings the KDE frontend in line with the GTK frontend by disabling the interface when the installer is in the middle of a partitioning step. Without this in place, the user could edit a partition, press okay, then delete a partition, and the installer would crash because the editing step had not finished yet.

http://launchpadlibrarian.net/44770414/563309.patch

Original report follows:

Binary package hint: ubiquity

Crash with manual partitioning while trying to select one of existing partitions. Happens in both beta2 livecd and daily live from 14-04-2010

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/PartMan.py", line 392, in on_partition_list_treeview_activated
    self.partman_edit_dialog(devpart, partition)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_components/PartMan.py", line 340, in partman_edit_dialog
    self.ctrlr.dbfilter.edit_partition(devpart, **edits)
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 2282, in edit_partition
    assert self.current_question == 'partman/choose_partition'
AssertionError
---
Architecture: amd64
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Kubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100414)
Package: ubiquity 2.2.16
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-20-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

marcinq (marcinq) wrote :
marcinq (marcinq) wrote :
marcinq (marcinq) on 2010-04-14
tags: added: lucid
Evan (ev) wrote :

Can you please run the installer in debug mode and attach a new set of logs? You can do this by booting into the "Try or Install Kubuntu" option. Once at the desktop press alt-F2 and type `ubiquity -d`, then press enter. Run the installer until it crashes, repeating the same steps you did before, then press alt-F2 again and type `apport-collect 563309`.

Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Jonathan Riddell (jr) wrote :

I can't recreate this on a virtual machine

marcinq (marcinq) wrote : Casper.gz

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

Evan (ev) wrote :

I can reproduce this by changing the mounpoint of an existing partition to /home.

Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
Evan (ev) wrote :

I can reproduce this by changing the mountpoint of an existing partition to /home.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04
Evan (ev) wrote :

Ah, it occurs on the second mount point you change. I don't think the KDE frontend is passing data back to the dbfilter after it changes a mountpoint.

Evan (ev) wrote :
Evan (ev) wrote :
Evan (ev) wrote :
marcinq (marcinq) wrote :

Just to confirm:

I select partition and mount point for "/" from existing partitions list, then after accepting it doesn't get chenged/selected at all on the main parted window . Selecting it for the second time makes it appear on the main list but then the crash happens.

So well I even could not select /home which would be my next step in the installation process.

Evan (ev) wrote :

Looking into this a bit further, this seems to be a matter of the KDE frontend not calling allow_change_step(False) while processing after a partition is edited in the UI (which is probably exacerbated by the recent slowness of the KDE frontend). Giving the partitioner sufficient time to complete each step does not result in an AssertionError.

I haven't managed to reproduce this using an English locale.

Evan (ev) on 2010-04-16
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
status: Triaged → In Progress
Evan (ev) on 2010-04-16
Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :

Second time I managed to recreate, logs on bug 564955

Changed in ubiquity (Ubuntu):
status: Fix Committed → Confirmed
Jonathan Riddell (jr) wrote :

reverting status, I changed without noticing evan had already committed a fix

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Evan (ev) wrote :
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.20

---------------
ubiquity (2.2.20) lucid; urgency=low

  * Use allow_change_step(False) from the KDE portions of the partman
    component when necessary (LP: #563309).
 -- Evan Dandrea <email address hidden> Mon, 19 Apr 2010 09:21:49 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers