Truncated text in Ubiquity after selecting Hebrew

Bug #560114 reported by Shlomil on 2010-04-10
46
This bug affects 20 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

In Ubiquity (GTK), after selecting Hebrew (or any other Right To Left language) the entire GUI will be flipped and the text displayed on the first screen is truncated. It looks like the language selector overlaps the welcome text.

Steps to reproduce:
1. Reboot from the Ubuntu Desktop live CD.
2. In the first screen select Hebrew - the screen will be flipped and truncated text will be displayed.
OR
2. Select "Try Ubuntu.."
3. After Desktop is loaded click the "Install Ubuntu" icon - ubiquity will start.
4. In Ubiquity's first screen select "Hebrew" - the screen will flip and text will

Please note that I think this bug might be related to LP bug #557164 (the fix might be the same) but I think my case is more related to the flipping of the entire GUI (which doesn't occur in Spanish).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.15
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Fri Apr 9 01:14:19 2010
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=he_IL.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Related branches

Shlomil (shlomister) wrote :
Evan (ev) on 2010-04-16
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.18

---------------
ubiquity (2.2.18) lucid; urgency=low

  [ Evan Dandrea ]
  * Force garbage collection so we don't end up with stray X resources
    when we kill the X server (LP: #556555).
  * Fix the Portuguese and Latvian translations of the variable name
    RELEASE (LP: #564517).
  * Fix a missing closing bold tag in the Portuguese and Polish
    translations (LP: #564545).
  * Fix labels not expanding vertically to fit their text (LP: #560114,
    LP: #557164, LP: #520898).
  * Do not translate variable names in the Amharic translation
    (LP: #564582).
  * Start the window manager via ck-launch-session so pulseaudio is
    granted access to the sound devices (LP: #549738).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup
    1.34ubuntu14, flash-kernel 2.13ubuntu16, hw-detect 1.73ubuntu3,
    partman-auto 89ubuntu6, partman-base 139ubuntu5, partman-ext3
    58ubuntu3, partman-target 64ubuntu8, user-setup 1.28ubuntu6.

  [ Colin Watson ]
  * Break out of oem-config-firstboot's main loop if oem-config-wrapper
    succeeds (LP: #558593).
  * Quit plymouth before starting either the emergency noninteractive
    ubiquity frontend in automatic mode, or oem-config's debconf frontend.
  * Get a controlling terminal before starting bterm, as otherwise bterm
    won't reliably be able to take console input.
 -- Evan Dandrea <email address hidden> Fri, 16 Apr 2010 15:28:19 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Shlomil (shlomister) wrote :

tested with 2.2.18
Hebrew text still gets truncated.

Changed in ubiquity (Ubuntu):
status: Fix Released → New
Shlomil (shlomister) wrote :

It seems like when commenting out the following line (line 85 at gtk_ui.py) :
   layout.set_width(allocation.width * pango.SCALE)
The Hebrew text is displayed perfectly.

Evan, the fix you published deals with a vertical fitting issue while this bug is about horizontal truncating of the text.

if you want to keep that line on non-rtl languages we can always do something like the following:

85,86c85
< if gtk.widget_get_default_direction() != gtk.TEXT_DIR_RTL:
< layout.set_width(allocation.width * pango.SCALE)
---
> layout.set_width(allocation.width * pango.SCALE)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.23

---------------
ubiquity (2.2.23) lucid; urgency=low

  * Correctly select the detected timezone (LP: #559647).
  * Don't reboot on failure if we say we're not going to.
  * Always run wrap_fix in its entirety, even if the width or height
    hasn't changed, as we may have switched text direction since the
    last run (LP: #560114).
  * Properly align keyboard_test_label, which was getting cut off in RTL
    languages with the wrap_fix in place.
 -- Evan Dandrea <email address hidden> Mon, 26 Apr 2010 17:00:55 +0100

Changed in ubiquity (Ubuntu):
status: New → Fix Released
Shlomil (shlomister) wrote :

Tested 2.2.23 and text is still truncated in welcome screens and TZ-Select screens.

Changed in ubiquity (Ubuntu):
status: Fix Released → New
Shlomil (shlomister) wrote :

This bug had the honor of being mentioned in a review by one of the major and most popular Israeli newspapers aka YNet - (warning - lots of flash ahead):
http://tinyurl.com/ynet-10-04-article-translated

The author refers to is as a "slight problem of the alignment to right".
Other that this annoying bug, the Hebrew installation could have been perfect :-\

Yaron (sh-yaron) wrote :

Can't we use the button's position in order to correctly align the labels?

Shlomil (shlomister) wrote :

Yaron: What button are you referring to?

The cause for the problem is (IMO) the 'layout.set_width' line.
Last time I tried (which was about a year ago), removing this line solves the problem.

Some hints from the devs regarding the role of this line might help as it seems that removing it doesn't affect other languages.

Yaron (sh-yaron) wrote :

That was before the explanation you gave on G+, I will do my best to pull some strings and get this over with.

Thank you for your efforts!

Colin Watson (cjwatson) wrote :

No, simply removing that line or making it RTL-specific doesn't make sense, I'm afraid. Either layout.set_width is needed in all languages, or it isn't needed in any languages: it doesn't make sense for it to be LTR-specific. It *does* affect LTR languages; if you boot to a live CD desktop ("Try Ubuntu") in current Oneiric, comment out the layout.set_width line in /usr/lib/ubiquity/ubiquity/frontend/gtk_ui.py, run ubiquity, and go to the second page in English, you'll see that the layout of the "Ubuntu uses third-party software ..." label is poor: it doesn't use the full width of the window as it should. This is, as I understand it, exactly the problem Evan was trying to solve with this function.

It looks to me as though what's happening is that we're setting the correct width in the RTL case, but the left-hand X coordinate for the layout isn't being updated to match, so the layout overflows the right-hand side of the screen. Could you look at fixing this instead?

This may well be moot for Oneiric anyway, since we should be on GTK+ 3 by then, but it wouldn't hurt to investigate this in the meantime.

tags: added: ubiquity-2.2.15
דוביקס (dovix2003-gmail) wrote :

The texts are no longer cut in the current beta. However, there's one sentence that does not display correctly, see the attached screenshot (sentence below the first checkbox):

http://www.imagebanana.com/view/un0z2d4l/hebmessed.png

(compare this to https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/798768/+attachment/2172899/+files/Ubuntu2.png)

This is how the text should display (taken from Libre Office):

http://www.imagebanana.com/view/dktkfdv7/correct.png

Shlomil (shlomister) wrote :

Hi Dovix,

I can confirm that this bug seem to have been solved in Oneiric Beta1 .
Probably the move to Gnome3 included some fix for it.

Since we have 2 confirmations that this bug doesn't appear on 11.10Beta1 we should probably close it.
I just wonder who/what fixed it.

Offtopic:
The sentence in your screenshot starts with LTR letter and that's why the direction of the label is assumed to be LTR which explain the left aligning. Moreover, the translated label text contains both Hebrew and English words which contributed to the mess. This is a translation issue (and unrelated to the current bug). I already reported it to Yaron.S and he added RLE chars where needed in that string. It will probably be fixed in next release.

Changed in ubiquity (Ubuntu):
status: New → Fix Released
Shahar Or (mightyiam) wrote :

Nice work RTL Team!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers