[Lucid] "Where are you?" screen doesn't select timezone

Bug #559647 reported by Fido on 2010-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan
Lucid
High
Evan

Bug Description

Binary package hint: ubiquity

When installing the current daily built of Lucid, at the second step ("Where are you?" screen) the timezone isn't selected when picking it from the map. In order to make it work is necessary first to select a region (any region), and after that you can choose your timezone from the map as usual.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.15
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
Architecture: i386
Date: Fri Apr 9 22:15:07 2010
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Fido (fedevera) wrote :
tags: added: iso-testing

HI, I think that should be fixed. Thanks for the report

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Fido (fedevera) wrote :

This bug is still present in the latest Ubuntu daily built.
As an additional note, I first started the LiveUSB and then click on 'Install Ubuntu 10.04'.

Evan (ev) on 2010-04-21
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
status: Confirmed → Triaged
Evan (ev) wrote :

This appears to be because the geoip server reports America/Mendoza whereas tzsetup interprets that timezone as Argentina/Mendoza. The installer should also fail more gracefully on timezones it does not understand.

Evan (ev) on 2010-04-26
Changed in ubiquity (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.23

---------------
ubiquity (2.2.23) lucid; urgency=low

  * Correctly select the detected timezone (LP: #559647).
  * Don't reboot on failure if we say we're not going to.
  * Always run wrap_fix in its entirety, even if the width or height
    hasn't changed, as we may have switched text direction since the
    last run (LP: #560114).
  * Properly align keyboard_test_label, which was getting cut off in RTL
    languages with the wrap_fix in place.
 -- Evan Dandrea <email address hidden> Mon, 26 Apr 2010 17:00:55 +0100

Changed in ubiquity (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers