Timezone page doesn't come up until network cable is unplugged

Bug #556890 reported by Mario Limonciello on 2010-04-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
tzsetup (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

In testing a daily image, I'm finding that the second ubiquity page for timezone selection is causing Ubiquity to hang. Once I remove the network cable, the page shows up.

This appears to be because http://geoip.ubuntu.com will resolve from my network but is not accessible. I switched to a VT and saw a pending wget of that URL.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: ubiquity 2.2.14
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Tue Apr 6 22:10:06 2010
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity

Mario Limonciello (superm1) wrote :
Evan (ev) on 2010-04-07
Changed in ubiquity (Ubuntu):
status: New → Invalid
Changed in tzsetup (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzsetup - 1:0.26ubuntu7

---------------
tzsetup (1:0.26ubuntu7) lucid; urgency=low

  * Add a 15 second timeout to the wget of geoip.ubuntu.com
    (LP: #556890).
 -- Evan Dandrea <email address hidden> Wed, 07 Apr 2010 11:00:33 +0100

Changed in tzsetup (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

This will have broken d-i; see my comment in bug 519756, which is the same bug.

Mario Limonciello (superm1) wrote :

I can still reproduce this with ubiquity 2.2.20 (which includes tzsetup 1:0.26ubuntu8).

It's not entirely clear to me, but it appears that the timeout parameter might need to be specified before the URL in the wget command line.

Changed in tzsetup (Ubuntu):
status: Fix Released → New
Mario Limonciello (superm1) wrote :

Actually it looks like it was because of the retries. The default number of times to retry is 20 times, and this took approximately 5 minutes (15sec x 20 times / 60 ) ~ 5 min. So it should only be trying 1.

Colin Watson (cjwatson) on 2010-04-21
Changed in tzsetup (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tzsetup - 1:0.26ubuntu9

---------------
tzsetup (1:0.26ubuntu9) lucid; urgency=low

  * Only try to wget from geoip.ubuntu.com once, at least if we have
    non-busybox wget (LP: #556890).
 -- Colin Watson <email address hidden> Thu, 22 Apr 2010 00:01:59 +0100

Changed in tzsetup (Ubuntu):
status: Fix Committed → Fix Released
Jerone Young (jerone) on 2010-04-23
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers