oem-config loops indefinitely in Kubuntu OEM installations

Bug #556555 reported by Ara Pulido on 2010-04-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan
Lucid
High
Evan

Bug Description

Binary package hint: ubiquity

Using Kubuntu Lucid Beta 2 candidate images (20040406)
After finishing the installation, running oem-config and rebooting, the configuration for the final user, when reached the last step cycles back to the beginning of the configuration process.

Ara Pulido (apulido) wrote :
Ara Pulido (apulido) wrote :
Ara Pulido (apulido) wrote :
tags: added: iso-testing
Jonathan Riddell (jr) wrote :

debug log has the same traceback as bug 556436 maybe it's the same issue and should be solved by my recent commit

Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
tags: added: kubuntu
Ara Pulido (apulido) wrote :

I am afraid it does not solve it. With the latest images bug 556436 is solved, but this one persists.

Jonathan Riddell (jr) on 2010-04-07
Changed in ubiquity (Ubuntu Lucid):
status: New → Confirmed
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Ara Pulido (apulido) wrote :

With bug bug 556436 now, it does not crash, but it keeps looping without finishing the OEM configuration. I am attaching the new logs.

Ara Pulido (apulido) wrote :
  • Ne Edit (1.9 KiB, text/plain)
Ara Pulido (apulido) wrote :
Ara Pulido (apulido) wrote :
Ara Pulido (apulido) wrote :
Steve Langasek (vorlon) on 2010-04-08
Changed in ubiquity (Ubuntu Lucid):
importance: Undecided → High
Jonathan Riddell (jr) wrote :

Still on today's CD. Hard to tell what part is crashing. When running oem-config on its own I couldn't recreate the problem.

Evan (ev) on 2010-04-15
Changed in ubiquity (Ubuntu Lucid):
assignee: nobody → Evan Dandrea (ev)
Evan (ev) on 2010-04-15
Changed in ubiquity (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.18

---------------
ubiquity (2.2.18) lucid; urgency=low

  [ Evan Dandrea ]
  * Force garbage collection so we don't end up with stray X resources
    when we kill the X server (LP: #556555).
  * Fix the Portuguese and Latvian translations of the variable name
    RELEASE (LP: #564517).
  * Fix a missing closing bold tag in the Portuguese and Polish
    translations (LP: #564545).
  * Fix labels not expanding vertically to fit their text (LP: #560114,
    LP: #557164, LP: #520898).
  * Do not translate variable names in the Amharic translation
    (LP: #564582).
  * Start the window manager via ck-launch-session so pulseaudio is
    granted access to the sound devices (LP: #549738).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup
    1.34ubuntu14, flash-kernel 2.13ubuntu16, hw-detect 1.73ubuntu3,
    partman-auto 89ubuntu6, partman-base 139ubuntu5, partman-ext3
    58ubuntu3, partman-target 64ubuntu8, user-setup 1.28ubuntu6.

  [ Colin Watson ]
  * Break out of oem-config-firstboot's main loop if oem-config-wrapper
    succeeds (LP: #558593).
  * Quit plymouth before starting either the emergency noninteractive
    ubiquity frontend in automatic mode, or oem-config's debconf frontend.
  * Get a controlling terminal before starting bterm, as otherwise bterm
    won't reliably be able to take console input.
 -- Evan Dandrea <email address hidden> Fri, 16 Apr 2010 15:28:19 +0100

Changed in ubiquity (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers