auto-update ubiquity if a newer version is available from internet

Bug #55505 reported by Marco Cimmino on 2006-08-07
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Colin Watson

Bug Description

The problem of ubiquity is:
if a serious/crash bug is fixed _after_ the final release it is not possible to bypass it, the only thing is to manually update it via console.

It can be very usefull to auto-search and auto-update itself if internet and a newer version is available during very first step of installation.

Mateusz Drożdżyński (matid) wrote :

Thanks for your report. Your idea might get more attention and have
the possibility of being implemented if you would submit a
specification for this.

You should first check whether it already exists at the Ubuntu specs
page (https://launchpad.net/distros/ubuntu/+specs) in Launchpad. If
that is the case, feel free to contact the drafter of that spec about
your comments/suggestions. Otherwise you can start writing a spec
following the steps described in
        https://wiki.ubuntu.com/FeatureSpecifications

Changed in ubiquity:
status: Unconfirmed → Rejected
Mateusz Drożdżyński (matid) wrote :

This might be confusing, but your specification was not rejected. I only changed the bug status to 'Rejected' so it doesn't show itself in the Malone, which is not the place to request features.
Your proposition will be considered regardless of this bug and all further status changes will be made on the specification tracker.

Colin Watson (cjwatson) wrote :

Mateusz should not have rejected this bug. While I appreciate help, I wish people wouldn't take items off my to-do list without asking me first! Rejecting bugs on actively-maintained packages should be left to those maintaining the package.

Michael Vogt did some work on this before Dapper at my request, but I haven't yet had time to investigate it. I would like to do it for Edgy. The main consideration is that it has to be optional - you can't have ubiquity hanging at startup because it couldn't talk to the network.

Changed in ubiquity:
status: Rejected → Confirmed
Colin Watson (cjwatson) wrote :

And Mateusz, the specification process is too heavyweight for this IMO. I would rather that that specification did not exist - a bug report is just fine.

Sigh.

Colin Watson (cjwatson) on 2007-03-19
Changed in ubiquity:
importance: Undecided → Wishlist
Colin Watson (cjwatson) on 2009-10-30
Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Colin Watson (cjwatson)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.1

---------------
ubiquity (2.1.1) lucid; urgency=low

  [ Evan Dandrea ]
  * Run success_cmd, error_cmd, and automation_error_cmd as root.
  * Use /cdrom/casper/filesystem.size instead of calculating the size of
    /rofs on each run.
  * Include a progress message for ubiquity/success_command.
  * Do not use the preseeded install progress message as the install
    window title. Use a more understandable string.
  * Check the syntax of any shell scripts in the source tree as part of
    debian/rules check.

  [ Mario Limonciello ]
  * When calling execute_root, don't pass a list because everything
    passed is translated into a tupple. Passing a list causes subprocess to
    fail when invoked.

  [ Colin Watson ]
  * Add a button to the language page to upgrade the installer on the fly,
    based on work by Michael Vogt several years ago (LP: #55505).
  * GTK frontend:
    - Only set the debconf progress window's transience and type hint when
      it isn't already being shown.
  * Automatic update of included source packages: debian-installer-utils
    1.72ubuntu1.
 -- Colin Watson <email address hidden> Fri, 27 Nov 2009 20:02:26 +0000

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers