Freeze exception request: only show update installer link when an update is available.

Bug #554570 reported by Evan on 2010-04-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

sabdfl has requested that we either remove the update installer link from the first page of ubiquity, or only show it when a critical update is available. Please allow a freeze exception for the following patch, which implements this functionality.

It has been suggested by Colin that we host the update hint file on changelogs.ubuntu.com, but if the release team thinks there's a better place for it, I'm open to suggestions.

The code itself is quite small and simplistic, with the only complexity rising from the need to avoid superfluous calls to wget.

http://launchpadlibrarian.net/42970722/554570.patch

Evan (ev) wrote :
description: updated
Steve Langasek (vorlon) wrote :

The implementation seems to rely on a yes/no check of a file on the server - since this is an LTS, the answer to "is there an updated installer available?" might be "yes" for 10.04.0, but "no" for 10.04.1. Shouldn't this be done as a version check?

Also, doesn't the implementation mean the 'update' button will show up initially, and be hidden only once the server has been checked? Shouldn't it be hidden by default?

UIFe granted for the actual UI change, anyway.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Evan (ev) wrote :

I've fixed the update button potentially showing up initially.

Regarding the version check, isn't that what it does already? Is lsb_release -rs not guaranteed to print 10.04.1 with the first lucid point release?

Thanks Steve!

Steve Langasek (vorlon) wrote :

> Is lsb_release -rs not guaranteed to print 10.04.1 with the first lucid point release?

Afraid not; we update the description (lsb_release -d), but not the release version on point releases because some software in the wild (including the Ubuntu hardware db) expects the version number to remain constant.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.16

---------------
ubiquity (2.2.16) lucid; urgency=low

  [ Evan Dandrea ]
  * Only show the update link and release notes when a critical update
    is available (LP: #554570).
  * Fix backing up to the language page in the KDE frontend (LP: #557225).
  * Bring back the debconf translation for password_extra_label. The
    KDE frontend still uses it (LP: #557192).
  * Fix a small typo that was preventing the duration string on the
    language page from being translated (LP: #551633).
  * Fix backing up past partitioning when manual partitioning was
    selected (LP: #557210).
  * Let the user know why we're starting a desktop session or rebooting
    when ubiquity in only mode crashes. If in automatic mode, the
    default is to reboot. Preseed ubiquity/reboot_on_failure to false
    to start a desktop session instead (LP: #558371).
  * Make oem-config/install-language-support false by default. OEMs
    should only be turning this on if they've provided all the possible
    langpacks in oem-config/repository or can guarantee an Internet
    connection (LP: #539710).
  * Call ubiquity/failure_command if we crash in only ubiquity mode.

  [ Amichai Rothman ]
  * Fix KDE frontend's slideshow links not working (LP: #540278)
  * Fix KDE progress bar and skip button too small (LP: #555707)
  * Fix KDE skip button appearing as full-width button at the
    bottom of the window and messing up dialog layout (LP: #540321)
  * Fix progress bar updated file count out of range (LP: #550147)
  * Fix progress title not shown during some configuration steps

  [ Colin Watson ]
  * Update handling of "Ready to install" etc. templates to account for the
    removal of the separate welcome page.
  * KDE frontend:
    - Hide install_process_label ("installation process") and
      breadcrumb_install ("Install") when running as oem-config; providing
      alternative strings would break string freeze, and the UI should look
      OK without them (LP: #540929).
  * GTK frontend:
    - Re-fetch translations before calling plugin_translate (LP: #552673).
  * Update translations from Launchpad.
  * Automatic update of included source packages: partman-auto 89ubuntu5,
    tzsetup 1:0.26ubuntu7.
 -- Colin Watson <email address hidden> Fri, 09 Apr 2010 19:29:50 +0100

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers