Keyboard indicator not enabled by default for non-English installations of Kubuntu

Bug #550704 reported by RussianNeuroMancer on 2010-03-29
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
KDE Base
Fix Released
Medium
Ubuntu Translations
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
ubuntu-meta (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Keyboard indicator not enabled by default for non-English installations of Kubuntu.

Shriramana Sharma (jamadagni) wrote :

It also is not enabled by default for *English* installations of Kubuntu.

I think it's not needed for English installations, but need for installation in other languages.

Jonathan Thomas (echidnaman) wrote :

Actually, my English install does have this by default...

I'm not sure that you understand me correctly.
Keyboard Layout, as I understand it, allows you to show what language is selected at this time. People who write in English only, do not need to Keyboard Layout. All the rest need a Keyboard Layout enabled by default, because the system is used not only in English.

Harald Sitter (apachelogger) wrote :

The indicator has nothing to do with the default keyboard setting. If you have an english keyboard layout setup in a russion environment then I would think that you might have choosen the wrong layout at installation (there is an own page that allows you to configure and try the keyboard layout).

Changed in kubuntu-meta (Ubuntu):
status: New → Invalid

> If you have an english keyboard layout setup in a russion environment then I would think that you might have choosen the wrong layout at installation (there is an own page that allows you to configure and try the keyboard layout).
I talk not about this.

> The indicator has nothing to do with the default keyboard setting.
Easy example:

Windows:
English user install English Windows - indicator is disabled. it's correct behavior.
Russian (or other country) user install Russian (or other language) Windows - indicator enabled by default. it's correct behavior.

Kubuntu (I just don't know situation in Ubutnu):
English user install Englush Kubuntu - indicator is disabled. it's correct behavior.
Russian (or other country) user install Russian (or other language) Kubuntu - indicator is disabled. it's incorrect behavior!

Now you see?

Changed in kubuntu-meta (Ubuntu):
status: Invalid → New
David Planella (dpm) wrote :

Thanks for reporting this bug. I'm marking the translations task as Invalid, since it does not directly affect translations or can be fixed there, and there is the 'kubuntu-meta' task to track it.

As per the you are expecting, I'm not sure this is the expected behaviour. I personally find that there is no need for the system to tell me which language it is in, as I can see that in the menus, apps, etc. I only find the keyboard indicator useful if I need to switch between different keyboard layouts, which the majority of users won't have to do, regardless of whether their installation is in English or in another language. Barring the design differences, in GNOME, as another example, the keyboard indicator applet is not enabled by default.

Changed in ubuntu-translations:
status: New → Invalid
Nevill (spb-nevill) wrote :

> I only find the keyboard indicator useful if I need to switch between different keyboard layouts, which the majority of users won't have to do, regardless of whether their installation is in English or in another language.

You do realise that there are quite a few users for whom English isn't a native language? And yet, they need to write in English - to browse sites, at the very least. To do so they must switch between keyboard layouts, and the layout indicator is essential to see in what language they are about to write.

It is not a convenience, it is a necessity.

> Barring the design differences, in GNOME, as another example, the keyboard indicator applet is not enabled by default.
So, then this problem affected to Ubuntu too, right?

Harald Sitter (apachelogger) wrote :

a) You do not need to switch your keyboard layout to write in english
b) If a user selects the us layout as default keyboard layout at installation _even though_ the installer defaults to a sensible default for the language selected earlier, it is to be assumed that the user either preferres the us layout to begin with or is indeed native us user and just happens to live somewhere else (for whatever reason there is).

Showing an indicator to switch the keyboard layout in cases where layout != locale layout is simple pointless. You can't even list another layout because for some locales there are multiple different layouts and you wouldnt know which one to list. If you care to be able to switch the keyboard layout at runtime, then there is appropriate functionallity around to make this happen, but there is no reason why the average user would need this.

Changed in kubuntu-meta (Ubuntu):
status: New → Won't Fix

Harald Sitter wrote:
> a) You do not need to switch your keyboard layout to write in english
> b) If a user selects the us layout as default keyboard layout at installation _even though_ the installer defaults to a sensible default for the language selected earlier, it is to be assumed that the user either preferres the us layout to begin with or is indeed native us user and just happens to live somewhere else (for whatever reason there is).
>
> Showing an indicator to switch the keyboard layout in cases where layout
> != locale layout is simple pointless. You can't even list another layout
> because for some locales there are multiple different layouts and you
> wouldnt know which one to list. If you care to be able to switch the
> keyboard layout at runtime, then there is appropriate functionallity
> around to make this happen, but there is no reason why the average user
> would need this.

Harald,
you are forgetting the countless users who speak a language which does
not use Latin script, but Cyrillic, Arabic, Hebrew, Thai, Lao, Khmer,
etc. . Those keyboards have two modes, one for Latin (ususally QWERTY
layout, although Morocco also has AZERTY) and one for the native script.
On some keyboards there is a dedicated key to switch the layout, on
others the user needs to use a key combination. However, there is no
visual indicator on the keyboard that tells the user in which mode it
is. Therefore I think this request is totally valid.
What's more, given the high number of migrants and bilingual users with
non-Latin script languages in Europe and the US, I would even go that
far to install this layout indicator/switcher by default for _every_
user, even if the user chooses to use English as his primary language.

Cheers
Arne

Harald or David, you can add Ubuntu to affected project?

Changed in kubuntu-meta (Ubuntu):
status: Won't Fix → New
Harald Sitter (apachelogger) wrote :

Ubuntu is not affected due to the very same reasoning as stated earlier.

Changed in kubuntu-meta (Ubuntu):
status: New → Won't Fix

Harald, it's look like you completly not understand, what we talking about! Please, read Arne Goetje comment carefully.

description: updated

With all due respect to the staff Canonical, please talk about this issue with members of the Ubuntu Translators Team, before the next time to change the status of this bug. I hope that they will be able to explain the situation on this issue to you.

Changed in kubuntu-meta (Ubuntu):
status: Won't Fix → New

Russian (Israeli, Greek and so on) users have to switch between RU (or some other) and USA layout. And the layout switcher enabled by default is necessary in this situation.

Russian language have these letters: «абвгдеёжзийклмнопрстуфхцчшщъыьэюя». Some of them looks like Latin symbols, but Cyrillic 'a' (ah) is not the same as Latin 'a' (ei). And these two symbols have different unicode codes. You can't write «google» using Cyryllic 'o'. We press layout switcher hotkey to select US layout and write «google».

Harald Sitter (apachelogger) wrote :

Whoops. Wrong bug.

Anyhow. This needs to be reported at http://bugs.kde.org and implemented there, it will then arrive in Kubuntu once KDE releases this feature.

Changed in kubuntu-meta (Ubuntu):
assignee: nobody → Harald Sitter (apachelogger)
status: New → Invalid

>Whoops. Wrong bug.

>Anyhow. This needs to be reported at http://bugs.kde.org and implemented there, it will then arrive in Kubuntu once KDE releases this feature.

No, it is not a truth. In other distros (I tried Debian, Gentoo and Arch), when you choose more than one keyboard layout, keyboard indicator is automatically shown in traybar.

Changed in kubuntu-meta (Ubuntu):
status: Invalid → New
DEFCOИ (red-octobeer) wrote :

As a native non-English speaker and Gentoo/Arch user, I can confirm this. This bug/misfeature is clearly Kubuntu-specific, and is very confusing for casual users who have 2 or more layouts (i.e. the clear majority).

Harold, you're talking nonsense. People need multiple layouts, people need indication. Please listen to the people who actually use kubuntu in multi-lang environments.

Even for French, German and other languages using latin alphabet, it is _quite_ frequently useful to see the indication - they may switch between us and, say, fr layouts. I seen that many times.

For languages that are not using latin alphabet - it is ESSENTIAL - because they have to use at least 2 layouts - one for ASCII, one for their native language.

Trust me, I am the person who maintains GNOME keyboard layout indicator. As far as I know, vanilla KDE4 is reasonable with layout indication, I happen to know the guy who maintain the KDE layout indicator. Should I invite him here to explain the right behaviour and reasons behind it?

My apologies, I misspelled your name, Harald.

> Should I invite him here to explain the right behaviour and reasons behind it?
I think that it will not be superfluous.

affects: kubuntu-meta (Ubuntu) → kdebase-workspace (Ubuntu)
Changed in kdebase-workspace (Ubuntu):
assignee: Harald Sitter (apachelogger) → nobody
Harald Sitter (apachelogger) wrote :

As per https://bugs.kde.org/show_bug.cgi?id=235736

KDE 4.5 will most likely support displaying the layout indicator by default, as long as 2 profiles are configured either globally or locally (i.e. on a per-user basis). This means that ubiquity needs to properly configure console-setup to not only list the user's selected layout, but also us as additional selection (if appropriate?).

So after installation the xkb layout selection will globally be "he, us", which will make KDE 4.5's layout indicator show up and let the user toggle the layout easily.

Please note that KDE 4.5 is targetted to be deployed with maverick.

affects: kdebase-workspace (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-10.10
David Planella (dpm) wrote :

I've also added this as a topic for the Desktop-Translations roundtable,
to be discussed at the Ubuntu Developer Summit in Brussels next week:

https://blueprints.launchpad.net/ubuntu/+spec/community-m-desktop-translations-roundtable

--
David Planella
Ubuntu Translations Coordinator
david(dot)planella(at)ubuntu(dot)com
www.ubuntu.com

Changed in kdebase:
status: Unknown → In Progress

Harald, David, thank you for due attention to this problem.

Changed in kdebase:
status: In Progress → Fix Released

So, now this bug is sucsessfuly fixed (tested on Kubuntu Maverick Beta) in KDE 4.5! Thanks!

I not sure what status for ubiquity is correct. Fix Released or Invalid?

Changed in ubiquity (Ubuntu):
milestone: ubuntu-10.10 → maverick-updates
milestone: maverick-updates → ubuntu-10.10
Changed in ubiquity (Ubuntu):
status: New → Fix Released
Changed in ubuntu-meta (Ubuntu):
status: New → Fix Released
Changed in ubuntu-meta (Ubuntu Maverick):
status: New → Fix Released
Changed in ubiquity (Ubuntu Maverick):
status: New → Fix Released
Changed in kdebase:
importance: Unknown → Medium

Again problem in Kubuntu Natty.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.