[Lucid Beta2] Booting with new ubiquity live session audio doesn't work

Bug #549738 reported by Roman Friesen on 2010-03-27
108
This bug affects 21 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan
Lucid
High
Evan

Bug Description

In live system (daily build from 27 March 2010) there are no sound (neither with built-in speaker nor with headset), while the volume level is on maximum. The fresh lucid beta1 has worked here...

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D1c', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D3c', '/dev/snd/pcmC0D4p', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer2', '/dev/sequencer'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'ICH5'/'Intel ICH5 with AD1888 at irq 17'
   Mixer name : 'Analog Devices AD1888'
   Components : 'AC97a:41445368'
   Controls : 39
   Simple ctrls : 28
CheckboxSubmission: 963c514a59f61cc33fa5855c009cf704
CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
Date: Sat Mar 27 17:46:43 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100327)
Package: alsa-base 1.0.22.1+dfsg-0ubuntu3
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
SourcePackage: alsa-driver
Uname: Linux 2.6.32-17-generic i686

Roman Friesen (krokosjablik) wrote :
Roman Friesen (krokosjablik) wrote :

The same problem on my laptop Thinkpad T61 (daily build from 27 March 2010).
With the fresh lucid beta1 it worked.

Brad Figg (brad-figg) wrote :

Hi Roman,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage needs-required-logs needs-test-current-image no-sound-system
Changed in alsa-driver (Ubuntu):
status: New → Incomplete
Roman Friesen (krokosjablik) wrote :

Hi Brad, I have encountered this issue testing the Live System, therefore I cannot test new kernels...

Nicolas Delvaux (malizor) wrote :

I have the same problem with my 2 laptops. (04-06 daily-build)
Strange thing: the speaker systray-icon is muted, even when the sound level is max.
(see the attached screen-shot)

But, in my case, this problem happens only on the live system: sound works as expected after the install.
So, is this really an "alsa-driver" bug ?

summary: - no sound in lucid
+ no sound in lucid (live system)

Hi, I'm here from duplicated #557342.

The strange thing is that booting with Live Image, if you don't press anything on the first screen and wait for Ubiquity to load, and then you press "Try Ubuntu" Audio doesn't works.

If you press a key in the first screen falling back to old menu, you select "Try Ubuntu without change your computer" audio works out-of-the-box.

So, it's not a kernel issue. There's something in how new ubiquity load live system.

summary: - no sound in lucid (live system)
+ [Lucid Beta2] Booting with new ubiquity live session audio doesn't work
Changed in alsa-driver (Ubuntu):
status: Incomplete → Confirmed
tags: added: iso-testing
Paolo Sammicheli (xdatap1) wrote :

Check my original report for all apport information:

https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/557342

Dell Inspiron 1520

tags: added: regression-potential
Nicolas Delvaux (malizor) wrote :

I confirm this behaviour too (only happen with the new ubiquity "try system" window)

affects: alsa-driver (Ubuntu) → ubiquity (Ubuntu)
Steve Langasek (vorlon) on 2010-04-08
Changed in ubiquity (Ubuntu Lucid):
importance: Undecided → High
Steve Langasek (vorlon) wrote :
Download full text (5.3 KiB)

The basic problem here is pulseaudio starting up before consolekit has granted pulse access to the sound devices.

Apr 8 22:46:27 ubuntu pulseaudio[3807]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Apr 8 22:46:27 ubuntu pulseaudio[3807]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Apr 8 22:46:27 ubuntu pulseaudio[3807]: core-rtclock.c: Timer slack is set to 50 us.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: core-util.c: Failed to acquire high-priority scheduling: Permission denied
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: This is PulseAudio 0.9.21-63-gd3efa-dirty
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Compilation host: i486-pc-linux-gnu
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Compilation CFLAGS: -g -O2 -g -Wall -O3 -Wall -W -Wextra -pipe -Wno-long-long -Winline -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wold-style-definition -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing=2 -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Running on host: Linux i686 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Found 2 CPUs.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Page size is 4096 bytes
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Compiled with Valgrind support: no
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Running in valgrind mode: no
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Running in VM: no
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Optimized build: yes
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: All asserts enabled.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Machine ID is 7fce1b2cc87bb769666a15594bbdeddb.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Using runtime directory /home/ubuntu/.pulse/7fce1b2cc87bb769666a15594bbdeddb-runtime.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Using state directory /home/ubuntu/.pulse.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Using modules directory /usr/lib/pulse-0.9.21/modules.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Running in system mode: no
Apr 8 22:46:28 ubuntu pulseaudio[3807]: main.c: Fresh high-resolution timers available! Bon appetit!
Apr 8 22:46:28 ubuntu pulseaudio[3807]: cpu-x86.c: CPU flags: CMOV MMX SSE SSE2 SSE3 SSSE3
Apr 8 22:46:28 ubuntu pulseaudio[3807]: svolume_mmx.c: Initialising MMX optimized functions.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: remap_mmx.c: Initialising MMX optimized remappers.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: svolume_sse.c: Initialising SSE2 optimized functions.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: remap_sse.c: Initialising SSE2 optimized remappers.
Apr 8 22:46:28 ubuntu pulseaudio[3807]: sconv_sse.c: Initialising ...

Read more...

Changed in ubiquity (Ubuntu Lucid):
status: Confirmed → Triaged

No sound in lucid beta 2 (live system) my audio card is sound blaster audigy 2.

sparker256 (bgood) wrote :

I also have no sound with Ubuntu 10.04 beta2 but had it in beta1. I have found that if I use the command pulseaudio -k this will get sound working in that session. My machine also has a sound blaster audigy.

Terry Jones (terryjones28056) wrote :

I also have no sound. Testing from two usb drives (one 32 bit, one 64 bit)
The output in sound preference shows dummy.
Sudo killall pulseaudio will give sound each session.

t

Roman Friesen (krokosjablik) wrote :

If it may be relevant:

After starting "Try Ubuntu 10.04" comes in terminal shortly:
(process:281): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)
       * Setting sensors limits
<red>*</red> Speech-dispatcher configured for user sessions
       * Starting Common Unix Printing System: cupsd
<red>*</red> PulseAudio configured for per-user sessions
       * Enabling additional executable binary formats binfmt-support
* Checking battery state...

bviyuviuviul (bviyuviuviul) wrote :

I had also the same problem. But after 'killall pulseaudio', everything worked. If only affects live system is not a big deal, but it will be interesting to fix it before the final release.

Daniele (dani3l3) wrote :

I've Sony VAIO VPCEB1A4E, dual boot Windows7 / Ubuntu 9.10 (2.6.31-21-generic) with Audio card Intel HDA with Chip Realtek ALC269 Analog (from aplay -l).
Sound Ok on Windows, no sound at all in Ubuntu,
I remove pulseaudio and installed ALSA. No sound.
I will try installing Opensound.
Same problem with 10.4 LiveUSB.

Matt Zimmerman (mdz) wrote :

If the problem is as described in comment #9, is this really a ubiquity bug? It sounds like it will need to be fixed in pulseaudio or consolekit.

Evan (ev) wrote :

I had the same suspicion; however, pressing a key at boot to bring up the syslinux menu and selecting "Try or Install Ubuntu" results in a properly working pulseaudio.

Changed in ubiquity (Ubuntu Lucid):
milestone: none → ubuntu-10.04
Evan (ev) on 2010-04-16
Changed in ubiquity (Ubuntu Lucid):
assignee: nobody → Evan Dandrea (ev)
Evan (ev) on 2010-04-16
Changed in ubiquity (Ubuntu Lucid):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.18

---------------
ubiquity (2.2.18) lucid; urgency=low

  [ Evan Dandrea ]
  * Force garbage collection so we don't end up with stray X resources
    when we kill the X server (LP: #556555).
  * Fix the Portuguese and Latvian translations of the variable name
    RELEASE (LP: #564517).
  * Fix a missing closing bold tag in the Portuguese and Polish
    translations (LP: #564545).
  * Fix labels not expanding vertically to fit their text (LP: #560114,
    LP: #557164, LP: #520898).
  * Do not translate variable names in the Amharic translation
    (LP: #564582).
  * Start the window manager via ck-launch-session so pulseaudio is
    granted access to the sound devices (LP: #549738).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup
    1.34ubuntu14, flash-kernel 2.13ubuntu16, hw-detect 1.73ubuntu3,
    partman-auto 89ubuntu6, partman-base 139ubuntu5, partman-ext3
    58ubuntu3, partman-target 64ubuntu8, user-setup 1.28ubuntu6.

  [ Colin Watson ]
  * Break out of oem-config-firstboot's main loop if oem-config-wrapper
    succeeds (LP: #558593).
  * Quit plymouth before starting either the emergency noninteractive
    ubiquity frontend in automatic mode, or oem-config's debconf frontend.
  * Get a controlling terminal before starting bterm, as otherwise bterm
    won't reliably be able to take console input.
 -- Evan Dandrea <email address hidden> Fri, 16 Apr 2010 15:28:19 +0100

Changed in ubiquity (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin (vylik) wrote :

I tryed Ubuntu 10.04 beta2 (x86) with package ubiquity - 2.2.18 but still no sound on my computer. Sound is available after command pulseaudio -k
In previous Ubuntu 10.04 beta1 (x86) sound works properly.
My hardware is in attachment.

sparker256 (bgood) wrote :

I tried the daily lives USB today 041810 and both 32 and 64 bit desktop seems to work fine.

Steve Langasek (vorlon) wrote :

Martin, beta2 didn't include ubiquity 2.2.18, so I don't see any way that you could have tried that version of ubiquity with beta2. This issue is fixed in the daily CD images.

Martin (vylik) wrote :

Steve, you're right. My mistake I apologize. I will test Release Candidate.

Michael Zamora (mz-flaco) wrote :

So is this sound bug fixed? Under sound prefences, when I check my output it still reads "Dummy Output"...I've tried running pulseaudio -k and it doesn't work...can someone please help? Is this bug still being figured out?

Thanks!

Steve Langasek (vorlon) wrote :

This bug was fixed, precisely as the bug state shows. If you are experiencing this symptom with a liveCD of the 10.04 final release, you have a different issue and should file a separate bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers