Ubuntu

Ubiquity should give visual feedback that username cannot contains capital letter(s)

Reported by Ronan Jouchet on 2010-03-26
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
ubiquity
Fix Released
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

It seems usernames musn't contain capital letters.

That's fair, and Ubiquity does a good job at refusing them (clicking "Forward" doesn't move to the next step), but it should give feedback about it to the user (by turning the indicator next to the input box to a red cross).
Currently, the user is not informed (the validity indicator remains a green tick).

----
mpt suggests :
"Better than giving an error message would be to lower-case capital letters automatically as they are typed."
----
ProblemType: Bug
Architecture: i386
Date: Fri Mar 26 18:35:50 2010DistroRelease: Ubuntu 10.04LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100326)
Package: ubiquity 2.2.8
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1SourcePackage: ubiquity
Uname: Linux 2.6.32-17-generic i686

Ronan Jouchet (ronj) wrote :

Confirmed at the Ubuntu Global Jam @ MTL

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Carl Simpson (cwd-simpson) wrote :

This bug persists even at release, and has been quite disruptive for at least a few people.

I reported this earlier today in a separate bug, which I have now marked as a duplicate of this one.

AJenbo (ajenbo) wrote :

I just tested the latest daily, if the user name contains upper case letters the check mark to the right disappears, ofcause this doesn't indicate what is wrong with the user name.
A good solution for this would be to have a warning triangle in the input box, like the one that appears for the password input if caps lock is on.

Vish (vish) wrote :

In dup Bug #658798 , mpt suggests :
"Better than giving an error message would be to lower-case capital letters automatically as they are typed."

Changed in ubiquity (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Changed in hundredpapercuts:
importance: Undecided → Wishlist
status: New → Triaged
description: updated
Vish (vish) wrote :

Carrying over comments and assign from dup Bug #690842

Matthew Paul Thomas wrote:
It's not mentioned in the current installer specification <https://docs.google.com/View?id=dfkkjjcj_101gnkrpg5v#6_2_First_Boot_464401107281446_5590505003929138>, but in the original installer specification from 2005 <https://wiki.ubuntu.com/UbuntuExpress/GnomeUserInterface#Personal%20information>, I suggested that prohibited characters be ignored, and that all other characters be converted to lower case as they are typed. That would avoid the need for any extra instructions, warnings, or error messages.

Evan Dandrea wrote:
Assigning to myself with the intention on implementing Matthew's suggestion.

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Wishlist → Medium
Changed in hundredpapercuts:
importance: Wishlist → Medium
Paul Sladen (sladen) wrote :

Seemingly seen on Twitter, seemingly all in capital letters:

  http://twitter.com/Vi3tHoneyX/status/17806695224844288
  "WTF UBUNTU, FOR THREE HOURS WILL AND I WERE TRYING TO INSTALL YOU ONLY FOR HIM TO REMEMBER I CAN'T USE UPPER CASE LETTERS IN MY USERNAME!!!!"

Chris Wilson (notgary) wrote :

What's the status of this bug? Will there be a fix for it in Natty?

Erick Brunzell (lbsolost) wrote :

When iso-testing the Natty alpha2 i386 image I tried using an upper case letter just to see and I was warned not to, so I think this is fixed in Natty. I will try and remember to watch for any regression with future images.

Evan Dandrea (ev) on 2011-02-08
Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
Vish (vish) on 2011-02-08
Changed in hundredpapercuts:
assignee: nobody → Papercuts Ninja (papercuts-ninja)
IKT (ikt) wrote :

It now shows that you can't create a username with a capital letter, so marking this fixed.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Changed in ubiquity:
status: New → Fix Released
IKT (ikt) on 2011-03-04
Changed in hundredpapercuts:
status: Triaged → Fix Released
Vish (vish) on 2011-03-04
Changed in hundredpapercuts:
assignee: Papercuts Ninja (papercuts-ninja) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers