[lucid] Ubiquity summary does not show any partition info when using auto-resize

Bug #546347 reported by Jeff Lane on 2010-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Doing pairwise testing of ubiquity 2.2.7 using todays daily of Ubuntu 32bit

Installing on a VM that had a full disk karmic install by doing auto-resize.

On the final page in the summary, I see the following:

Language: English
Keyboard layout: USA
Name: Jeff
Login name: jeff
Location: America/New_York
Migration Assistant:

No partition table changes and no creation of file systems have been planned.

If you plan on using already created file systems, be aware that existing files may prevent the successful installation of the base system.
---
Architecture: i386
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100324)
Package: ubiquity 2.2.7
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Tags: lucid
Uname: Linux 2.6.32-17-generic i686
UserGroups:

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

Jeff Lane (bladernr) wrote :

Extra Information:

I'm on to a different pairwise test now (full disk OEM). The summary for a full disk install does not have this issue... so far, I've only seen it on auto-resize installs.

Evan (ev) wrote :

It displays that message because you've already made the changes to the partition table and no further changes are necessary. It already popped up a dialog box telling you it was going to immediately resize the partition when you pressed next on the automatic partitioning page.

I'm marking this as not a bug. Thanks just the same for your effort.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Jeff Lane (bladernr) wrote :

Not exactly. The only thing that has been changed and committed at this point is resizing the original partition on disk. The actual creation of new partitions for my Lucid install has not been done, and should be listed in the summary showing me exactly what partitions will be created.

Look at the attached screenshots.

partman_firstrun.png shows what my disk looks like initially. A full disk Karmic install.
summary_firstrun.png shows that it's telling me that install will create NO partitions.

After that summary appears, I simply reset the VM and boot back into the installer again. Now, after I reboot, if, as you said, all changes to the partition table have been made, I should see more than just a 2 partitions (root and swap).

However, on reboot, the only partitions on my disk are the original root and swap.
See partition_table_secondrun.png

The point is, by the time the summary page is loaded, the ONLY changes to the partition table involve resizing the original root partition. NO NEW PARTITIONS have been created or formatted at this point in the process.

any NEW partitions that are to be created or formatted should ALWAYS show up in the summary.

Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :
Jeff Lane (bladernr) wrote :
Changed in ubiquity (Ubuntu):
status: Invalid → New
tags: added: ubiquity-2.2.7
tags: added: lucid
Jeff Lane (bladernr) wrote :

Probably fixed by release

Changed in ubiquity (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers