Xubuntu fails to localize the system into Spanish

Bug #540878 reported by Ara Pulido on 2010-03-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Medium
Colin Watson
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

Testing Xubuntu Lucid Beta 1 candidate ISOs (ubiquity 2.2.5)

The ES lang packs are in the CD, in fact, the Live environment is fully localized in Spanish.
When I install the sytem (also in Spanish), after rebooting, the system is in English.

Looking at the installer logs, it looks like lang packs, including the selected one, are being uninstalled.

I will attach the logs.

Ara Pulido (ara) wrote :
Ara Pulido (ara) wrote :
Ara Pulido (ara) wrote :
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

This is a CD image bug; I changed debian-cd to preseed pkgsel/install-language-support to false during the Hardy cycle, for reasons which I suspect were only recorded on IRC so I'm going to have to track them down in my logs. This doesn't seem to match how the seeds are constructed, so right now I'm inclined to revert it since language support installation is cleverer nowadays anyway.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Colin Watson (cjwatson) wrote :

Actually, on reflection I think that even if pkgsel/install-language-support is set to false, ubiquity should keep language packs already available in the live system. The purpose of preseeding this question was to avoid a large download from the Internet (although it's of less use these days, with check-language-support), and there are other ways to remove language support altogether if that's what you want.

Changed in ubiquity (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
status: Invalid → Triaged
Colin Watson (cjwatson) on 2010-03-18
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntu-cdimage:
importance: Undecided → Medium
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.6

---------------
ubiquity (2.2.6) lucid; urgency=low

  [ Evan Dandrea ]
  * Properly set the text for the release notes label after the user
    runs the 'update this installer' option.
  * Correctly set up GtkComboBoxEntry widgets (LP: #539204).
  * In the KDE frontend, call reboot with root privileges and try
    rebooting via dbus only if a KDE dbus session exists (LP: #540856).
  * Remove the apport hook, it lives in Ubuntu's apport package now.
  * Don't let the user select both "Try Ubuntu" and "Install Ubuntu".
  * Provide visual feedback for clicking "Try Ubuntu" in the form of a
    spinning cursor.
  * Automatic update of included source packages: base-installer
    1.103ubuntu5, console-setup 1.34ubuntu12, partman-base 139ubuntu1.

  [ Colin Watson ]
  * If pkgsel/install-language-support is set to false, then don't install
    new language packs from the network, but nevertheless keep any language
    packs that are in the live filesystem (LP: #540878).
  * Install oem-config-kde in the KDE user-setup plugin (LP: #540895).
  * Don't fall through to the failsafe X server if the main X server
    succeeds (LP: #540938).
  * ubiquity-frontend-gtk depends on gksu (LP: #540331).
  * Change .desktop translation domain to ubiquity-desktop (LP: #540936).
  * Report disk sizes in decimal units in the manual partitioner, for
    consistency with partman and to abide by the new units policy
    (LP: #539653).

  [ Mario Limonciello ]
  * Don't delete the cache too early in select_language_packs.

  [ Roman Shtylman ]
  * Fix for 100% cpu usage in kde frontend (LP: #538505)

  [ Michael Terry ]
  * Upstart jobs: start on starting uxlaunch, Moblin's display manager
    (LP: #540257).
 -- Evan Dandrea <email address hidden> Fri, 19 Mar 2010 23:52:24 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

revno: 1535
fixes bug(s): https://launchpad.net/bugs/540878
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Thu 2010-03-18 13:07:47 +0000
message:
  stop setting pkgsel/install-language-support=false for images where we aren't expecting language-support-* to be present, since with check-language-support this no longer causes a warning and we want to have whatever language support is available (LP: #540878)

Changed in ubuntu-cdimage:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers