Keyboard input needed to change grub-install device w/Lucid Live install

Bug #539204 reported by Erick Brunzell on 2010-03-15
94
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan

Bug Description

Binary package hint: ubiquity

Sorry in advance, I stumbled and bumbled trying to find a decent brief summary title for a nearly insignificant issue.

I'm testing the i386 Lucid Beta 1 candidate (http://cdimage.ubuntu.com/daily-live/20100315/lucid-desktop-i386.iso _ md5sum: ae9b66a6873845cc43f9cbc9cc66a605) and performing a manual partitioning install went almost flawlessly, but when I get to the final screen and click on Advanced to change the device on which to install grub and try to use the "pop-down" menu and select /dev/sdb the "device designation" does NOT change.

However simply paying attention and seeing that it did NOT change, after trying a few times, I simply used the keyboard to backspace out the "a" in /dev/sda and typed in a "b" changing it to /dev/sdb and the installation did complete successfully. That is the installer did respect my choice, it was simply necessary to to "manually" change the device designation.

So I guess whatever that little "pop-down" selection menu is needs a bit of tweaking. Hardly a show stopper, another of those things that I'm reluctant to even report, but I've seen a major effort on the part of the devs to truly make this the best Ubuntu ever. Just something you'll probably want to have fixed by final.

tags: added: iso-testing
Evan (ev) wrote :

I took a look at this yesterday, but I'm not entirely sure yet why it is breaking. I've removed the clear() call on the combobox, which gets rid of the error, but leaves a third cellrender packed in the comboboxentry. I have no idea where that is coming from, but reusing it instead of packing the first cellrenderer gives the intended behavior. That said, I intend to get to the bottom of this and fix it properly.

Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (ev)
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: New → Confirmed
Evan (ev) on 2010-03-18
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.6

---------------
ubiquity (2.2.6) lucid; urgency=low

  [ Evan Dandrea ]
  * Properly set the text for the release notes label after the user
    runs the 'update this installer' option.
  * Correctly set up GtkComboBoxEntry widgets (LP: #539204).
  * In the KDE frontend, call reboot with root privileges and try
    rebooting via dbus only if a KDE dbus session exists (LP: #540856).
  * Remove the apport hook, it lives in Ubuntu's apport package now.
  * Don't let the user select both "Try Ubuntu" and "Install Ubuntu".
  * Provide visual feedback for clicking "Try Ubuntu" in the form of a
    spinning cursor.
  * Automatic update of included source packages: base-installer
    1.103ubuntu5, console-setup 1.34ubuntu12, partman-base 139ubuntu1.

  [ Colin Watson ]
  * If pkgsel/install-language-support is set to false, then don't install
    new language packs from the network, but nevertheless keep any language
    packs that are in the live filesystem (LP: #540878).
  * Install oem-config-kde in the KDE user-setup plugin (LP: #540895).
  * Don't fall through to the failsafe X server if the main X server
    succeeds (LP: #540938).
  * ubiquity-frontend-gtk depends on gksu (LP: #540331).
  * Change .desktop translation domain to ubiquity-desktop (LP: #540936).
  * Report disk sizes in decimal units in the manual partitioner, for
    consistency with partman and to abide by the new units policy
    (LP: #539653).

  [ Mario Limonciello ]
  * Don't delete the cache too early in select_language_packs.

  [ Roman Shtylman ]
  * Fix for 100% cpu usage in kde frontend (LP: #538505)

  [ Michael Terry ]
  * Upstart jobs: start on starting uxlaunch, Moblin's display manager
    (LP: #540257).
 -- Evan Dandrea <email address hidden> Fri, 19 Mar 2010 23:52:24 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers