Ubuntu

Gigabyte GA-M61PME-S2 does not boot on Lucid

Reported by Sandeep on 2010-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gfxboot

I have a desktop with the following configuration that simply does not boot with a bootable USB Lucid Lynx Alpha 3 (rechecked with daily-live Mar 15). Each time, I am able to boot it using Jaunty (and even install it). I am using USB Startup Disk Creator on a Jaunty machine.

Please note that I have several desktops of this configuration (about 4), and this happens on ALL of them.

1. Athlon X2 240
2. Gigabyte GA M61PME S2 motherboard with an integrated nvidia 6100 chip
3. USB mouse
4. PS2 keyboard

Observed behavior:
1. The initial purple spash screen of UBuntu appears
2. it blinks a couple of times and goes directly to the splash screen with the animated dots.
    I do NOT get the boot options menu (i.e. "Install Ubuntu", "Try Ubuntu without trying". In fact, I do not even get the menu to choose my keyboard locale.
3. The animated dots keep going forever.

On ctrl-alt-f1, I see the following error trace:
stdin: error 0
stdin: error 0
stdin: error 0
stdin: error 0
stdin: I/O Error

I'm not sure how to debug this further, since I do not encounter the boot options menu. I am game to try a verbose-boot build if available.

thanks

Sandeep (sandys-gmail) on 2010-03-15
summary: - Gigabyte GA-M61PME-S2 does not boot
+ Gigabyte GA-M61PME-S2 does not boot on Lucid
Colin Watson (cjwatson) wrote :

Well, you're getting past gfxboot, so I don't think this is a gfxboot bug.

plymouth implements the splash screen, although it may well not be responsible for this bug. Nevertheless, reassigning there as the next plausible thing in the chain ...

affects: gfxboot (Ubuntu) → plymouth (Ubuntu)

If the dots are animating, then this isn't a plymouth issue - only if the dots stop or the splash screen goes away would it indicate a problem there

affects: plymouth (Ubuntu) → ubuntu

This then implies ubiquity is the issue (following the chain for a Live CD)

affects: ubuntu → ubiquity (Ubuntu)
Sandeep (sandys-gmail) wrote :

Today, I let the USB drive sit in the machine for over an hour - eventually Lucid did boot and I managed to install it to the computer.

On first reboot, GDM did not come up. After trying a couple of times, the GDM came up and I was able to login. I installed non-free Nvidia driver in the hope that it would fix some issues.

After rebooting, same issue - GDM does not always come up. I am able to do "ctrl-alt-f1" and use TTY login. I have zipped up all the log files of that machine in the hope that someone might be able to debug it.

Of particular interest is the Xorg.0.log (failed GDM) and Xorg.0.log.old (successful GDM) - nvidia driver 195.36.08 failed to load.
Also of interest is syslog :

Mar 18 16:44:49 kenobi init: failsafe-x main process (1142) terminated with status 1

However, sometimes it does go through and boot properly.

Again, let me reiterate that I have a couple of desktops with the same motherboard and all of them exhibit the same issues.

Sandeep (sandys-gmail) wrote :
Sandeep (sandys-gmail) wrote :

This still does not boot - I have tried Beta 1 and 04 April 2010 snapshot. However, Jaunty's live-usb works beautifully.

Can somebody please take a look at this - this effectively means, we will not be able to use Lucid on any of our machine.

In my previous mail, I have attached compressed /var/log after letting the computer sit for a few hours (it did eventually boot into the live-usb then). Please let me know how else can I help.

Sandeep (sandys-gmail) wrote :

I may have some additional info today:

I added "debug=" to the boot options of the livecd

It seems to go and hang at this point:
-------------------------
/sbin/udevadm info -q name -p /block/fd0
echo /dev/fd0
devname =/dev/fd0
/sbin/blkid -s LABEL -o value /dev/fd0

[93.998824] end request: I/O error, dev fd0, sector 0
[93.998953] Buffer I/O error on device fd0, logical block 0
-------------------------

And this error goes on and on. After sometime, the boot sequence resumes and then it hits the same few lines as above.

If I am not wrong fd0 stands for floppy disk - my desktop does not have a floppy disk drive

Sandeep (sandys-gmail) wrote :

Workaround:
In this motherboard, in the "Standard CMOS Options", set "Drive A" to "None".

This lets the LiveCD to go through.

This is a regression against 9.10, which has no such problems.

Arthur Peters (amp) wrote :

This bug also affects me on the MSI P965 motherboard. The same workaround worked for me too. Sounds like maybe some piece of code is repeatedly querying the FDD if it claims to exist and if there is actually no FDD then the time outs kill the performance.

Matthew Warner (mkw152) wrote :

Same bug affected me when trying to boot Kubuntu 10.10 live USB on DFI LanParty NF4 motherboad, socket 939. Disabled floppy in BIOS and it booted fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers