Freeze exception request: modify install window to match new theme

Bug #538411 reported by Evan on 2010-03-13
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Please grant a freeze exception for the following patches:
ubiquity: http://launchpadlibrarian.net/40904341/install-window-match-theme.patch
ubiquity-slideshow-ubuntu: http://launchpadlibrarian.net/41110160/slideshow-match-theme.patch

We've implemented Michael Forrest's mockup for the new slideshow, which brings it more in line with the new theme, but this requires some very small changes to ubiquity. It now puts items on the install window in slightly different places and uses the theme colors for the window background.

The result of which, is this:
http://people.canonical.com/~evand/tmp/new-install-desktop.png

I've tested this myself and confirmed it working without issue.

Evan (ev) wrote :
description: updated
Evan (ev) wrote :
description: updated
description: updated
Martin Pitt (pitti) wrote :

Why does it replace svg icons with .png? That seems like an evolutionary step backwards?
The slightly larger required dimensions might cause trouble on netbook installers (which need to work in 1024x600); has this been tested on a small resolution?

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: New → Incomplete

Hi Martin,

The SVGs were always being turned into PNGs by the build script, so
with the new design (which just uses regular 128x128px images without
needing to change them) I just got rid of that middle step. It means
we don't have a bizarre build dependency on GIMP, it's easier to test
and generally less fiddly.

Netbooks are getting their own content, hopefully...

On 3/22/10, Martin Pitt <email address hidden> wrote:
> Why does it replace svg icons with .png? That seems like an evolutionary
> step backwards?
> The slightly larger required dimensions might cause trouble on netbook
> installers (which need to work in 1024x600); has this been tested on a small
> resolution?
>
> ** Changed in: ubiquity-slideshow-ubuntu (Ubuntu)
> Status: New => Incomplete
>
> --
> Freeze exception request: modify install window to match new theme
> https://bugs.launchpad.net/bugs/538411
> You received this bug notification because you are subscribed to
> ubiquity-slideshow-ubuntu in ubuntu.
>

Evan (ev) wrote :

Traditionally the slideshow took svg source files, ran them through the GIMP to add a drop shadow, and outputted pngs. As the new design does not include a drop shadow, the svgs are no longer used. The slideshow does not scale, so the advantage that SVG provides does not apply here.

Ubiquity has always been set to not show the slideshow if the screen resolution is less than 800x600. The new slideshow height is only 500px, but the width is 816px, slightly larger than the current minimum bound for its display. As netbooks are generally 1024px wide (as you mention), we could increase this limit and still cover the majority of systems. However, as it's a difference of only 16px, lets first check with Dylan and Michael to see if we could reasonably shave off this extra space.

Michael, Dylan, what are your thoughts on this?

Feel free to make the window narrower - just pull the background image so that it stays in the same relative position to the right. (And make sure outer padding is preserved!)

Dylan McCall (dylanmccall) wrote :

Squeezing off 18px (bringing this to 798 wide) shouldn't be an issue at all.

Evan (ev) wrote :

Updated patch from Dylan that fits the slideshow in 800x600. Martin, does this satisfy all of your concerns?

Martin Pitt (pitti) wrote :

Thanks for the follow-ups. Approved.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Incomplete → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity-slideshow-ubuntu - 16

---------------
ubiquity-slideshow-ubuntu (16) lucid; urgency=low

  [ Dylan McCall ]
  * New look for the Ubuntu slideshow.
  * Updated license details for images in debian/copyright.
  * Larger dimensions for Ubuntu slideshow: 816x500, from 700x420.
  * Removed GIMP build dependency. GIMP scripts in images-source no
    longer to be run at build time; final icons should be added
    manually in source package.

  [ Evan Dandrea ]
  * Use the official Firefox icon, rather than a generic browser icon.
  * Freeze exception for new design (LP: #538411).
  * Update the update-launchpad-translations script.
  * Update translations from Launchpad.

  [ Richard A. Johnson ]
  * Updated slideshow for Kubuntu installer
    (LP: #540348) (LP: #534949) (LP: #539147)

  [ Brian Murray ]
  * resolved some grammatical issues with the xubuntu slides
 -- Evan Dandrea <email address hidden> Wed, 24 Mar 2010 14:31:56 +0000

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.8

---------------
ubiquity (2.2.8) lucid; urgency=low

  * Set a wallpaper and cursor for the KDE frontend when in only-
    ubiquity mode (LP: #540933, LP: #540339). Thanks Roman Shtylman!
  * Add a password strength meter (LP: #537995).
  * Modify the install progress window to match the new theme
    (LP: #538411).
  * Don't show the alpha warning in OEM mode when it's disabled.
  * Add translations for the locale's preferred time format and
    respective format string, as imported from gnome-panel
    (LP: #538156).
 -- Evan Dandrea <email address hidden> Wed, 24 Mar 2010 23:26:46 +0000

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers