Attribute Error: 'None Type' on kubuntu whole disk install 20100310

Bug #536912 reported by Fabio Marconi on 2010-03-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: ubiquity
daily build amd64

Installer crashes
File /usr/lib/ubiquity/frontend/kde_components/PartAuto.py, line 256,
in on_extra_combo_changed
E.SetVisible (false)
Attribute Error:'None Type'
Object has no attribute 'SetVisible

from syslog

/lib/partman/display.d/10/initial_auto:119
/lib/partman/automatically_partitioning//do_option: not found

description: updated
Fabio Marconi (fabiomarconi) wrote :

Tring to install from cd's menu.

tags: added: isotesting
tags: added: iso testing
removed: isotesting
Colin Watson (cjwatson) wrote :

You've selected a few bits and pieces out of the logs and typed them in. Thank you for your efforts, but it usually turns out to be awkward in practice; we need bits of the logs that you might not guess, and we need them to be precisely accurate. Could you please reproduce this bug, exit the installer after it crashes, and attach /var/log/syslog and /var/log/partman to this bug, following the directions in http://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs? If you have network access from the live session, you can run 'apport-collect 536912' and it should do all the right things for you.

Thanks in advance.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

On the new rebuilt nothing change 20100315

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :

nothing change on 20100319

Changed in ubiquity (Ubuntu):
status: Incomplete → New
Colin Watson (cjwatson) on 2010-03-31
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Fabio Marconi (fabiomarconi) wrote :

Thanks a lot to everibody

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.12

---------------
ubiquity (2.2.12) lucid; urgency=low

  [ Evan Dandrea ]
  * Accept and discard arguments to the KDE frontend's
    on_keyboard_layout_selected function (LP: #552399).

  [ Colin Watson ]
  * Fix pkgsel/ignore-incomplete-language-support check (LP: #527623).
  * KDE frontend:
    - Ensure that entries in extra_bar_frames are never None (LP: #536912).
    - Lock out manual partitioning operations while the partitioning backend
      is running (LP: #540203).
  * Don't lower-case the locale attribute on frontends. This was added a
    long time ago; since then, it's become unnecessary since i18n.get_string
    lower-cases the locale itself, and it prevented us from finding
    slideshow files for language variants (LP: #476269).
  * Automatic update of included source packages: partman-auto 89ubuntu4,
    partman-ext3 58ubuntu2.

  [ Jonathan Riddell ]
  * Move oem-config-prepare-kde.desktop install directory to
    /usr/share/applications/kde4/, else it is labelled as a KDE 3
    application
 -- Colin Watson <email address hidden> Thu, 01 Apr 2010 01:27:27 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers