[lucid UNR] ubi-partman crashes with error 141

Bug #535630 reported by spaetz on 2010-03-10
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Binary package hint: ubiquity

I just tried todays daily image of UNR and the installer fails as soon as I click on the "specify partitions manually" checkbox and hit "Next". I get a dialog box saying that ubi-partman failed with error 141. I will attach my logs in a second.
This is a Hewlett Packard 5102, with the hard disk previously erased. My ubiquity version is 2.1.33.

spaetz (spaetz) wrote :
spaetz (spaetz) wrote :
spaetz (spaetz) wrote :
spaetz (spaetz) wrote :

I also tried the "Use the whole disk option" and that let me proceed. At least until the 93% done "grub detecting other operating systems" (with a blank hard disk) hang indefinitely.

spaetz (spaetz) wrote :

Following 3 new debug logs with the installer actually closed after the failure. Ignore the previous 3 ones.

spaetz (spaetz) wrote :
spaetz (spaetz) wrote :
spaetz (spaetz) wrote :
mercedes (preciousa1237) on 2010-03-10
Changed in ubiquity (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

mercedes: DO NOT CLOSE THIS BUG. Thank you.

Changed in ubiquity (Ubuntu):
status: Fix Released → Confirmed
Colin Watson (cjwatson) on 2010-03-10
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → High
Colin Watson (cjwatson) on 2010-03-10
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
KevinM (kevbert1) wrote :

Just had this problem with the latest daily build of Kubuntu (downloaded from main server 19.30UTC). Fails after manual partitioning selected and disks scanned for other OS).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.34

---------------
ubiquity (2.1.34) lucid; urgency=low

  [ Mario Limonciello ]
  * Remove extraneous '--', restoring oem-config-firstboot.

  [ Colin Watson ]
  * Add not_me to the base interface definition of Controller.translate.
  * Keep track of how partitioning progress is displayed without requiring
    an argument to be passed to progress_stop (LP: #535630).
  * Automatic update of included source packages: user-setup 1.28ubuntu5.

  [ Roman Shtylman ]
  * Updated Kubuntu artwork
  * Fixed sidebar showing when not in greeter mode for kde
 -- Colin Watson <email address hidden> Thu, 11 Mar 2010 01:41:16 +0000

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
vmc (vmclark) wrote :

Thanks for the fix. It worked.
 Using MAR10th daily-live, I just updated the installer and was able to use manual method.

I did notice that Ubiquity is now at version 2.1.35

Giuseppe Pennisi (giupenni78) wrote :

I'm using MAR12th daily-live of Kubuntu and the problem persist, I have try to upgrade ubiquity to 2.1.35 and after I choose the time zone ubiquity get this error:
ubi-console-setup failed with exit code 141.

Colin Watson (cjwatson) wrote :

Giuseppe, please file a new bug with full logs. This symptom can have multiple causes and it is not generally helpful to follow up to existing bugs. In fact, it's quite clear that you have a different symptom: "ubi-console-setup" is not the same as "ubi-partman".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers