kubuntu ubiquity crashes after first page

Bug #526534 reported by Jonathan Riddell on 2010-02-23
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

on today's daily live CD ubiquity crashes after the first page. the logs indicate a permissions problem. ubiquity is being run as the "ubuntu" user

ProblemType: Bug
Architecture: i386
Date: Tue Feb 23 16:06:49 2010
DistroRelease: Ubuntu 10.04
LiveMediaBuild: Kubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100223.2)
Package: ubiquity 2.1.24
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SourcePackage: ubiquity
Uname: Linux 2.6.32-14-generic i686

Jonathan Riddell (jr) wrote :
Changed in ubiquity (Ubuntu Lucid):
milestone: none → lucid-alpha-3
Jonathan Riddell (jr) on 2010-02-23
summary: - ubiquity crashes after first page
+ kubuntu netbook ubiquity crashes after first page
tags: added: iso-testing

today I got this in the installer from the desktop image. The crash seems to be in QTextEngine so it's probably an issue in Qt or kdebindings

#0 0x0142df6b in QTextEngine::boundingBox(int, int) const () from /usr/lib/libQtGui.so.4
#1 0x0140407a in QFontMetrics::boundingRect(QString const&) const () from /usr/lib/libQtGui.so.4
#2 0x015d0359 in ?? () from /usr/lib/libQtGui.so.4
#3 0x015d0576 in QComboBox::sizeHint() const () from /usr/lib/libQtGui.so.4
#4 0x00e477bc in ?? () from /usr/lib/pymodules/python2.6/PyQt4/QtGui.so
#5 0x011e16c3 in QWidgetItemV2::updateCacheIfNecessary() const () from /usr/lib/libQtGui.so.4
#6 0x011e2700 in QWidgetItemV2::minimumSize() const () from /usr/lib/libQtGui.so.4
#7 0x011d5b5d in ?? () from /usr/lib/libQtGui.so.4
#8 0x011d6582 in ?? () from /usr/lib/libQtGui.so.4
#9 0x011d68fa in QGridLayout::setGeometry(QRect const&) () from /usr/lib/libQtGui.so.4
#10 0x00dd984e in ?? () from /usr/lib/pymodules/python2.6/PyQt4/QtGui.so
#11 0x011ddc3f in QLayoutPrivate::doResize(QSize const&) () from /usr/lib/libQtGui.so.4
#12 0x011ddd67 in QLayout::activate() () from /usr/lib/libQtGui.so.4
#13 0x011df30b in QLayout::widgetEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#14 0x011a64a6 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#15 0x011ad0d9 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#16 0x028b0b2a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x023b6823 in sipKApplication::notify(QObject*, QEvent*) () from /usr/lib/pymodules/python2.6/PyKDE4/kdeui.so
#18 0x007978db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4

Jonathan Riddell (jr) wrote :

not showing the new progress bar seems to stop the crash

summary: - kubuntu netbook ubiquity crashes after first page
+ kubuntu ubiquity crashes after first page
Colin Watson (cjwatson) wrote :

Worked around for alpha-3; moving to beta-1.

ubiquity (2.1.26) lucid; urgency=low

  [ Evan Dandrea ]
  * Specify migrationassistant's order as simply coming before summary,
    as setting it as coming after user-setup and partman was causing it
    to come after summary (LP: #526581).

  [ Jonathan Riddell ]
  * kde_ui.py: don't show integrated progress bar, it seems to cause a crash
    https://launchpad.net/bugs/526534
  * kde_ui.py: Show progressDialog for install, still needed (LP: #526454)

 -- Jonathan Riddell <email address hidden> Wed, 24 Feb 2010 13:11:43 +0000

16:21 <Riddell> cjwatson: no, hiding the progress bar is a workaround, I'd like to find the cause after the alpha

Changed in ubiquity (Ubuntu Lucid):
milestone: lucid-alpha-3 → ubuntu-10.04-beta-1
Fabio Marconi (fabiomarconi) wrote :

For me is impossible to install Kubuntu from cd's menu
The only way to install is to select "Try kubuntu whithout change ....." load all the live and from application : sistem : install kubuntu 10.04 .

Paulo Lopes (jetdrone) wrote :
Download full text (4.0 KiB)

On alpha3 my ubiquity log is as follows:

Ubiquity 2.1.28
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Couldn't create index file "/var/tmp/kdecache-root/kpc/kde-icon-cache.index"
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Permission denied
QFileSystemWatcher: failed to add paths: /root/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
trying to create local folder /var/tmp/kdecache-root/kpc: Permission denied
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Couldn't create index file "/var/tmp/kdecache-root/kpc/kde-icon-cache.index"
FIXME, medianotifier unload port to KDE 4
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Failed to lock file "/var/tmp/kdecache-root/kpc/kde-icon-cache.lock" , last result = 2
kubuntu-ubiquity(3258): Fail...

Read more...

Roman Shtylman (shtylman) wrote :

The issues in this bug have been fixed/changed in the codebase. If any one particular issue comes back, it should be opened as a separate bug.

Changed in ubiquity (Ubuntu Lucid):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers