ubiquity crashed with IndexError in on_region_combo_changed()

Bug #521851 reported by Krasimir Chonov on 2010-02-14
182
This bug affects 37 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

When I`ve tried to install Ubuntu 10.04 amd64 Daily build 14.02.2010 on vritual machine the ubiquity just crashed after I pressed the Install button. The installation haven`t started.

ProblemType: Crash
Architecture: amd64
Date: Sun Feb 14 19:18:40 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100214)
Package: ubiquity 2.1.19
ProcAttrCurrent: unconfined (enforce)
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity gtk_ui
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/3850/environ'
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'gtk_ui']
SourcePackage: ubiquity
Title: ubiquity crashed with IndexError in on_region_combo_changed()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/ubiquity/plugins/ubi-timezone.py", line 204, in on_region_combo_changed
     if m[i][1]:
 IndexError: could not find tree path
Uname: Linux 2.6.32-13-generic x86_64
UserGroups:

Krasimir Chonov (kchonov) wrote :
tags: removed: need-duplicate-check
Markus Korn (thekorn) wrote :

I can reproduce this bug when navigating through the different steps multible times

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Markus Korn (thekorn) on 2010-02-20
visibility: private → public
Erik B. Andersen (azendale) wrote :

I had this problem when I went back to the first step of the installer, and right when I clicked update this installer it triggered the error.

Kenny Strawn (kenny-strawn) wrote :

There was one time when I started installing, and as soon as I got to the point where I could click "Install", Ubiquity crashed with this same bug. I assume it's an issue that certainly needs to be fixed in time for Lucid's final release, considering it is potentially fatal.

-Kenny Strawn

tags: added: iso-testing
Jeff Lane (bladernr) wrote :

Also seen here on a Lenovo S-10 Netbook while doing an OEM install.

1.5GB Ram
1.6GHz Atom Proc
16GB SSD drive

Krasimir Chonov (kchonov) wrote :

I`ve tested the build from 27.02.2010 and the problem is fixed. Thanks.

John Haitas (jhaitas) wrote :

I experienced this bug today on the latest live cd... i don't know that the problem is fixed

Fabio Marconi (fabiomarconi) wrote :

On Lucid i386 20100321
I start installation, but at the configuring clock popup i see that the internet connection was out, then click back from geo/localization window then click on forward at the first window then apport start, but ubiquity continue his work correctly.

Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Fabio Marconi (fabiomarconi) wrote :
Moshpet (moshpet01) wrote :

Switching back and forth on the regions seems to be what is causing this bug.
Amd Athlon II x3 using 32bit version

Sebastien Bacher (seb128) wrote :

confirming the issue on beta2 if you go back from the timezone selection to the language one and click next there

Sebastien Bacher schrieb:

> confirming the issue on beta2 if you go back from the timezone selection
> to the language one and click next there
>
>
>
Correct. Thats what I did.

Steve Langasek (vorlon) on 2010-04-11
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Evan (ev) on 2010-04-12
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.2.17

---------------
ubiquity (2.2.17) lucid; urgency=low

  [ Mario Limonciello ]
  * Remove unused install_bottom_eb from GTK frontend's install_window.

  [ Evan Dandrea ]
  * Catch invalid iterators in on_region_combo_changed (LP: #521851).
  * Don't let not being able to talk to the system bus crash the entire
    language page.
  * Translate the yes and no buttons on the quit dialog in the KDE
    frontend (LP: #561876).
  * Update translations from Launchpad.
  * Automatic update of included source packages: base-installer
    1.103ubuntu7, choose-mirror 2.29ubuntu3, partman-base 139ubuntu4,
    partman-basicfilesystems 63ubuntu4, tzsetup 1:0.26ubuntu8.

  [ Colin Watson ]
  * Skip copy_wallpaper_cache when running as oem-config.
  * Update finish-install.d/07oem-config-user for new location of KDE's
    oem-config-prepare .desktop file (LP: #557309).
  * Restore translations for oem-config-check and oem-config-udeb, lost in
    oem-config merge.
  * Display simple progress feedback using debconf-apt-progress while
    removing oem-config (LP: #558593).
  * Write locale-gen output from ubiquity-dm to /var/log/installer/dm rather
    than to the console.
  * Increase kernel flush times (dirty_writeback_centisecs to 3000, and
    dirty_expire_centisecs to 6000) during bulk data copying. Surbhi
    Palande suggests that this should make it easier for the kernel to pack
    blocks contiguously, speeding up ureadahead after installation.

  [ Amichai Rothman ]
  * Fix hang unless mouse is moved (LP: #556376)
 -- Evan Dandrea <email address hidden> Wed, 14 Apr 2010 17:38:36 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers