Ubiquity crash when configuring grub on raid0 system with dmraid loaded

Bug #51497 reported by John on 2006-07-01
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Ubiquity crashes when installing onto a system using a motherboard software raid, aka 'fake raid', even when the dmraid package is loaded. It crashes when it tries to configure grub as the installer tries to setup /dev/hdb, /dev/sdc or similar. On a side note it would be useful to have the dmraid package as part of the liveCD so people with this setup, which is becoming more prevalent with the rise of SATA, aren't left without access to their hard drives until they figure out what is going on. Logs files follow.

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 130, in ?
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 55, in install
    ret = wizard.run()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 309, in run
    self.progress_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 524, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s; see "
RuntimeError: Install failed with exit code 1; see /var/log/installer/syslog and /var/log/syslog

Contents of /var/log/installer/syslog:

<< deleteted 33000 lines >>

Changed in ubiquity:
status: Unconfirmed → Confirmed
John (jc453) on 2006-10-17
description: updated
description: updated
Tormod Volden (tormodvolden) wrote :

Please use attachments for the log files. Pasting 33000 lines into the bug report makes it unreadable.

description: updated
Tormod Volden (tormodvolden) wrote :

See also bug #73141 on grub and dmraid.

Johan Schiff (johan-idealist) wrote :

I have the same problem.

Using:
Asus P5B mobo
2xSATA 320MB disks
RAID 0 "fake raid" setup on jmicron controller

I'm installing ubuntu 8.10 from usb stick with an extra 'sudo apt-get install dmraid' to get access to the raid-device.

I would be happy to run any tests and submit logs for this one. Also, I checked out bug #73141 and tried to mess with /boot/grub/device.map and some other stuff, but didn't become much wiser.

Danny Wood (danwood76) wrote :

Once it crashes you can still configure the bootloader following the original community guide:
https://help.ubuntu.com/community/FakeRaidHowto#Set%20Up%20the%20Bootloader%20for%20RAID

Just change root to the installer target:
sudo chroot to /target

install dmraid:
sudo apt-get install dmraid

Then follow that grub guide I posted above, don't go further than "Ubuntu 5.10" as anything past that is outdated and not required.

I think this could be integrated into the grub section of ubiquity as its not much extra to work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Phillip Susi (psusi) on 2014-01-07
affects: grub-installer → ubuntu
Changed in ubuntu:
status: New → Confirmed
Phillip Susi (psusi) wrote :

At the time this bug was fixed, ubuntu did not support dmraid. It has correctly for quite a few years now, so I believe this to be fixed.

no longer affects: ubuntu
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers