Kubuntu installer crashes when starting (daily-live January 22nd)

Bug #511947 reported by Bernhard Hanakam on 2010-01-24
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

Here's the summary of the crash (reproducable):

Traceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 450, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 435, in main
    install(args[0], query=options.query)
  File "/usr/lib/ubiquity/bin/ubiquity", line 239, in install
    wizard = ui.Wizard(distro)
  File "/usr/lib/ubiquity/ubiquity/frontend/kde_ui.py", line 205, in __init__
    mod.breadcrumb.setText(self.get_string(breadcrumb))
TypeError: argument 1 of QLabel.setText() has an invalid type

This happens every time when I click on "install kubuntu". As I said above, I used the daily-live-CD of January 22nd (amd64).

Bernhard Hanakam (jiraiya) wrote :
Monkey (monkey-libre) on 2010-01-24
tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.15

---------------
ubiquity (2.1.15) lucid; urgency=low

  [ Mario Limonciello ]
  * Add a new template, ubiquity/only-show-installable-languages for modifying
    the behavior of what languages to offer on an invokation based upon
    what's installed or "available" to install according to an apt cache.
  * Expose extra functions get and substitute to plugins via it's
    second argument (currently called Progress).
  * Drop extraneous handlers from Mythbuntu pages.
  * Move all handlers from mythbuntu_ui directly into plugins themselves.
  * Move some functions from the install.py script into a new file,
    install_misc. The intention here is that they can then be used more
    directly by ubiquity plugins.
  * Add a new method for package removals to install_misc to allow
    plugins to mark packages to be removed later in remove_extras.
  * Modify the Mythbuntu services plugin to not even offer VNC if a short
    pw. (LP: #469312)
  * Convert most of the functions from mythbuntu_install.py into plugin
    type Install methods.
  * Support using pkgsel/install-language-support preseeded to false to
    ignore installation of language packs (just like alternates).
  * Drop mythbuntu_ui and all references to it. The (former) Mythbuntu
    frontend is now fully pluggable into ubiquity's gtk_ui on it's own.
  * Fix unmount command in chroot_cleanup to actually release /target/dev.
  * In the KDE frontend for ubi-language, use findChildren to find widgets
    because QWidget itself is not iterable.
  * In the KDE frontend, don't try to set the text on the breadcrumbs early
    as translations don't appear ready yet. The widgets will still load,
    and translate when the langauge is changed. (LP: #511947)
  * Automatic update of included source packages: console-setup
    1.34ubuntu8, debian-installer-utils 1.72ubuntu2, tzsetup
    1:0.26ubuntu4.

  [ Evan Dandrea ]
  * Support getting the timezone from a geoip server (LP: #229884).
  * Move oem-config runtime debconf questions into the oem-config
    package.
  * Add oem-config/early_command (run a command just before oem-config
    starts).
  * Support installing additional packages at runtime in oem-config, as
    specified by oem-config/extra_packages.
 -- Mario Limonciello <email address hidden> Sun, 31 Jan 2010 23:44:44 -0600

Changed in ubiquity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments