Installs '/' in the '/boot' partition

Bug #50825 reported by otaku on 2006-06-24
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
delboy

Bug Description

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 130, in ?
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 55, in install
    ret = wizard.run()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 266, in run
    self.process_step()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 741, in process_step
    self.mountpoints_to_summary()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 1029, in mountpoints_to_summary
    self.progress_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 538, in progress_loop
    raise RuntimeError, ("Install failed with exit code %s; see "
RuntimeError: Install failed with exit code 1; see /var/log/installer/syslog and /var/log/syslog

otaku (otaku-unixborg) wrote : syslog

syslog

otaku (otaku-unixborg) wrote :

syslog

partman

My partition table is set up so that /boot is the first partition, / is the second partition, and swap is a logical partition.

The installer assumes that hda1 (really /boot) is /. I change this in the part of the installer where I can change it, then the installation starts. But the installer continues to insist on installing the root filesystem into my /boot partition!

I know this because when I go back into the installer, it shows that my /boot partition is full even though it was reformatted before install.

My /boot partition is /dev/hda1 (130MB)
My / partition is /dev/hda2 (30 GB)
My swap partition is /dev/hda5 (3GB)

After exiting the installer, Ubuntu informs me that /target is full. When I mount boot after the installer crashes, I can see a directory structure that resembles that of root.

I have attempted this install multiple times to ensure that I am selecting the correct partition as /boot (the 130MB one) and the correct root partition (30GB).

This appears to be a pretty major flaw in the user interface.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Thank you for your detailed report with logs. I can confirm your choice of mountpoints and their sizes from the logs. This is clearly not the usual 'out of disk space' problem and will be looked at more closely.

Sorry that it has taken us so long to reply to this.

Changed in ubiquity:
importance: Undecided → Medium
delboy (derek635) on 2009-11-17
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
assignee: nobody → delboy (derek635)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers