No drive detected within QEMU

Bug #48390 reported by Stuart Ellis on 2006-06-04
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Running ubiquity from a Ubuntu 6.06 Desktop CD within a QEMU session, applications don't see the QEMU virtual hard drive. This includes the GNOME Partition Manager, and Ubiquity.

If I run the Install it reaches step 5, loads the partitioner, and the partitioning screen displays no disks. The only active option is "Cancel". The error produced in /var/log/partman is:

parted_server: Read command: PARTITIONS
parted_server: The device ubuntu is not opened.
parted_server: Line 1188. CRITICAL ERROR!!! EXITING.

The host is a standard Fedora Core 5 system running QEMU 0.8.1, and is used with other guest OSes without issue (Ubuntu Breezy, Windows 2000 etc.).

Stuart Ellis (stuart-ellis) wrote :

Sorry - the QEMU package here is actually version 0.8.0-6.fc5.

/var/log/partman for attempted install.

Main syslog for the guest system.

FWIW, this is /var/log/installer/syslog - again, the hard drive is isn't seen by any app, so I don't think that the issue is with Ubiquity or partman.

Walter Tautz (wtautz) wrote :

did you run a command like: qemu -boot d -hda virtual-qemu-test.img -cdrom Desktop/ISO\ Images/ubuntu-7.04-server-i386.iso -m 512
I.E., -hda must specify a virtual disk image otherwise no disk will be detected ;-)

Chris Coulson (chrisccoulson) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in ubiquity:
status: New → Incomplete
assignee: nobody → chrisccoulson
Mikhail Gusarov (dottedmag) wrote :

Works fine with 8.04, however I tested 6.06 again - it did not.

Changed in ubiquity:
status: Incomplete → Fix Released
Changed in ubiquity:
assignee: chrisccoulson → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers