recover more gracefully from /var/cache/debconf being deleted

Bug #48369 reported by MarkyC on 2006-06-04
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity

When I was trying to install Xubuntu via Ubiquity (the install icon on the desktop, I apologize if I have the name wrong), I ran into a problem when it was time to enter my login info (step 4) it automagically goes to setting up the partitioner while I'm writing. I have a video, but can't upload right now, it'll be up in 15 minutes though.

MarkyC (mmmarcooo) wrote :

Alright, really bad quality because I'm in a hurry to go to my cousins confirmation, but kinda-sorta viewable. Also there is another bug in the install NTP support part, when I had to delete some debconf files (templates.dat, passwords.dat, something-else.dat) in the /var/cache/debconf (I think, I'm gonna make a real bug report for that when I get home) directory. http://www.speedyshare.com/211493621.html

Colin Watson (cjwatson) wrote :

Wow, a video is an innovative although rather bandwidth-heavy approach. :-) Unfortunately it doesn't really tell me much. Could you please run 'UBIQUITY_DEBUG=1 sudo ubiquity' from a terminal and attach /var/log/installer/syslog to this bug? Be sure to use a throwaway password if you get that far, since in debug mode the password will be written to the log file.

Changed in ubiquity:
status: Unconfirmed → Needs Info
Colin Watson (cjwatson) wrote :

By the way, if you delete random files in /var/cache/debconf, you'll really need to reboot to make the installer work properly again. Did you by any chance do this before this error occurred?

The NTP problem is bug 47859. It can, obviously, be worked around by just not choosing to install NTP support while running the installer.

MarkyC (mmmarcooo) wrote :

Actually Colin, I can't finish the installer due to the installer crashed (line 130) bug. But I will try again without choosing to install ntp support. Also, I would take pictures, but the screen moves fast and I don't know how to illustrate it. And I can fill out the personal info, but I have to click back 3-4 times in order to finish filling it out.

Colin Watson (cjwatson) wrote :

I don't mind that you can't finish the installation, and I don't mind that you can't finish filling out the personal information screen easily; all I need you to do is run through the installer in debug mode to the first point when the personal information screen starts behaving weirdly, and stop there and send me the bug.

(By the way, with regard to "line 130", you're reading the traceback upside-down ... the actual point where the exception is raised is at the bottom of the traceback, not the top.)

Colin Watson (cjwatson) wrote :

("send me the bug" -> "send me the log". Oops.)

When in debug mode, and choosing not to install ntp support, it seems to not do it... Then I did my little fix (rm'ing those /var/cache/debconf files) and I got this error. And it won't start anymore...giving me errors on lines 441 and 1121

OK, thanks for the log and the confirmation that this only happens if you delete files in /var/cache/debconf. I'm really quite inclined to reject this, on the grounds that removing files in /var/cache/debconf is pretty much akin to removing ubiquity's brains through its nose and throwing them in the bin; that's where it keeps all its text strings and its database, and you absolutely must not remove it.

However, it *is* /var/cache, and it would be nice if ubiquity could recover gracefully from having it deleted out from under it, per the FHS. So I'll keep this around as a wishlist request.

Changed in ubiquity:
status: Needs Info → Confirmed
MillenniumBug (millenniumbug) wrote :

This bug reports is several years old and concerns obsolete versions of Ubuntu. It has now been marked 'invalid'.

If the but still appears in Ubuntu 10.10, feel free to open a new report.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers