crashes if some packages on live fs are unconfigured

Bug #47859 reported by Matthew Kogan
362
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

If any packages in the running live filesystem are unconfigured, then install.py crashes while trying to install language packs. This suggests that apt is not being properly pointed at the target filesystem.

Revision history for this message
Matthew Kogan (matthew-epoq) wrote :

I think this might be down to a corrupt CD. I'm re-downloading and re-writing now, so I'll let you know if that fixes it. By the way, sorry about the long bug report. I didn't find out about the facility to attach files until after I'd posted it. Perhaps it would be a good idea to allow files to be attached on the same page as the bug report itself is entered. Or at least have a note to the effect that files can be attached afterwards.

Revision history for this message
Colin Watson (cjwatson) wrote :

You've got a half-configured sun-java5-bin; fix it or remove it before starting the installer.

(Yes, the installer should be fixed so that this doesn't upset it, though)

Revision history for this message
Colin Watson (cjwatson) wrote :

I absolutely agree with you about bug attachments, but I have no control over that myself. I filed a bug about this some time ago: https://launchpad.net/products/malone/+bug/30856

Revision history for this message
Matthew Kogan (matthew-epoq) wrote :

Well, I rebooted the machine and it installed without crashing, so I guess the CD was fine after all.

Thanks for your help.

Colin Watson (cjwatson)
Changed in ubiquity:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson)
description: updated
Revision history for this message
Colin Watson (cjwatson) wrote :

ubiquity (1.1.3) edgy; urgency=low

  * Fix typoed variable name while raising InstallStepError.
  * Rename Partman component to PartmanAuto to allow for a future all-in-one
    partman component
    (https://launchpad.net/distros/ubuntu/+spec/ubiquity-advanced-partitioner).
  * When an error occurs with the install progress bar up, only return to
    autopartitioning if the partitioner is still running.
  * Turn DebconfInstallProgress upside-down so that the main process handles
    apt installation and the subprocess handles the translation of apt
    status messages into debconf protocol messages, rather than the other
    way round. The previous approach resulted in exceptions from apt ending
    up in the wrong process.
  * Silence apt errors while installing language packs, since we ignore them
    anyway.
  * Point apt at /target/var/lib/dpkg/status rather than
    /var/lib/dpkg/status (closes: Malone #47859).
  * Handle new initramfs-tools configuration directory.
  * Set debconf's escape capability when fetching extended descriptions,
    since they're potentially multi-line.
  * Use partman's confirmation message rather than generating it ourselves,
    now that its use of multi-line SUBSTs has been fixed (closes: Malone
    #47043).
  * Make the rest of the summary text translatable.
  * Display grub-installer/install_to_xfs question if it's asked.
  * Fix get_filesystems() not to assume ext3 in quite so many situations.
  * Detect XFS for validation purposes even when it wasn't just formatted by
    gparted/qtparted (closes: Malone #53642).
  * Fix all mentions of gparted in the KDE frontend.
  * Leave existing newworld boot partitions alone when committing manual
    partitioning changes.
  * Automatic update of included source packages: localechooser
    1.20ubuntu4, partman-auto 54ubuntu2, partman-base 90ubuntu2.

 -- Colin Watson <email address hidden> Mon, 24 Jul 2006 18:16:25 +0100

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :
Download full text (3.3 KiB)

This will also be fixed in the first Dapper point release.

ubiquity (1.0.13) dapper-updates; urgency=low

  * Don't require entering a full name (see
    http://www.hermann-uwe.de/blog/os-install-experiences-part-4-ubuntu).
  * GTK frontend:
    - Return None from location_from_point if point is None (thanks to Chris
      Moore for the idea; closes: Malone #48885).
  * KDE frontend:
    - Add slightly more paranoia in case getNearestCity returns None.
  * Don't show hw-detect/modprobe_error, and make it non-fatal (closes:
    Malone #48524).
  * Make it clear in the crash dialog that you should file a new bug, not
    attach your details to an existing bug.
  * Take a copy of the supplied choice map in set_keyboard_choices.
  * Save tracebacks from install.py and slurp them back into the traceback
    displayed if install.py exits non-zero.
  * Warn in the partitioner if you try to use XFS for /boot (closes: Malone
    #47848).
  * Warn in the partitioner if system filesystems are not reformatted
    (closes: Malone #47046).
  * Use os._exit() rather than sys.exit() in the apt install progress child
    process after forking, fixing a lot of strange "PROGRESS STOP" messages
    in /var/log/installer/syslog and bizarre debconf exceptions. See also
    Malone #53298.
  * Use 'replace' Unicode error handling when dealing with data coming from
    debconf (closes: Malone #44595, #48732).
  * Fix ubiquity/install/apt_error_install and
    ubiquity/install/apt_error_remove templates to be of type 'error'
    (closes: Malone #53258).
  * Install more defence against gparted/qtparted crashing (closes: Malone
    #47194, #48856).
  * If gparted or qtparted crashes, put up a dialog allowing the user to try
    again, return to autopartitioning, or quit the installer. This is a
    pretty awful hack, but hopefully we won't be using gparted/qtparted for
    all that much longer ...
  * Fix crash in KDE frontend while translating widgets (closes: Malone
    #53367).
  * When an error occurs with the install progress bar up, only return to
    autopartitioning if the partitioner is still running.
  * Turn DebconfInstallProgress upside-down so that the main process handles
    apt installation and the subprocess handles the translation of apt
    status messages into debconf protocol messages, rather than the other
    way round. The previous approach resulted in exceptions from apt ending
    up in the wrong process.
  * Silence apt errors while installing language packs, since we ignore them
    anyway.
  * Point apt at /target/var/lib/dpkg/status rather than
    /var/lib/dpkg/status (closes: Malone #47859).
  * Display grub-installer/install_to_xfs question if it's asked.
  * Fix get_filesystems() not to assume ext3 in quite so many situations.
  * Detect XFS for validation purposes even when it wasn't just formatted by
    gparted/qtparted (closes: Malone #53642).
  * Fix all mentions of gparted in the KDE frontend.
  * Leave existing newworld boot partitions alone when committing manual
    partitioning changes.
  * Always set mirror/country to the country selected on the timezone page,
    regardless of what localechooser does thereafter (closes: Ma...

Read more...

Przemek K. (azrael)
Changed in ubiquity (Baltix):
status: New → Fix Released
To post a comment you must log in.