"Incomplete Language Support" is still shown when a DVD installation is preseeded with ALL

Bug #471553 reported by Mario Limonciello on 2009-11-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
pkgsel (Ubuntu)
Undecided
Evan
Karmic
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Evan
Karmic
Undecided
Unassigned

Bug Description

TEST CASE:
Preseed d-i pkgsel/language-packs string ALL. On reboot after installation, you should not see the "Incomplete Language Support" message.

Original report follows:
Binary package hint: ubiquity

Using the gold Ubuntu 9.10 media and the preseed " d-i pkgsel/language-packs string ALL", the note

/var/lib/update-notifier/user.d/incomplete-language-support-gnome.note is created causing this error to show on the first boot.

Mario Limonciello (superm1) wrote :
Changed in ubiquity (Ubuntu):
assignee: nobody → Evan Dandrea (evand)
importance: Undecided → Medium
status: New → Triaged
Robbie Williamson (robbiew) wrote :

Assigning to Evan, but he's having some internet connection issues today, so I will also subscribe Colin.

Changed in oem-priority:
importance: Undecided → Medium
Evan (ev) wrote :

Mario,
Your syslog indicates that you didn't have network access at the time of installation. It is by design that you would see this message on reboot if you had preseeded all of the languages but ubiquity was unable to install them. Is this just an oversight, or are you requesting that we provide a mechanism to avoid the incomplete language support question altogether?

I did notice on my machine, however, that there appears to be a bug in gnome-user-guide-gu, which erroneously contains gnome-access-guide-ar.omf, amongst other files present in other packages. This will always fail to install, and thus will force the presence of the incomplete language support message.

Mario Limonciello (superm1) wrote :

Hi Evan:

This is correct. Network access is impossible during the type of installation being performed.

So this is indeed requesting a mechanism to avoid the language support question altogether when "ALL" has been preseeded.

Evan (ev) on 2009-11-10
Changed in pkgsel (Ubuntu):
assignee: nobody → Evan Dandrea (evand)
status: New → Fix Committed
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Evan (ev) on 2009-11-12
description: updated

Accepted ubiquity into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

I doubt that it is very relevant since we won't re-roll Karmic CDs. but it might be useful for OEMs. This can be tested by upgrading ubiquity on the live system before doing the preseeding and installation, I take it?

Changed in ubiquity (Ubuntu Karmic):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.0

---------------
ubiquity (2.1.0) lucid; urgency=low

  [ Evan Dandrea ]
  * Run X with -nolisten tcp (LP: #462394).
  * Make sure we never try to install onto the live filesystem.
  * Only print the filenames being blacklisted if in debug mode.
  * Provide human readable sizes in the partitions-too-small warning
    (LP: #298974).
  * Mark the "Installation Complete" window as always on top
    (LP: #462178).
  * Fixes from Pychecker for the KDE frontend (kde_ui):
    - Don't import datetime or math. The timezone code is in a separate
      module now.
    - Remove some unused variables.
    - Don't assign to a variable that's going to be immediately discarded.
  * Signal to GTK+ when using a right-to-left language, so that it
    composes the interface from right to left (LP: #222845).
  * Signal to the slideshow when the installer is using a right-to-left
    language (LP: #446989).
  * Set SUDO_UID and SUDO_GID in ubiquity-dm so ubiquity knows what user
    to drop privileges to (LP: #422254).
  * Do not try to configure networking in oem-config (LP: #471498).
  * Make migration-assistant import failures non-fatal to the overall
    install.
  * pkgsel now provides a debconf question to avoid warning the end user
    when the language packs could not be installed (LP: #471553).
  * Make sure a device exists as part of the grub target device
    validation.
  * Allow the user to retry grub installation with a different device on
    failure.
  * Automatic update of included source packages: apt-setup
    1:0.42ubuntu1, choose-mirror 2.29ubuntu2, clock-setup 0.100ubuntu1,
    debian-installer-utils 1.71ubuntu1, grub-installer 1.47ubuntu1, hw-
    detect 1.73ubuntu1, netcfg 1.51ubuntu1, partman-base 135ubuntu1,
    tzsetup 1:0.26ubuntu1, user-setup 1.28ubuntu1.

  [ Colin Watson ]
  * Add a debian/rules target to run pychecker. I've fixed several warnings,
    but there are still several left so this is not yet enabled by default.
  * Fix debconf frontend:
    - Start oem-config on stopping rc, as well as when starting display
      managers.
    - Add some missing imports (ubiquity.frontend.base.Controller,
      ubiquity.plugin.Plugin, ubiquity.i18n, signal,
      ubiquity.components.install).
    - If there's a containing debconf frontend, talk to it rather than using
      debconf-communicator.
    - Set a controller in the language plugin.
    - Use spaces rather than ${!TAB} in localechooser when using the debconf
      frontend, since debconf doesn't support the latter yet.
    - Don't handle user-setup preseeding for the debconf frontend.
    - Remove unused progress_position handling.
    - Fix exception names in ubi-network and ubi-tasks.
  * Require Python 2.5, so we can now use hashlib rather than md5 and avoid
    a slew of warnings.
  * Add an intro message noting that we're alpha again.
 -- Evan Dandrea <email address hidden> Fri, 13 Nov 2009 10:41:42 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Jerone Young (jerone) on 2009-11-25
Changed in oem-priority:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.0.9

---------------
ubiquity (2.0.9) karmic-proposed; urgency=low

  * Do not try to configure networking in oem-config (LP: #471498).
  * pkgsel now provides a debconf question to avoid warning the end user
    when the language packs could not be installed (LP: #471553).
 -- Evan Dandrea <email address hidden> Thu, 12 Nov 2009 15:00:43 +0000

Changed in ubiquity (Ubuntu Karmic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pkgsel - 0.25ubuntu5

---------------
pkgsel (0.25ubuntu5) lucid; urgency=low

  [ Evan Dandrea ]
  * Provide a way to avoid warning the end user when the language packs
    could not be installed (LP: #471553).

  [ Colin Watson ]
  * Install zh-hans language packs for zh_CN, and zh-hant language packs for
    zh_TW (LP: #517621).
 -- Colin Watson <email address hidden> Wed, 10 Feb 2010 09:56:22 +0000

Changed in pkgsel (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in pkgsel (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers