breaks if system partitions are not reformatted

Bug #47046 reported by Mark Constable
916
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson

Bug Description

Installing RC onto a serial ATA drive to /dev/sda10 mounted as /target. It seemed to have copied all files and was about to install the packages.

Traceback (most recent call last):
  File "/usr/bin/ubiquity", line 120, in ?
    install(sys.argv[1])
  File "/usr/bin/ubiquity", line 54, in install
    ret = wizard.run()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 311, in run
    self.process_step()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 729, in process_step
    self.mountpoints_to_summary()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 1034, in mountpoints_to_summary
    self.progress_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/kde-ui.py", line 524, in progress_loop
    raise RuntimeError, "Install failed with exit code %s" % ret
RuntimeError: Install failed with exit code 1

Revision history for this message
Dennis Kaarsemaker (dennis) wrote : Re: [Bug 47046] Ubiquity crash

Please attach /var/log/installer/syslog and /var/log/partman to this
bug.

Revision history for this message
Mark Constable (markc) wrote : Re: Ubiquity crash

Unfortunately that livecd session is no longer available but I will know, next time, what log files to attach.

However, I think (95%) I know what may have caused this problem. The partition I was installing onto had (or may have had) a previous amd64 test installation (probably Gentoo) and when Ubiquity tried to chroot into /target to complete the installation it could have crashed if any x86_64 binaries or libs were called. When I checked the partition after this failed attempt there was a lib -> lib64 link in / and I did use this machine for testing various 64 bit installs over the last year. When I reformatted that partition and tried again the Ubiquity installation succeeded and I could boot on that particular partition.

So perhaps there is not a problem with Ubiquity and this was simply operator error. However, maybe a check for unsuccessful execution when chroot'ing could provide a warning.

Revision history for this message
Colin Watson (cjwatson) wrote :

I should either enforce reformatting of /, /usr, and other system partitions, or I should put up a warning in the event that they are not reformatted.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Revision history for this message
Mark Constable (markc) wrote :

If you enforce reformatting of system partitions then please be careful. In my case above I was using /dev/sda10 only as a test install. There were still usable and wanted "real" 64bit system partitions on /dev/sda5 thru /dev/sda8 (sda9 is my swap on this drive).

My USB wireless card would not work at all with the RC amd64 installation so I was installing the regular i386 RC onto a spare partition on the same hardware to see if that would work with my wireless device (and it did, intermittently).

Revision history for this message
Colin Watson (cjwatson) wrote :

Naturally we'd only force reformatting of partitions that you actually had mounted on /, /usr, or whatever, not random other ones lying around on the disk.

I think I prefer d-i's approach though - put up a warning and let the user decide whether to go ahead anyway.

Revision history for this message
Cristian Nastase (cnastase) wrote :

The system breaks even the partitions ARE formatted. I got the same error ... and I forced formating the swap and / partions. Tha latter I did it as XFS. In fact it took me 1 hour to try to install. Qtparted was a complete mess. Kept trying to install on the ntfs partion. Could not find why the swap and / entries were missing for the life of me. So I used fdisk and mkfs /dev/hdaX -t xfs. Then the installer went ok till this bug. How do I attach the syslog and partman. I forgot to mention that I am talking about the x86_64 version.

Revision history for this message
Andre Landwehr (andrel) wrote :

I have the same problem here, Dapper Drake final for AMD 64. I tried to install into fresh partitions, but use my old 32 Bit XFS /home without formatting it. Ubiquity crashed 100% reproducible. Now I install without using my old home and it seems to work. I'll try to mount the stuff by hand later when I have the system up and running.

Revision history for this message
Colin Watson (cjwatson) wrote :

Cristian, you're encountering a different problem. See "Crash if /boot is on XFS" in https://wiki.ubuntu.com/DapperReleaseNotes/UbiquityKnownIssues. Andre, you may well be having that problem too.

Revision history for this message
Cristian Nastase (cnastase) wrote : Re: [Bug 47046] Re: breaks if system partitions are not reformatted

Ha ... I actually fixed it the way is explained without knowing it ... I
found some old stuff on goggle xfs/ubuntu related where somebody was
mentioning that ubuntu needs a /boot as ext3 ... I did it and it worked
perfectly. That was yesterday ... Anyway, I will post later on today my
solution for reference (for it needs additional fix for qtparted). All
in all I have to take bow for kubuntu/community ...

Colin Watson wrote:

>Cristian, you're encountering a different problem. See "Crash if /boot
>is on XFS" in
>https://wiki.ubuntu.com/DapperReleaseNotes/UbiquityKnownIssues. Andre,
>you may well be having that problem too.
>
>
------------------------------------------------------------------------

Revision history for this message
Wessel van Norel (delgurth) wrote :

You say you should reformat the partitions. But my experience with this bug was the following. If I created the mountpoints myself (with amd64 flight 6), I would get this exception. Both mountpoints where set to be formatted. If I told ubunto to just create the mountpoints by itself, nothing was wrong. But I don't want to use the entire disk for ubuntu, so that's not an option for me.

I hope you guys can work this problem out.

Revision history for this message
Wessel van Norel (delgurth) wrote :

Oh, I should read better before commenting. I guess I've also experienced the XFS /boot problem.

I'll try it with a non XFS /boot partition, and I assume that will resolve my problem.

Revision history for this message
Colin Watson (cjwatson) wrote :
Download full text (3.2 KiB)

Fixed in Edgy, to be released in October 2006. I've also included this fix in the list of changes scheduled to go into the first point release of Dapper, which will probably be in August 2006. Since there are a lot of people subscribed to this bug due to duplicates, I'd appreciate it if any queries about this bug or complaints about the form of the fix were sent by private e-mail or filed as new bugs respectively.

ubiquity (1.1.0) edgy; urgency=low

  * Use try/finally in install.py to ensure that PROGRESS STOP is always
    called; ignore errors from PROGRESS STOP (e.g. because debconf has gone
    away due to a previous error).
  * Support /UNIONFS (Knoppix) as well as /rofs as the read-only filesystem
    source.
  * Don't require entering a full name (see
    http://www.hermann-uwe.de/blog/os-install-experiences-part-4-ubuntu).
  * GTK frontend:
    - Return None from location_from_point if point is None (thanks to Chris
      Moore for the idea; closes: Malone #48885).
  * KDE frontend:
    - Add slightly more paranoia in case getNearestCity returns None.
  * Don't show hw-detect/modprobe_error, and make it non-fatal (closes:
    Malone #48524).
  * Make it clear in the crash dialog that you should file a new bug, not
    attach your details to an existing bug.
  * Add passwd and adduser dependencies from user-setup.
  * Take a copy of the supplied choice map in set_keyboard_choices.
  * Save tracebacks from install.py and slurp them back into the traceback
    displayed if install.py exits non-zero.
  * Convert to new Python policy (python-central). Install Python
    modules/extensions to /usr/lib/ubiquity/ubiquity rather than into the
    public module path.
  * Warn in the partitioner if you try to use XFS for /boot (closes: Malone
    #47848).
  * Warn in the partitioner if system filesystems are not reformatted
    (closes: Malone #47046).
  * Remove /usr/bin/espresso compatibility symlink.
  * Use os._exit() rather than sys.exit() in the apt install progress child
    process after forking, fixing a lot of strange "PROGRESS STOP" messages
    in /var/log/installer/syslog and bizarre debconf exceptions. See also
    Malone #53298.
  * Use exceptions to communicate all failures in install.py, so that we get
    more useful tracebacks.

  * Automatic update of included source packages: apt-setup 1:0.11ubuntu1,
    base-installer 1.63ubuntu2, choose-mirror 2.04ubuntu1, clock-setup
    0.10ubuntu1, debian-installer-utils 1.32ubuntu1, grub-installer
    1.17ubuntu1, hw-detect 1.38ubuntu1, kbd-chooser 1.29ubuntu1,
    localechooser 1.20ubuntu3, partconf 1.16, partman-auto 54ubuntu1,
    partman-base 90ubuntu1, partman-basicfilesystems 47ubuntu1,
    partman-basicmethods 30, partman-ext3 41, partman-jfs 17,
    partman-newworld 13, partman-palo 4, partman-partitioning 40ubuntu1,
    partman-reiserfs 31, partman-target 42ubuntu1, partman-xfs 29,
    silo-installer 1.04ubuntu1, tzsetup 1:0.10ubuntu1, user-setup
    1.2ubuntu2, yaboot-installer 1.1.7ubuntu1.
  * Handle move of prebaseconfig scripts to (variously) post-base-installer
    or finish-install.
  * Install search-path from debia...

Read more...

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Released
Revision history for this message
Stephane (mittiprovence) wrote : SV: [Bug 47046] Re: breaks if system partitions are not reformatted

I just saw that.
Both / and /home need to be reformatted.

Thanks

Stephane

Colin Watson <email address hidden> skrev: ** Bug 54017 has been marked a duplicate of this bug

--
breaks if system partitions are not reformatted
https://launchpad.net/bugs/47046

Revision history for this message
Colin Watson (cjwatson) wrote :
Download full text (3.4 KiB)

This will also be fixed in the first Dapper point release (which should hopefully dry up the flood of new reports of this problem!).

ubiquity (1.0.13) dapper-updates; urgency=low

  * Don't require entering a full name (see
    http://www.hermann-uwe.de/blog/os-install-experiences-part-4-ubuntu).
  * GTK frontend:
    - Return None from location_from_point if point is None (thanks to Chris
      Moore for the idea; closes: Malone #48885).
  * KDE frontend:
    - Add slightly more paranoia in case getNearestCity returns None.
  * Don't show hw-detect/modprobe_error, and make it non-fatal (closes:
    Malone #48524).
  * Make it clear in the crash dialog that you should file a new bug, not
    attach your details to an existing bug.
  * Take a copy of the supplied choice map in set_keyboard_choices.
  * Save tracebacks from install.py and slurp them back into the traceback
    displayed if install.py exits non-zero.
  * Warn in the partitioner if you try to use XFS for /boot (closes: Malone
    #47848).
  * Warn in the partitioner if system filesystems are not reformatted
    (closes: Malone #47046).
  * Use os._exit() rather than sys.exit() in the apt install progress child
    process after forking, fixing a lot of strange "PROGRESS STOP" messages
    in /var/log/installer/syslog and bizarre debconf exceptions. See also
    Malone #53298.
  * Use 'replace' Unicode error handling when dealing with data coming from
    debconf (closes: Malone #44595, #48732).
  * Fix ubiquity/install/apt_error_install and
    ubiquity/install/apt_error_remove templates to be of type 'error'
    (closes: Malone #53258).
  * Install more defence against gparted/qtparted crashing (closes: Malone
    #47194, #48856).
  * If gparted or qtparted crashes, put up a dialog allowing the user to try
    again, return to autopartitioning, or quit the installer. This is a
    pretty awful hack, but hopefully we won't be using gparted/qtparted for
    all that much longer ...
  * Fix crash in KDE frontend while translating widgets (closes: Malone
    #53367).
  * When an error occurs with the install progress bar up, only return to
    autopartitioning if the partitioner is still running.
  * Turn DebconfInstallProgress upside-down so that the main process handles
    apt installation and the subprocess handles the translation of apt
    status messages into debconf protocol messages, rather than the other
    way round. The previous approach resulted in exceptions from apt ending
    up in the wrong process.
  * Silence apt errors while installing language packs, since we ignore them
    anyway.
  * Point apt at /target/var/lib/dpkg/status rather than
    /var/lib/dpkg/status (closes: Malone #47859).
  * Display grub-installer/install_to_xfs question if it's asked.
  * Fix get_filesystems() not to assume ext3 in quite so many situations.
  * Detect XFS for validation purposes even when it wasn't just formatted by
    gparted/qtparted (closes: Malone #53642).
  * Fix all mentions of gparted in the KDE frontend.
  * Leave existing newworld boot partitions alone when committing manual
    partitioning changes.
  * Always set mirror/country to the country selected on the timez...

Read more...

Revision history for this message
Erich Graßmann (erich-grassmann) wrote : Bug 57730 - Installer crashed

Hello Vassilis,

thanks for your answer.

It's correct, the partition for installing ubuntu wasn't formatted by the installer. But I thought it was a free ext3-partition, only formatted by SuSE Linux (9.x or 10.0). And now I remember there was a crashed Kubuntu-Installation (after download by internet). I'm sorry I don't remember why the kubuntu-Installer crashed.

I'll try it again (but not today).

Erich

(excuse my bad English, I'm better in German)

-----Ursprüngliche Nachricht-----
Von: Bug 47046 <email address hidden>
Gesendet: 26.08.06 12:55:22
An: <email address hidden>
Betreff: [Bug 47046] Re: breaks if system partitions are not reformatted

** Bug 57730 has been marked a duplicate of this bug

--
breaks if system partitions are not reformatted
https://launchpad.net/bugs/47046

_____________________________________________________________________
Der WEB.DE SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen!
http://smartsurfer.web.de/?mc=100071&distributionid=000000000066

Revision history for this message
Rolf (rolf-kallenback) wrote : Re: [Bug 47046] Re: breaks if system partitions are not reformatted

Please tell me how I unregister from getting these emails.
/Rolf

2006/8/2, Carthik Sharma <email address hidden>:
>
> ** Bug 54964 has been marked a duplicate of this bug
>
> --
> breaks if system partitions are not reformatted
> https://launchpad.net/bugs/47046
>

Revision history for this message
Vassilis Pandis (pandisv) wrote :

The unsubscribe issues are known to the launchpad crew and they are working on them.... doesn't unsubscribing from bug 47046 help ?

Revision history for this message
MoMaT (momat) wrote :

It is not possible to unsubscribe from bug 47046 (original bug) since one is subscribed only to its duplicate and is just "notified" about changes in the original one (it is not a proper subsription). To stop the e-mail flood one need to unsubsribe from the duplicate. See bug 48860 for more details.

Revision history for this message
Stephane (mittiprovence) wrote : SV: [Bug 47046] Re: breaks if system partitions are not reformatted

How can I unsubscriibe from this mailing list..?

Regards,

Stephane

MoMaT <email address hidden> skrev: It is not possible to unsubscribe from bug 47046 (original bug) since
one is subscribed only to its duplicate and is just "notified" about
changes in the original one (it is not a proper subsription). To stop
the e-mail flood one need to unsubsribe from the duplicate. See bug
48860
for more details.

--
breaks if system partitions are not reformatted
https://launchpad.net/bugs/47046

Revision history for this message
Wolf Halton (saphil) wrote : Re: [Bug 47046] Re: breaks if system partitions are not reformatted

Thanks!

Reformatting worked bonzer!

-Wolf

--- Vassilis Pandis <email address hidden> wrote:

> ** Bug 63413 has been marked a duplicate of this bug
>
> --
> breaks if system partitions are not reformatted
> https://launchpad.net/bugs/47046
>

--
Summer Special - Make Money on Your Phone Bill Arrowstars.com
Computer support network: http://tech.groups.yahoo.com/group/Tech_Answers/?yguid=11909323
Eggs from Happy Chickens! Catwood Farms - 1960 Hightower Trail, Conyers GA 30012-1822 - 678-384-4930

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Revision history for this message
Mårten Woxberg (maxmc) wrote :

Isn't this bug fixed yet? I still get duplicate mails about it...

Revision history for this message
鸡毛 (liwf-net) wrote :

me too...

On Wed, Mar 26, 2008 at 1:39 AM, Mårten Woxberg <email address hidden>
wrote:

> Isn't this bug fixed yet? I still get duplicate mails about it...
>
> --
> breaks if system partitions are not reformatted
> https://bugs.launchpad.net/bugs/47046
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
鸡毛/李文富
http://liwf.net http://www.ifanshu.com

Revision history for this message
Vincent Laisney (vincent-laisney) wrote :

This bug is not fixed. I have had it today (Hardy-alternate downloaded yesterday).
On a Toshiba Satellite 1100.
I join the /var/log/syslog file I could get.
I hope it can help.
When I had reformatted the partitions. I had no more this bug (but another later!)
I hope it can help. Thanks a lot.
Vincent Laisney

Revision history for this message
鸡毛 (liwf-net) wrote : liwf wants to keep up with you on Twitter

To find out more about Twitter, visit the link below:

http://twitter.com/i/8a88391fb2e0c8334bc345b99bed6d19366868a1

Thanks,
-The Twitter Team

About Twitter

Twitter is a unique approach to communication and networking based on the simple concept of status. What are you doing? What are your friends doing—right now? With Twitter, you may answer this question over SMS, IM, or the Web and the responses are shared between contacts.

This message was sent by a Twitter user who entered your email address. If you'd prefer not to receive emails when other people invite you to Twitter, click here:
http://twitter.com/i/optout/17d38839e5e315d0183d8085a8e61c4e09ca6367

Revision history for this message
鸡毛 (liwf-net) wrote :

To find out more about Twitter, visit the link below:

http://twitter.com/i/abcd0231fe4228033e1a48c783ca3749fab35781

Thanks,
-The Twitter Team

About Twitter

Twitter is a unique approach to communication and networking based on the simple concept of status. What are you doing? What are your friends doing—right now? With Twitter, you may answer this question over SMS, IM, or the Web and the responses are shared between contacts.

This message was sent by a Twitter user who entered your email address. If you'd prefer not to receive emails when other people invite you to Twitter, click here:
http://twitter.com/i/optout/760a761b8aadfcd9216120e8f4b9c884b76096b4

Revision history for this message
Yan Maurakh (yan-maurakh) wrote :

I tried to install kubuntu-netbook (karmic alpha 3) on my hp2140 mini note, and 'ubiquity' is still in error messages

Revision history for this message
Wolfgang Habermann (whabermann) wrote : Wolfgang Habermann/GUS/DE ist nicht im Büro

Ich werde ab 23.07.2009 nicht im Büro sein. Ich kehre zurück am
12.08.2009.

Ich werde Ihre Nachricht nach meiner Rückkehr beantworten.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments