[PPC install 2006-05-25] problems with hfs partitions during manual partitioning

Bug #46735 reported by Per Christian Henden on 2006-05-26
8
Affects Status Importance Assigned to Milestone
Zenity
Invalid
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

I discovered a bug during the installation of 2006-05-25/RC1 when using manual partitioning. I'm dualbooting OSX and ubuntu.

My partition table is

/dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map
/dev/hda2 Apple_Bootstrap untitled 117187 @ 64 ( 57.2M) NewWorld bootblock
/dev/hda3 Apple_HFS mac 39062500 @ 117251 ( 18.6G) HFS
/dev/hda4 Apple_UNIX_SVR2 untitled 26233622 @ 39179751 ( 12.5G) Linux native
/dev/hda5 Apple_Free Extra 1989 @ 156299499 (994.5k) Free space
/dev/hda6 Apple_Void 0 @ 0 ( 0.0k) Unknown
/dev/hda7 Apple_UNIX_SVR2 untitled 89843744 @ 65413373 ( 42.8G) Linux native
/dev/hda8 Apple_UNIX_SVR2 swap 1042382 @ 155257117 (509.0M) Linux swap

I selected to mount
/dev/hda3 on /osx
/dev/hda4 on / (format)
/dev/hda8 as swap (format)
/dev/hda7 on /home
/dev/hda2 on /boot

The two partitions where successfully formatted, but two error messages showed.
They where "No filesystem specified for partition #3"
and later "No new world boot partition found".
/dev/hda2 is a valid new world boot partition.

The effect is that no entries for /dev/hda3 was included in fstab and OSX was not included in yaboot.conf. To fix it I added the entries to fstab and yaboot.conf and ran ybin.

entire /var/log/installer

Output of 'parted -s /dev/hda print'

Disk geometry for /dev/hda: 0kB - 80GB
Disk label type: mac
Number Start End Size File system Name Flags
1 1kB 32kB 32kB Apple
2 33kB 60MB 60MB hfs untitled boot
3 60MB 20GB 20GB hfs+ mac
4 20GB 33GB 13GB ext3 untitled
7 33GB 79GB 46GB ext3 untitled
8 79GB 80GB 534MB linux-swap swap swap

I retried with edgy ppc release. There was good improvement. The most serious problem, not detecting my boot partition was gone.
However, the filesystem of my hfs+ partition (/dev/hda3) was still not recognized.
Attaching /var/log/installer from my edgy installation.

Kai Kasurinen (kai-kasurinen) wrote :

I think that bug has nothing do with zenity

Changed in zenity:
status: Unconfirmed → Rejected

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in ubiquity:
status: New → Invalid
Changed in ubiquity:
status: Invalid → Incomplete

I'm not able to test it now or later, sorry about that.

Connor Imes (ckimes) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubiquity:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers