cannot select `continue' with keyboard in kde

Bug #46600 reported by Ian Jackson on 2006-05-25
20
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

I'm testing today's kubuntu daily and when I run the installer from the livecd, I'm not able to use the keyboard to progress through the wizard-style installer.

For example, currently I'm on the Language screen. I have Deutsch selected in the list. I can press tab to cycle through the various UI elements; when the (not very easy to see!) highlight reaches the Continue button I press Return but still nothing happens.

I've also tried Enter and right arrow.

Colin Watson (cjwatson) wrote :

I tried to fix this by (a) setting the "default" property on the next button in the .ui file and, separately, (b) putting self.userinterface.next.setDefault(True) after everything that programmatically enables the next button. Neither worked: the next button was the default for the first step, but after that the default became the cancel button. This is presumably due to the way we disable the next button temporarily, but I can't think of any other ways to force it to be the default again after re-enabling it.

Jonathan, can you help at all here?

Changed in ubiquity:
status: Unconfirmed → Confirmed
Adam Niedling (krychek) wrote :

Was this still an issue in the final version of Dapper(?) ?

Changed in ubiquity:
status: Confirmed → Invalid
Colin Watson (cjwatson) wrote :

This is still a valid and important issue. You had no justification for closing it.

Changed in ubiquity:
status: Invalid → Triaged
Michael Terry (mterry) wrote :

I pushed a fix for the original complaint: that pressing Enter doesn't activate those buttons, by marking Back/Forward/Quit as 'AutoDefault'. They were always activatable by pressing Space.

Colin, to address your issue, seems that the main window has to be a QDialog. The Qt documentation suggests that the whole default-button-logic only works inside of QDialogs... [1]

I'm leaving this bug open for the default-button issue.

[1] http://qt.nokia.com/doc/4.5/qpushbutton.html#default-prop

MarcRandolph (mrand) wrote :

Original complaint was addressed here:

---------------
ubiquity (1.99.22) karmic; urgency=low

  [ Michael Terry ]

  * kde: Let back/forward/quit buttons activate when highlighted and the
    user presses Enter. Part of bug #46600

Richard Johnson (nixternal) wrote :

I have been testing ubiquity-kde today/tonight with 10.04.4 LTS, 11.10, and 12.04. Having done so, I have always tabbed to continue and pressed enter w/o any issues. Alt+C also worked w/o issues. Is this still an issue for anyone else? If so, feel free to reopen this report with any further information you might think could help to me reproducing. Thank you.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers