Ubuntu

HDD(s) incorrectly detected

Reported by Paul Watkins on 2009-10-26
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubiquity

I have the following system:

500GB - WesternDigital WD500AKS-0 - empty/unpartitioned
160GB - Maxtor 6YM160M0 - Contains various paritions including Ubuntu 9.04
160GB - Maxtor 6YM160M0 - empty/unpartitioned

All of the above HDD are connected to a built in SATA controller (ICH8R) on my Intel motherboard.

I currently have no problems with my Ubuntu installation.

I just tried to run 9.10 RC and after the GUI loaded it told the 2 Maxtor drives contained errors etc. It couldn't detect anything on either 160GB and said there were numerous bad sectors.

At this point I ran the full installer to see what the partition tool in the installer had to say. It could detect the 500GB WD but described the 2x160GB Maxtors as being a 320GB RAID array. No wonder it thinks the drives are corrupted! These drives are not in a RAID array.

Any ideas why the partitioner thinks they are?

Thanks in advance

p.s. I've just seen the message below to post some logs. I'll try and post these files in a minute...

It looks like the relevant files have changed in the new installer. The only other file that looks vaguely useful is this one...

I should also add that the drives did used to be in a RAID array. Is there some historic flag that 9.04 was ignoring that 9.10 has taken exception to?

Lucio M Nicolosi (lmnicolosi) wrote :

Same thing here.
 - Running Jaunty and Karmic Beta both 64 completely OK.
 - Burned CD - K. RC, tested - OK
 - Gparted (from the Live CD) can "see" sda and all the partitions (Seagate Sata).
                  Deleted Karmic Beta root partition (sda1 ext4) to install Karmic RC AMD64 updated on Oct/28.
                  Created an empty ext4 sda1
 - Tried to install.
 - Instalation script (parted) can't "see" sda
 - Deleted sda1 with Gparted
 - Install still can't "see" sda
 - Put a ZIP drive at sdb (Pata)
 - Install (Parted) recognizes the Pata drive. (useless it is a 100 Meg ZIP) but not the Sata
 - Rebooted with PCI=NOMSI (A long time ago it worked) to no avail.

Only install script cannot recognize Sata sda - GParted on the same CD works perfectly.
... and Karmic is being released right... NOW!

Lucio M Nicolosi (lmnicolosi) wrote :

For the record:

tested done with last http://cdimage.ubuntu.com/daily-live/current/

karmic-desktop-amd64.iso 27-Oct-2009 18:31 691M

I spent some time last night playing around with the AHCI/IDE/RAID settings to no avail. In the end I decided to install 9.04 on a new partition (on one of the 160GB offending drives) and then upgrade.

The upgrade completed but the system is basically unuseable. The 160GB drives are detected as "Solid-state disk" (inlcuding the disk that 9.10 is running from - it's not. it's SATA). Running gparted caused the system to grind to a hault, it hangs when detecting partitions.

I'm out of ideas. Any suggestions?

Puleen Patel (puleen) wrote :

Having the exact same issue as Paul Watkins. The 2 160GB drives are getting detected as part of a RAID, when the motherboard RAID configuration is disabled. Using 9.04 Installer sees both drives separately and allows me to install on individual drives as I want.

Hope this is a bug in the 9.10 Installer. Pretty huge, if it is a bug. Wonder how many others are affected.

Cheers!

ilmpk (morris-ira) wrote :

I'm also having this issue with 9.10. My second hard drive is visible within the partitioner, but my primary drive is not shown.

I have 2 ST3160813AS - 160GB Sata drives running on a GIGABYTE GA-965P-DQ6.

tags: added: 9.10 detect drive hard hdd installer karmic partitioner
Richard Bailey (rmjb) wrote :

I'm also bitten by this bug, no sda :( but all the others show up.

And sda shows up everywhere else.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Richard Bailey (rmjb) wrote :

I've gotten a "fix". On the live cd I uninstalled the dmraid package, restarted the installer and now sda shows.

ilmpk (morris-ira) wrote :

I can confirm Richard's fix. I removed the dmraid package from the amd64 live cd and I was able to see the sda drive.

I've now tried the recommendation above with mixed results. After removing the dmraid package from the installer the partitioner does now correctly identify the 2x160GB as being non-RAID. However it only makes it as far as the creation of the filesystem before failing with the error that it can't create an ext4 (or ext3) file system on the target drive.

I'm beginning to suspect that there may be something genuinely wrong with the 2x160GB drives that the new version of the partitioner is more sensitive to. Does this seem reasonable?

Anyone else who is interested in modifying the install CD a good guide is here:

https://help.ubuntu.com/community/LiveCDCustomization

A couple of things to watch out for:

You need to install the most recent version of squashfs-tools. There's a deb package about if you Google search
There are 2 dmraid packages that need to be removed
Watch out for the final . on the consol command to make the modified iso

SLerman (smlerman) wrote :

I can confirm that this happens in both the Ubuntu and Kubuntu 64-bit DVD's. In my case, it's a pair of 500 GB SATA drives.

Shahar Or (mightyiam) wrote :

My test case:

1. Boot Karmic regular CD
2. I Can see SATA HDD on desktop and can mount it etc.
3. Open Ubiquity from desktop icon
4. Ubiquity doesn't see SATA HDD.

To work around this and be able to install karmic I did:

1. Disable everything that has to do with RAID in the BIOS (some Nvidia on-board software RAID)
2. Boot the karmic alternate CD
3. When asked, choose to *not* load RAID drivers
4. Installer detects the SATA HDD fine.

rhpot1991 (rhpot1991) wrote :

I had this same issue, while uninstalling dmraid lets you continues, that may be the incorrect fix. If you run dmraid -r it should show you that raid metadata exists on the hard drives which are not detected. I tested with my devbox and it seems that you can safely removed the raid metadata with dmraid -rE, the partitions were left untouched and working.

Same problem with a Seagate ST3160815AS hard disk. I can partition it manually with Gparted but when I begin to install Ubuntu, Gparted starts and freezes at 47%. I wrote tail -f /var/log/messages and saw that gparted freezes when using dmraid.

I uninstalled dmraid but gparted still freezes :o(

Tried with another SATA hard disk (Western Didital) -> same problem. Removed the IDE cd-rom driver and used an USB external CD-ROM driver, it works! The problem was not coming from the hard disk but from the IDE CD-ROM driver.

I followed John Baab's advice and sure enought there was some old RAID meta data on both drives. I've removed the data (using -rE as suggested) and the "Disk Utility" no longer things there is a RAID array present. Haven't run the installer again yet but I suspect this might be the fix I was looking for...

Lucio M Nicolosi (lmnicolosi) wrote :

Regarding my system, (see #4) just installed Maverick Beta AMD64 (2010 Sept) and the bug is gone. Live CD recognized all disks.

Colin Watson (cjwatson) on 2012-11-05
no longer affects: partitioner (Ubuntu)
Phillip Susi (psusi) wrote :

Closing since this was a misconfiguration that the reporter corrected.

Changed in ubiquity (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers