OEM Mode is not working for Ubuntu Netbook Remix on USB disks

Bug #456990 reported by Ara Pulido on 2009-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity
Invalid
Undecided
Unassigned
ubiquity (Ubuntu)
Critical
Unassigned
usb-creator (Ubuntu)
Critical
Evan

Bug Description

USB disks created with usb-creator will not be able to install in "OEM mode", due to usb-creator incorrectly processing the gfxboot.cfg configuration file.

Original report follows:

Binary package hint: ubiquity

Using Karmic RC image UNR 20091020.2

I select OEM, but the ubiquity installation is a normal one (no OEM batch name, no OEM password).

I will attach the logs as soon as the installation finishes.

Evan (ev) wrote :

This seems to be a bug somewhere around the upstart job as oem-config-firstboot does not run.

Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Evan (ev) wrote :

Actually, I stand corrected. I cannot reproduce this bug here. Ara, just to clarify, are you saying that when you select the OEM option under the F4 menu you get an installer window that does not have the OEM bits (OEM mode title, OEM batch field, default user set to OEM)?

Changed in ubiquity (Ubuntu):
status: Triaged → Incomplete
Ara Pulido (ara) wrote :

Yes, that's what I meant

Ara Pulido (ara) on 2009-10-21
Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
alex (ale-edison) on 2009-10-21
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
Evan (ev) wrote :

This appears to be specific to USB disks created with usb-creator.

Evan (ev) on 2009-10-21
Changed in usb-creator (Ubuntu):
assignee: nobody → Evan Dandrea (evand)
importance: Undecided → Critical
status: New → Triaged
Changed in ubiquity:
status: New → Invalid
summary: - OEM Mode is not working for Ubuntu Netbook Remix
+ OEM Mode is not working for Ubuntu Netbook Remix on USB disks
Evan (ev) on 2009-10-21
Changed in ubiquity (Ubuntu):
status: In Progress → Invalid
Changed in usb-creator (Ubuntu):
status: Triaged → Fix Committed
description: updated
Ara Pulido (ara) on 2009-10-22
Changed in usb-creator (Ubuntu):
milestone: none → ubuntu-9.10
Paul Larson (pwlars) on 2009-10-22
tags: added: ubuntu-unr
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.12

---------------
usb-creator (0.2.12) karmic; urgency=low

  * Properly mount the device when the user requests to open it in a
    file manager (LP: #455199).
  * Blacklist gfxboot.cfg in mangle_syslinux (LP: #456990).

 -- Evan Dandrea <email address hidden> Thu, 22 Oct 2009 12:52:01 +0100

Changed in usb-creator (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers